Rise of the Triad > ROTT '13 > Topic Details
hans Jul 31, 2013 @ 11:18am
Mouse Acceleration/Smoothing Fix [in here]
This fix was used in some unreal engine games, and it actually seems to do the trick in this game.

Go to your steamapps/common/Rise of The Triad/Engine/Config/BaseInput
as well as Users/yourname/mydocuments/mygames/riseofthetriad/rottgame/config/rottinput

Find these lines and replace them:

[Engine.PlayerInput]
LookRightScale=0.000000
LookUpScale=0.000000
bEnableMouseSmoothing=False

Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX Speed=2.0")
Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY Speed=2.0")

Bindings=(Name="LookUp",Command="Axis aLookUp Speed=+25.0 AbsoluteAxis=0")
Bindings=(Name="LookDown",Command="Axis aLookUp Speed=-25.0 AbsoluteAxis=0")

Bindings=(Name="GBA_TurnLeft",Command="Axis aBaseX Speed=-40.0 AbsoluteAxis=0")
Bindings=(Name="GBA_TurnRight",Command="Axis aBaseX Speed=+40.0 AbsoluteAxis=0")
Last edited by hans; Aug 1, 2013 @ 9:06am
Showing 1-15 of 33 comments
< >
hans Jul 31, 2013 @ 11:22am 
let me know if it works for u guys
Jon Jul 31, 2013 @ 3:34pm 
I would say this worked very well. Mouse aiming feels much improved to me.
[DeRp] Fennec Jul 31, 2013 @ 4:28pm 
I confirm this definitely worked for me
HighKillerDK Jul 31, 2013 @ 4:39pm 
I can confirm this clearly did something for me too.
Thegreen Jul 31, 2013 @ 5:21pm 
Do I modify:
Bindings=(Name="TurnLeft",Command="Axis aBaseX Speed=-200.0 AbsoluteAxis=100")
Bindings=(Name="TurnRight",Command="Axis aBaseX Speed=+200.0 AbsoluteAxis=100")

I couldn't find the GBA_Turn.. in the Engine/Config/BaseInput.ini one
RMJ Jul 31, 2013 @ 5:22pm 
This definitely helps. but its still not perfect.

I hope the devs are working on fixed and ingame settings

But thanks for this, at least now its playable. Its hard enough to aim when you running at 90km/h, dont need bad mouse and keyboard controls on top af that :P lol
The Batman Jul 31, 2013 @ 6:54pm 
Replace them with WHAT? What horrid directions.
Last edited by The Batman; Jul 31, 2013 @ 6:54pm
Lee Jul 31, 2013 @ 7:08pm 
can the developer make it changed with a update? why this bug needs to be fixed by players? and it can be difficult to fix that for some players
7MD Jul 31, 2013 @ 7:27pm 
Originally posted by The Batman:
Replace them with WHAT? What horrid directions.

Find those lines, and replace them with the values he has provided. So just copy and paste / overwrite your current values.
Prepare Ur Anus Jul 31, 2013 @ 7:35pm 
Originally posted by The Batman:
Replace them with WHAT? What horrid directions.

imho you're an idiot
7MD Jul 31, 2013 @ 7:51pm 
This does feel a bit different with these changes, but aiming is still laggy at anything below 70fps, and I can only get 70fps while staring at the floor. Thanks for trying :( Hopefully it'll work for most other people though.
Last edited by 7MD; Jul 31, 2013 @ 8:07pm
Willy Jul 31, 2013 @ 8:21pm 
Stone or someone that made the changes

Can someone add meas a friend at Steam and send me the config file with the corrections? I think i made some mistake at the file and messed up

If it won`t be a problem to you guys i`ll be thanktfull

Thanks
purgatory; Jul 31, 2013 @ 8:36pm 
this dont not give true 1to1 mousemovement but its better
Chubzdoomer Jul 31, 2013 @ 8:48pm 
Wow, this feels much better! Thank you!
Sensator Aug 1, 2013 @ 12:14am 
Yeah this isn't 1:1. Really wish there was a raw mouse input or direct mouse input, even with these settings it doesn't feel 'right'. But the settings at least make it playable.
Showing 1-15 of 33 comments
< >
Per page: 15 30 50