Doctor Who: The Eternity Clock

Doctor Who: The Eternity Clock

檢視統計資料:
TylorWayne 2012 年 11 月 17 日 @ 上午 6 時 34 分
stuck on the city streets
I've just come out of the London underground onto the city streets but I can't seem to go anywhere from there. I can scan the button for the elevator in the building but can't seem to interact with that or anything else beyond a scan description. Any idea what to do?
< >
顯示 1-14,共 14 則回應
DaftPound***** 2012 年 11 月 17 日 @ 上午 8 時 23 分 
It's a bug... A ♥♥♥♥ing bug. Sorry :(
Edean 2012 年 11 月 17 日 @ 上午 8 時 47 分 
Press up while standing in the elevator.
NinjaChewie 2012 年 11 月 17 日 @ 上午 8 時 52 分 
just came here to say the same thing :(
Shadow of Avalar 2012 年 11 月 17 日 @ 下午 6 時 18 分 
Yea, the game does a bad job of telling you this. but both people need to stand in the elevator & then you press up or down to move it.
Nohiro: Global Nihilist 2012 年 11 月 17 日 @ 下午 7 時 56 分 
yep, play it with a controller it's more easier ^^
TylorWayne 2012 年 11 月 18 日 @ 上午 12 時 35 分 
I have been playing with a controler. I will try that out.
Mattaf 2012 年 11 月 18 日 @ 上午 10 時 10 分 
I've got the same bug too. The elevator keeps starting to go up, goes about halfway to the next floor and then jumps back down again. Anyone found a solution?
SpiderDalek49 2012 年 11 月 18 日 @ 上午 10 時 56 分 
I had the problem where the lift refuses to go up. The Solution I found was to turn the screen resolution down. solved the problem and the game runs much faster too.
TylorWayne 2012 年 11 月 20 日 @ 下午 9 時 40 分 
So what would be the ideal resolution to play at to avoid glitches?
Anubis 2012 年 11 月 28 日 @ 下午 2 時 13 分 
im the same and its really annoying
Bourgeoisie Destoryer 2012 年 12 月 14 日 @ 下午 10 時 38 分 
i tried 800x600 worked for a bit till i tried to get up another 4th floor
aNgelic_asceNt 2014 年 01 月 12 日 @ 下午 12 時 52 分 
It doesn't work for me i have River and I inside and it goes up partway then goes back down
Knucklan 2014 年 01 月 13 日 @ 上午 1 時 55 分 
Thanks, been stuck on ground level. A simple "press up" an problem solved. Pathetic that I didn't even try that... Thanks!
kewldewd56 03 月 8 日 @ 上午 10 時 40 分 
once both you and river are in the lift, press whatever button signifies up, like w, or something like that, then just go from there, if your still having trouble getting past that area, just go to the far left of the building on the first floor and it should explain what to do from there.
< >
顯示 1-14,共 14 則回應
每頁: 15 30 50