Deester Feb 27, 2013 @ 3:23pm
Game crashes at launch
Anyone of you guys encounter that too? Have no problems running other games incl. Gal Civ 2 from Stardock.

I already did the Steam integrity check and I deleted the game and downloaded it again. Both ideas did not work.

Sad panda...
Showing 1-15 of 46 comments
< >
ratdog17 Feb 27, 2013 @ 3:57pm 
You HAVE to do the Stardock registration. I tried to open it twice without registering, crashed to desktop. I finally registered and it works.
Jᴧgᴧ Feb 27, 2013 @ 3:58pm 
Except that for some of us, registration/activation fails with "invalid serial number".
lindward Feb 27, 2013 @ 4:21pm 
I`ve been using the steam validation number in the stardock serial number slot, still dosen't work
gponto18 Feb 27, 2013 @ 9:15pm 
I have the same problem, it claims to have registered successfully, but now no matter what I do it crashes at launch. I tried it on two different video cards and both crash so I'm assuming its a bad install. Im re-downloadng and installing now and will post my results...
gponto18 Feb 27, 2013 @ 9:32pm 
No help on the re-install, still crashing on startup. No problems with any other games whatsoever, I guess I'll go bug Stardock support...
Mattaui Feb 27, 2013 @ 10:12pm 
This game works fine on my Windows 7 desktop, but when I try running it on my Win 8 laptop, it installs but then won't launch. I've tried all the solutions in the support forum here, so I guess yeah, it's Stardock support time. Let me know if anyone has had this problem and has fixed it. Uninstall/Reinstall didn't work, either.
gponto18 Feb 27, 2013 @ 10:33pm 
Well I'm running Win 7 here and it never worked from purchase earlier today. Zero problems with any other game, application, anything. I emailed support@stardock.com and provided one of the crash files here: "C:\ProgramData\Stardock\Elemental - Fallen Enchantress\FallenEnchantress1_30-2013-02-27T21-42-20_405.zip", I suggest anyone else with this problem do the same until they provide a solution, something tells me one fix will solve everyone's issue.
cleghornalexlee Feb 28, 2013 @ 6:48am 
Mine also fails to register with the Steam Number :( Just purchased today.
suppa Feb 28, 2013 @ 12:57pm 
Same here. It was working fine before the most recent patch.
Mr. Stimpson Feb 28, 2013 @ 1:50pm 
I run Vista. When I load the game up it goes to a black screen and sits for a while. If I ctr-alt-del it, then re-run it, it starts fine.

I turned off the opening cinimatic and it seemed to start fine the first couple times, then it went right back into the old problem.

Outside of that problem, I'm really loving this game. Lots of fun.
Jᴧgᴧ Feb 28, 2013 @ 2:00pm 
Originally posted by cleghornalexlee:
Mine also fails to register with the Steam Number :( Just purchased today.

See the other topic I started regarding invalid serial numbers. There's a fix inside.
Pinkamena Diane Pyro Feb 28, 2013 @ 2:44pm 
Like Steam always does, it forced me to do some patch and now the game doesn't work at all. What the hell?
Deester Mar 1, 2013 @ 7:23am 
Just an update for you guys, I bugged the stardocksupport about it. They offered the "try integrity checking" explanation. After I told them that I already did that and that even reinstalling won't help, they are silent for the last two days now...

Stardock activation worked fine BTW. Still cannot get it to start under win8. :/
Mattaui Mar 1, 2013 @ 1:52pm 
I'm starting to think it's a Win8 problem, then. The best they could tell me to do was run some other program to provide them with a bug log. I think I'll just wait until they patch it, since it's broken in some fashion.
suppa Mar 2, 2013 @ 3:29pm 
I'm on windows 7 and having the issue. Worked fine when I played it months ago.
Showing 1-15 of 46 comments
< >
Per page: 15 30 50
Date Posted: Feb 27, 2013 @ 3:23pm
Posts: 46