Draetor Apr 5, 2013 @ 7:54pm
How do I turn off vsync?
Something I've been trying to do for a while now is turn off vsync for FE. The game suffers from random performance hits (especially after loading in and out of tactical battles and loading saves). My fps could go from 50-60 to 20-25 instantly. Fullscreen didn't help the situation, but maybe upping my fps to make up for the lack of optimization will.

I've tried forcing it off in ATI Catalyst...no go. I also tried disabling throttling in the .ini settings and that didn't work. There were 2 throttle settings I tried, including a combination of both.
Showing 1-5 of 5 comments
< >
^^o^^ BatCat Apr 5, 2013 @ 8:03pm 
Ferget it, it not the graphics thats the problem..

Have a read in "Found fullscreen..." msg' in this base.

Well some is, indirectly. FE runs in Desktop mode, boarderless window or windowed. So any "power saving modes" ADDS to the problem ..but not the source of it.

V-Sysnc ON would give you the smoothest when its availliable and the tip in the above msg'.

Draetor Apr 5, 2013 @ 8:22pm 
I responded to your other thread. However, I remember launching FE one time and the screen suffered from tearing due to obvious v-sync being off. I wasn't running fraps, so I couldn't confirm if it went beyond 60, but the screen was tearing. I have no idea why it was doing it at that time, but I can no longer get the frames above 60.
^^o^^ BatCat Apr 6, 2013 @ 6:35am 
Hrrmmm..

I didn't write the above all that clearly.

V-Sysnc should be on so vid' can let CPU work more on just game data. The game is horribly slow at crunching its own data.

Fullscreen mode should be used and not the default "desktop boarderless window" it uses. This helps convert game data to graphics with a vid'card fully powered up and not in 1/2 power desktop mode. In full power mode it will still get 50% usage or less

SmoOoth when it can do 60fps or more.

Draetor Apr 6, 2013 @ 8:11am 
I've experimented with fullscreen mode. The only way for it to stick is to enable read-only on the INI file. Also, fullscreen does not give me better performance, and my video card still ramps up ay 700 clock in window or fullscreen with the same amount of 50%ish usage.

Now the downside to fullscreen? It's the only time when my game will crash after a certain amount of play time. I don' know if it's because I set the INI to read-only and the game is trying to make changes on the fly....who knows. In regards to what v-sync does...I know. It also causes an fps hit on top of just limiting the fps to 60 due to monitor sync. I just wanted to know if there was a way to turn it off, which you haven't seemed to clarify.
^^o^^ BatCat Apr 6, 2013 @ 10:44am 
Crashes? Check your .ini for "desktopresolution" =0 and "fullscreen" =1, even if you resolution H+W settings is same as the desktop. (H+W should be set to your res')

V-Sync two sets of settings. One in main Vid' control panel setting has Force on/off and "depends".
.ini files has two variables GfxThrottleFrameRate=1 and ThrottleFrameRate=60

Killing V-Sync is not realy going to get you any more except to make this game chug more. Slowing the data crunching. You might get a wee fps boost but then your going to get wilder min and max swings. Less playable I would think. (Less like able?)

You didn't mention desk/laptop and vid' card. Mines ATI 7970 Ghz on Desktop and Phenom II @ 4G. (and 3x 27inch in Eyefinity @ 5760 x 1200)

Those are my settings copied from .ini.
My vid' usage is below 50% now, maybe down to 1/3.
Crashes very rare as I quit/restart somewhere after about 4-6hrs (Coffee/pee/food!)


(Join fellow Canuk in chat, eh)
Last edited by ^^o^^ BatCat; Apr 6, 2013 @ 10:53am
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Apr 5, 2013 @ 7:54pm
Posts: 5