Gateways > General Discussions > Topic Details
danly Jul 11, 2013 @ 12:20pm
Thanks for the Linux port! :D
Just expressing my gratitude.
Showing 1-8 of 8 comments
< >
AAAAAAHHHGAWDHELLP! Jul 11, 2013 @ 7:23pm 
Mine won't run. :(
SmudgedCat  [developer] Jul 12, 2013 @ 2:06am 
What's happening when you try and run it? Do you get any errors displayed at all?

Have you tried running the app from a terminal window to see what output you get?
AAAAAAHHHGAWDHELLP! Jul 12, 2013 @ 5:26am 
Thank you very much for asking!

A window opens that's big enough to fill the screen. It also has a black background. No music plays. It remains solid black. I'm trying to think of why this would happen. It's possible it just can't find the path for the objects to load.

Ran this command in the terminal:

~/.local/share/Steam/SteamApps/common/Gateways$ ./Gateways

Please note that I replaced ID numbers with an "x" character:

EXT_swap_control_tear unsupported. Fall back to standard VSync.
AL lib: alc_initconfig: Failed to initialize backend "pulse"
Setting breakpad minidump AppID = xxxxxx
Steam_SetMinidumpSteamID: Caching Steam ID: xxxxxxxxxxxxxxxxx [API loaded no]

Those aren't too many errors so I suspect I didn't run the correct executable or maybe I didn't run it in the correct way.

I tried running it like this. Not that the ID numbers are replaced with an X char:

$ steam steam://rungameid/xxxxxx
Running Steam on ubuntu 13.04 32-bit
STEAM_RUNTIME is enabled automatically

I'm going to look into finding ways to make this return more errors.

Last edited by AAAAAAHHHGAWDHELLP!; Jul 12, 2013 @ 5:27am
BlaXpirit [UA] Jul 15, 2013 @ 12:27pm 
Yes, thanks from me too!
Never would've thought XNA works so nicely on Linux.
Zhuinden Jul 16, 2013 @ 12:30am 
I think it's because it's not XNA anymore. But Smudged knows this a lot better. :D
SmudgedCat  [developer] Jul 16, 2013 @ 1:21am 
It uses Monogame (http://www.monogame.net) an open source implementation of XNA built on the Mono framework. So, depending on your viewpoint, it kinda is and isn't XNA.
AAAAAAHHHGAWDHELLP! Jul 16, 2013 @ 5:35am 
I installed monogame, via

sudo apt-get install libmonogame-cil

No change.
Last edited by AAAAAAHHHGAWDHELLP!; Jul 16, 2013 @ 5:35am
[Linux] unbridledExüberance Jul 24, 2013 @ 9:43pm 
Do you have pulseaudio installed? The error log indicated that OpenAL failed to connect to the PulseAudio server.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50