Flip™ Aug 7, 2013 @ 1:53pm
5-20 fps on lowest settings with a high-end computer. Please help!
Hey, i just got DIR from the humble bundle and i managed to purchase it twice which has me ♥♥♥♥ed of enough alread. But to the point, when i play the game i get constantly 5-20 FPS at max when im on the lowest settings on everyhing, its barely playable, i've got pretty good computer specs so i cant see why i have any problems with this game.

Specs:
Gigabyte GA-X58A-UD3R
Corsair XMS3 1866MHz 8GB Vengeance CL9
Intel® Core i7-Processor
Gainward GeForce GTX 570 1280MB PhysX


Also, when i tab out halfway out of the game so that i am still in the game but i can see the toolbar and maybe skype or something the framerate on the game in the background is about 80-100+ there has to be something wrong here...

I've already tried the fixes that involved deleting the settings files etc but with no help.
Thanks in advance!
Showing 1-9 of 9 comments
< >
[RUF]Soundcreepy Aug 7, 2013 @ 7:13pm 
hmmm, have you tried running the game in windowed mode then? I have heard some people have issues with certian games in Fullscreen but Windowed works perfectly. Or Borderless windowed mode? (however I think you need a program for that)

Last edited by [RUF]Soundcreepy; Aug 7, 2013 @ 7:14pm
Flip™ Aug 8, 2013 @ 6:22am 
Ah, this seems to solve the problem. Thank you so much!
HenitoKisou Aug 8, 2013 @ 12:46pm 
20 FPS is rich framerate, imagine some people running it with lowest settings with 5-14 and it's still playable for them. ;-)
Flip™ Aug 8, 2013 @ 2:51pm 
What? Below 26 fps the human eye doesnt look at it as a moving picture but more like a slideshow, which means it can't really be enjoyable at all having a powerpoint presentation of dead island
[RUF]Soundcreepy Aug 8, 2013 @ 3:47pm 
Yea, I don't know why fullscreen will sometimes slow a game down. The only game that I have this happen to me is Fable 3, so maybe its just bad ports :(
Flip™ Aug 8, 2013 @ 3:47pm 
Hmm maybe, may be some compatibility with my setup vs the game config or something
qmjs Aug 8, 2013 @ 6:39pm 
Antialiasing has been a problem for some people with this game. There is no direct interface to turn it off, but you can change it yourself. Go into your video.scr (C:\Users\YOURUSERNAME\Documents\Riptide\out\Settings). You may have to right-click and turn off the read-only attribute first.
Open it with notepad and change the FSAA from whatever it is to FSAA(0), that may make a huge difference. I have mine set on absolutely maximum settings, but with antialiasing off, and it runs perfectly.

You can try changing some of the other settings there as well, but do one at a time, and keep track so you can put it back if your changes make things worse.

( I think the Riptide version of the Dead Island Helper may also let you do this... it is a useful tool for a lot of tweaks.)
Last edited by qmjs; Aug 8, 2013 @ 6:40pm
HenitoKisou Aug 9, 2013 @ 2:53pm 
Not really slideshow. Playing with 1-5 is slideshow, at least 9 and it's like slowmo, still, mind and eyes can easily fill the blanks between. I playing many games on 9-14 framerate on low-end laptop and I see difference only when switch to better machine. With better fps however, I react too slow, because when having low framerate you can predict which moves and actions to make on screen before they are rendered. Best example is F.E.A.R. series and this game (Riptide) because it will slow down all animations in-game when framerate is low.
Newtonious Aug 18, 2013 @ 6:40am 
Same, I get problems like this with Fable III, maybe switch to windowed mode? Have you got geforce experience, try optimising. Thats all I can come up with atm sorry!
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Aug 7, 2013 @ 1:53pm
Posts: 9