Mohikan May 1, 2013 @ 12:40am
Black Screen After Character Selection
Hi guys, I've already posted a discussion about this issue, however no one could give me a helping hand. I start the game, after I select or import a character, my screen goes completely black. No sound, no character introduction, nothing. I tried almost everything; reinstalled the game, ran in admin, drivers updated, -nologos is enabled, directx is up to date, I disabled every autorun in MSCONFIG, VSync is off, everything. I still suffer this issue. Please help me guys I really want to play this game. Thank you.
Showing 1-15 of 26 comments
< >
Sandcracka May 1, 2013 @ 12:41am 
Get a new computer.
Mohikan May 1, 2013 @ 12:45am 
If I could understand what is wrong with my computer, I would definitely made some changes.
Sandcracka May 1, 2013 @ 12:50am 
Well for one thing, posting your pc specs would be helpful.
Mohikan May 1, 2013 @ 1:06am 
PainX May 1, 2013 @ 1:12am 
Originally posted by Mohikan:
http://www.mediafire.com/view/?4nm5e3nncg42azn here is my pc specs

should be fine my m8 is running this on his ancient 2ghz with a 512mb gfx and 3gb ram how ever maybe you could try using DIR Helper it has 2 black screen fixes not sure they will help as its still work in progress but its worth a go i reckon

Linky
http://steamcommunity.com/app/216250/discussions/0/828937261940292800/
Mohikan May 1, 2013 @ 1:14am 
I tried them both but it didnt work...
Sandcracka May 1, 2013 @ 1:20am 
Right click on your game in steam, select Properties. Go to the Local Files tab. Verify integrity of game cache. If it downloads anything, restart steam afterwards.

When was the last time you updated your video card drivers? Have you defragged your hard drive recently? How long has it been since you did a fresh install of windows?
PainX May 1, 2013 @ 1:57am 
Originally posted by Mohikan:
I tried them both but it didnt work...
to bad :( unfortunately this is one of those bugs both riptide and dead island share for some people
Mohikan May 1, 2013 @ 3:22am 
my video card drivers are up to date, I updated them 2 days ago, no I didn't defrag my hard drive. I didn't refresh my windows since I bought this computer.
Mohikan May 1, 2013 @ 8:59am 
any advices ?
Deady May 1, 2013 @ 4:06pm 
Lol got this bug too and I was playing john happily until after the 7.1 sound patch, thats when I got this bug...
Mohikan May 2, 2013 @ 7:01am 
it is insoluble bro, i am planning to refund my money somehow and will buy to ps3...
Deady May 2, 2013 @ 1:44pm 
I Know right this is pretty unexcuseable, Paid for it fully knowing my computer specs pass minimum requirements to play and I cannot even play past character selection screen
Mohikan May 2, 2013 @ 3:53pm 
Thats right...
ZaGaPonG May 3, 2013 @ 12:05pm 
Same problem here with I7 2.2, 8G Ram, Radeon HD 6600m

-_-
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: May 1, 2013 @ 12:40am
Posts: 26