RabidTweak Apr 27, 2013 @ 4:53am
Dead Island Riptide Crash at Startup
I recently purchased Dead Island Riptide from steam this included the Original Dead Island as well for $40.
The original Dead Island's intro videos are black, I can only hear sound and after the intro finishes then the game crashes.
Dead Island Riptide crashes immediately after executing.

My system's specs are:
Windows 8 64 bit
Intel I5 2500 3.30GHz
8 GB Memory (RAM)
Geforce GTX 560 TI 4GB

What I have tried thus far:
Verified the Integrity of Game cache on both games 3 times via steam.
Installed all 3 redistributables in the Redist folder of Riptide's game directory and restarted.
Tried running both as Administrator via right click.
Tried changing Sound settings to 48000 Hz.
Tried both on Compatabilty modes for Windows 7 and then on XP Service pack 3.
Downloaded latest NVIDIA drivers and installed GeForce 320.00, the one with the Dead Island Update and restarted.
Disabled Firewall and Antivirus - Avast Free
Set Launch Options via steam with the flag "-nologos", read this might work, didn't.
Tried disabling Windows UAC and tried with AUC on.
Deleted Dead Island's "Video.src" file at "Documents\DeadIsland\out\Settings\Video.src", Riptide doesn't have a Settings directory under "Documents\Riptide\out\" directory.
The "Video.src" file is then recreated, read this might fix the problem on a different forum, did not work for me...

The Riptide Crash.log ends with _______________
ERRR: Missing mesh: blood_pp.msh
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'blood_pp&0000.mat' - using default!
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'mission_failed&0000.mat' - using default!
ERRR: Missing mesh: scope_pp_cross_0.msh
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'scope_pp_cross&0000.mat' - using default!
ERRR: Missing mesh: scope_pp_cross_1.msh
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'scope_pp_cross&0000.mat' - using default!
ERRR: Missing mesh: scope_pp_cross_2.msh
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'scope_pp_cross&0000.mat' - using default!
ERRR: Missing mesh: scope_pp_cross_3.msh
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'scope_pp_cross&0000.mat' - using default!
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'copy_srgb&0000.mat' - using default!
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'copy_gamma_win&0000.mat' - using default!
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'p_extents_stencil_fill&0000.mat' - using default!
WARN: [CMaterialMgr::_LoadMaterial] Cannot load material 'p_extents_stencil_clear&0000.mat' - using default!
ERRR: Missing mesh: bbox.msh
_________________________________________________


GAME FIXED - SEE INSTRUCTION BELOW

Moved my Dead Island Riptide folder to it's default installation path under the c: drive "C:\Program Files (x86)\Steam\SteamApps\common\diriptide"
External hard drives containing the game will not work, it must be placed in it's default installation path under your c: drive. It can then be launched from "C:\Program Files (x86)\Steam\SteamApps\common\diriptide\DeadIslandGame_x86_rwdi.exe"

ALSO NOTE

If you are using an Nvidia GFX card, get the latest drivers, thay have additional support built in for this game.
Last edited by RabidTweak; May 20, 2013 @ 8:53am
Showing 1-15 of 15 comments
< >
BUTTER YOUR MUFFINS May 17, 2013 @ 1:14pm 
I have the same problem too. but may I ask did u install this game in ur external drive?
cos I happened to have this game in my internal then I moved it to ext and this happens. Still, im waiting for a solution here because all my steam games are in my external.
BUTTER YOUR MUFFINS May 17, 2013 @ 11:59pm 
any kind souls help us with this issue here?
mgsmith02 May 18, 2013 @ 4:02am 
If this game's not on your C: drive it can cause all sorts of weird issues (like the above). I too had mine on a separate drive and crash city, then move it to C: and it's fine. The first game was the same for me also.... Or if your My Documents folder doesn't have admin permissions or is on a networked drive...
Last edited by mgsmith02; May 18, 2013 @ 4:03am
Juanan May 18, 2013 @ 4:05am 
Install Windows Media Player
DonkyBoY May 18, 2013 @ 4:34am 
Is windows media player not part of windows 8
BUTTER YOUR MUFFINS May 19, 2013 @ 12:02am 
yes im running this game on external any idea how to get it to work?
DonkyBoY May 19, 2013 @ 12:50am 
Originally posted by BUTTER YOUR MUFFINS:
yes im running this game on external any idea how to get it to work?

well let me see you had it on your internal and it worked then moved it to your external and it didnt work. hmmmmmm let me do the math ALAA-KAAA-ZAAAMMM = putting it back on the internal should fix it !!!!!!!!

Originally posted by BUTTER YOUR MUFFINS:
cos I happened to have this game in my internal then I moved it to ext and this happens. Still, im waiting for a solution here because all my steam games are in my external.

as mgsmith02 has already pointed out to you

Originally posted by mgsmith02:
If this game's not on your C: drive it can cause all sorts of weird issues (like the above). I too had mine on a separate drive and crash city, then move it to C: and it's fine. The first game was the same for me also.... Or if your My Documents folder doesn't have admin permissions or is on a networked drive...

do you see.
Last edited by DonkyBoY; May 19, 2013 @ 12:56am
BUTTER YOUR MUFFINS May 19, 2013 @ 3:01am 
im asking whether there is a solution to work it on external bro. because im running all my steam games on external except to get this game to work
BUTTER YOUR MUFFINS May 19, 2013 @ 7:01am 
up
BUTTER YOUR MUFFINS May 19, 2013 @ 9:58am 
sad
hashlyn May 19, 2013 @ 11:35am 
Yes mine keeps crashing instantly after start up and says EXIT:FATAL ERROR Cannot initialize renderer
sourrain May 19, 2013 @ 2:24pm 
ye, have that problem sometimes
RabidTweak May 20, 2013 @ 8:47am 
There is currently no other way to get this issue resolved other than placing it on your c: drive. Also please get all the latest drivers etc etc I know for a fact that Nvidia released drivers specifically for RipTide, so if youre running a Geforce card go get the driver.
Tμpp#b0X Jul 9 @ 11:00am 
maybe i got a solution
i just configured it but by a strange way it download all again... but at least this doesnt matter for you

so in windows you can make directory linkage where explorer its self doesnt notice the real physical savepoint
the tool is called mklink
so you start a command prompt with administrative rights
change to the direcotry (common), where the linkage should be created
use for this the command cd (change directory) and tab for auto complete

so you have to use the parameter /j

here a short example
C:\Program Files (x86)\Steam\SteamApps\common>mklink /j diriptide Q:\SteamLibrar
y\SteamApps\common\diriptide
Verbindung erstellt für (connection created for) diriptide <<===>> Q:\SteamLibrary\SteamApps\common\dirip
tide
for more information ask search machine as always

but now i have to download it again....beacause of that i cant tell you if that works
DonkyBoY Jul 10 @ 5:04pm 
why dont you just put it back on your C: drive you can have multiple steam librarys in multiple locations just keep one on your C: drive for games that are fussy and dont like to be on other drive's.

This would solve the problem and you wouldnt need a fix.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Apr 27, 2013 @ 4:53am
Posts: 15