Zeno Clash 2 > General Discussions > Topic Details
Lobo May 1, 2013 @ 5:35pm
Game Thinks That There Is a Controller Plugged In
Howdy,

As soon as I start the campaign or tutorial, my view will NOT stop spinning in a circle. I had this problem with Bioshock Infinite, and had to disable controller input in the .ini file; however, I do not see such an option for ZC2.

I have never had a controller plugged in to my system, so I do not know what could be causing the problem.

Thanks for your time.
Showing 1-15 of 27 comments
< >
[ACE] abordeu  [developer] May 1, 2013 @ 6:57pm 
Strange issue. Bioshock Infinite is also an UE3 game. Seems to be something with your system. What ini info did you change so I can consult with the tech team tomorrow? Someone else having this issue?
Lobo May 1, 2013 @ 8:04pm 
I tried editing the .ini files in the actual game directory for ZC2.

"\Steam\steamapps\common\Zeno Clash 2\ZC2Game\Config"

As for bioshock 2, it was in

"Administrator\Documents\my games\BioShock Infinite\XGame\Config"

Unfortunately, I cannot remember the value that I edited, and Google isn't bringing me any luck. I remember I either had to add something, or set something to "0" or "FALSE" in the Bioshock config file, but I can't remember what the function was called for the life of me...
Lobo May 2, 2013 @ 6:29pm 
Any update on this?

I'm the biggest fan of ZC1, and I can't even play the sequel that I waited so long for.

Does anyone know the command I must input in the .ini file to disable controller input for the Unreal 3 engine?
Lobo May 3, 2013 @ 12:23pm 
I tried adding "AllowJoystickInput=0" in to every .ini/.cfg file for this game with no luck. I even tried disabling any virtual cotnrollers, like Unified Remote, still no luck.

Please help me. I want to play this game...
BEAN May 3, 2013 @ 1:15pm 
Have you checked your input/interface device drivers?
Also, if you are using a spiffy kb/mouse... have you checked its software to determine wether there may be a mapping issue or something of the like?
What direction does the game spin towards? left-right-up-down?
Can you move at all? or is the spinning command overriding your direct input?
Have you tried using a controller to see if the issue persists WHILE a controller is present?

sorry for the 20 questions, but it may help diagnose and fix this issue :D
Lobo May 3, 2013 @ 1:50pm 
I am using a Razr Mamba, but the same issue occurs when the mouse is physically plugged in.

I checked my device manager, and there are no controllers/joysticks present.

I can move around, but my camera keeps spinning up, and to the left.

Thanks for the reply!
BEAN May 3, 2013 @ 2:10pm 
that's certainly odd...

Im also using a mamba btw so i doubt that it could be a driver or compatibility issue
and the fact that it has occured with other unreal 3 games is weirder... bio inf worked fine for me as well...

info for my mamba
firmware vers: 1.07
driver version 2.01

let's rule out the mouse...
Lobo May 5, 2013 @ 6:22pm 
No change...

Anybody have any other suggestions..?
Lobo May 8, 2013 @ 4:46pm 
Anyone? Would be nice to play the game I paid for...
Ver May 10, 2013 @ 4:44pm 
Originally posted by ACE abordeu:
Someone else having this issue?
I have this issue too - screen is constantly spinning to the left.
Ver May 11, 2013 @ 3:05am 
Originally posted by Lobo:
Anyone? Would be nice to play the game I paid for...
I found a solution which worked for me. I installed and plugged my PS3 controller using this drivers and instruction: http://forums.pcsx2.net/Thread-XInput-Wrapper-for-DS3-and-Play-com-USB-Dual-DS2-Controller
Then I started game with controller - it worked. Than quit, unplugged controller and started game again - it is working so far with the keyboard.
Lobo May 11, 2013 @ 11:31am 
I don't have a PS3 controller to try that, so I tried my old wired Xbox 360 controller instead.

My computer detected it and installed all the drivers and such, but when I tried to play Zenoclash 2, it didn't even detect my controller and just kept spinning in circles again...
Ver May 11, 2013 @ 1:37pm 
Maybe install new Xbox drivers from here (get suitable for your system): http://www.microsoft.com/hardware/en-us/d/xbox-360-controller-for-windows
tschumann May 11, 2013 @ 6:50pm 
Maybe try unplugging all input devices from the computer.
SupernastyPants May 12, 2013 @ 8:44am 
Sounds like you are running some emulator input program that is running in the background.

Open up task manager and look for any programs that shouldn't be running, end the process(es). Start the game and see what comes of it.
Showing 1-15 of 27 comments
< >
Per page: 15 30 50