Home > Home - Technical Support > Topic Details
Molex Oct 26, 2012 @ 3:27pm
Can't control the character
Just got the game and I'm really excited to play. When I start the game and get to the menu screen to press A, I can't. If I press spacebar I can get into the game. After that I can't control the character.

Would love to play this awesome looking game!
Showing 1-9 of 9 comments
< >
Lestrade  [developer] Oct 27, 2012 @ 10:39am 
Hi Molex:

Did you have a joystick (especially an Xbox 360 pad) plugged in at the time? Do you have any keymapping software (JoyToKey, etc.) installed? It sounds like the game is recognizing a joystick, even though you weren't trying to play with one.

Let me know if these keyboard controls allow you to play the game (even if the game is showing you prompts for Xbox buttons):

Left and right arrows: move left and right
Up arrow: look up
Y key: choose "Yes"
N key" choose "No"
Right arrow (when in a text screen): speed up text
Down arrow (text screen): continue
ESC: quite game
F4: toggle full-screen/windowed modes

Thanks,
B.
Shadowritter Oct 28, 2012 @ 6:40am 
Same's here, with the controller unplugged (a PS1 to USB), I can move the character with keyboard, but I can't pass the text, I have to press ESC then NO to pass the first 2 texts
Molex Oct 28, 2012 @ 11:33am 
I was able to get my Xbox controller to work. The problem was a joystick that had preinstalled drivers messing with the game. Also just finished the game, awesome work! Love the story and I plan on telling everyone to get this game!
Lestrade  [developer] Oct 29, 2012 @ 9:25am 
Molex: Great, thanks for the update, and glad you enjoyed the game!

Shadowritter: The game only officially supports the Xbox 360 email, so please try using one of those, or an Xinput-compatible controller to see.

If you unplug your controller, you should see all the in-game prompts for keyboard controls (it should say "Press Space," instead of "Press [ A ]," for example.
Shadowritter Oct 29, 2012 @ 2:04pm 
That's the problem, without controller Space does nothing (in game ok, but with a text, only ESC work)
Lestrade  [developer] Oct 31, 2012 @ 1:47pm 
Oh, I see! Space doesn't do anything in the text boxes (it's a weird conflict; don't ask!). Here again are the keyboard controls. Please note the controls in bold:

Left and right arrows: move left and right
Up arrow: look up
Y key: choose "Yes"
N key" choose "No"
Right arrow (when in a text screen): speed up text
Down arrow (text screen): continue

ESC: quit game
F4: toggle full-screen/windowed modes
Shadowritter Nov 2, 2012 @ 12:09am 
Thanks, it works, now I will check the game running slow topic ^^
­North Nov 26, 2012 @ 4:58pm 
Hi, Lestrade!

Home looks really awesome, but I can't play it because of this glitch. Unplugging my gamepad and closing the control panel for it doesn't fix this issue; Home still detects the drivers and runs in Gamepad mode. It'd be nice to mayhaps have an options screen, or an alternate application to run that ONLY runs in Keyboard mode, and disregards joysticks or gamepads. Some way to tell Home to stop trying to play via a gamepad.

Thanks.

EDIT: I should clarify; Even with the controller unplugged and the control application for the controller exited fully, the game still detects that I have a joystick plugged in. Also, for some reason, while the game is open, my computer acts as if I'm holding down the up arrow at all times. Even if the game loses focus, the up arrow is held down. (This stops when I close the game.)
Lestrade  [developer] Dec 10, 2012 @ 7:50am 
Hi North, really sorry for the late reply; these topics don't always seems to correctly alert me when there's a new post.

I will take your suggestion into serious consideration; I think the issue is stemming from Game Maker's less-than-amazing gamepad support. There are bugs that they don't necessarily disclose nor fix.

Since I'm porting the game over to the newest version of Game Maker (Studio), I'm hoping I can optimize and correct a lot of this.

Thanks,
B.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50