Home
Swymco Aug 8, 2013 @ 7:13am
Will this run on Mac 10.6.8?
I'm unable to upgrade my machine to 10.8 and the Store Page says the min Mac OS is 10.7.

I was wondering if someone knows if this will run on 10.6? If it does I will certainly buy it.
< >
Showing 1-5 of 5 comments
jaydot Aug 8, 2013 @ 11:04am 
Also wondering about this.
Carlos Coen Aug 8, 2013 @ 3:45pm 
yeah, it works
Swymco Aug 8, 2013 @ 5:17pm 
Thanks for letting me know.
Lestrade  [developer] Aug 11, 2013 @ 4:31am 
Whoa, really?
Nostapricorn Nov 19, 2015 @ 4:17pm 
no it doesn't not anymore D:
< >
Showing 1-5 of 5 comments
Per page: 15 30 50