The Atomic Ass Aug 2, 2013 @ 6:18am
[Linux] Crash when entering the gremlin's house
When Ivo enters the gremlin's house, (shortly after Wilbur takes off in the rocket), the game crashes. I'm running Ubuntu 13.04, with the 12.04 "RenderSystem_GL.so" so that I can access the settings menu.
Showing 1-15 of 34 comments
< >
Grigi Aug 3, 2013 @ 12:18pm 
I have a crash on exactly the same spot. Tried with every permutation of graphics settins that I can, and it crashes on all of them.
Running gentoo with fglrx.
When I run the game from the console to get an error log, the last few rows are this:

Mesh: Loading co_items_kueche.mesh.
Mesh: Loading co_items_ofen.mesh.
Mesh: Loading co_items_leuchtqualle.mesh.
Mesh: Loading co_items_buecherschrank.mesh.
Mesh: Loading cm_haus_des_gremlins_innen.mesh.
Mesh: Loading co_items_drachenschaedel.mesh.
Mesh: Loading ao_kiste.mesh.
Mesh: Loading nm_haus_des_gremlins_innen.mesh.
Mesh: Loading nm_haus_des_gremlins_innen_loch.mesh.
Skeleton: Loading elfe_gremlinhaus_innen.skeleton
Mesh: Loading ao_strahl_tuer_spiegel.mesh.
Mesh: Loading ao_strahl_spiegel_keller.mesh.
./bout.sh: line 8: 6101 Segmentation fault LD_LIBRARY_PATH=$BASE_LIB_PATH/$BITS/:$LD_LIBRARY_PATH $BASE_BIN_PATH/$BITS/$EXE_NAME


If you need more info, please ask.
The Atomic Ass Aug 4, 2013 @ 4:45am 
An update on this: the crash happens on my desktop with an AMD HD 7850 graphics card, running the latest beta drivers. I cannot replicate the crash on my laptop, which has Intel Sandybridge (HD 3000) graphics.

I also cannot run bout.sh to get a similar crash log, as the game never even starts, with the following error:
% ./bout.sh
./bin/32/kAGE: error while loading shared libraries: libXaw.so.7: cannot open shared object file: No such file or directory

I also sync my game saves between my laptop and desktop, and loading the game save from inside the gremlin's house on the desktop gives about 0.3 seconds view of the inside of the house before the game crashes.
Last edited by The Atomic Ass; Aug 4, 2013 @ 5:01am
Grigi Aug 4, 2013 @ 11:11am 
I have an AMD Mobility 7770, both our cards are SI (Southern Islands) generation cards. I wonder if the issue only happend in this situation?
Currently I'm running the 13.6beta drivers. I'll try different ones now, and report back.
Grigi Aug 4, 2013 @ 11:58am 
And the issue doesn't happen with the 13.4 Catalyst drivers... If that helps?
The Atomic Ass Aug 6, 2013 @ 12:06pm 
Haven't tried the 13.4 drivers yet... Will give them a try shortly.
The Atomic Ass Aug 9, 2013 @ 5:35pm 
Well the 13.4 drivers allow the game to work, at the expense of 50% of my graphics performance. :/ (13.6 beta drivers were giving me a glmark2 score of double what 13.4 drivers do)
Grigi Aug 14, 2013 @ 11:49am 
heh, my plan is to stick with the 13.4 drivers until I finished the book of unwritten tales.
hopefully by that time there will be the next better driver :-)
Either way, I suspect this is caused by the usual dodgy and not-quite-valid shaders generated by Cg.
RadicalPi Sep 6, 2013 @ 7:10pm 
I have this same issue. Fedora 19 x86_64 with AMD HD 6950 and the 13.8 Beta 2 Drivers.
Grigi Sep 7, 2013 @ 8:30am 
using the 13.4 non-beta drivers, I completely finished the game and its expansion.
RadicalPi Sep 7, 2013 @ 8:37am 
I guess I'll have to wait and see if I can fiish the game once the drivers are out of Beta. I can't downgrade because only the 13.8 Drivers support 3.10+ Kernels.
madhi19 Sep 9, 2013 @ 11:55am 
Any idea if these issues are AMD only. Meaning is my Nividia card affected?
Grigi Sep 10, 2013 @ 9:38pm 
I think it is only on AMD beta 13.6+ drivers, on 6900 + 7000 series cards.
The little investigation I have done is that Cg is generating somewhat invalid shaders (granted, you should have one shader that is not rendered instead of a crash).

On Nvidia cards there is another issue with the game crashing if you go into settings. There is some person whom uploaded fixed ogre libraries for this game (somewhre on this forums) and its expansion, and apparently it works great after that. The settings issue doesn't happen on AMD cards.

Unfortunately it does seem like the game could probably get some fixing, but once you have everything you need up, it is a pretty fun game :-)
Lord Ocryd Sep 14, 2013 @ 9:26am 
Is there any hope of getting this fixed?
The Atomic Ass Sep 14, 2013 @ 6:11pm 
Originally posted by Lord Ocryd:
Is there any hope of getting this fixed?
The crash at the Gremlin's house is mostly up to the graphics drivers.

The crash at the settings dialog can be rectified by installing the 32-bit library mentioned in this thread: http://steamcommunity.com/app/215160/discussions/0/864961721980400994/#c828936718796946595

Wasn't sure which issue you were referring to.
Lord Ocryd Sep 15, 2013 @ 2:08pm 
This thread is titled: [Linux] Crash when entering the gremlin's house, so this is an issue I was referring to.

I would expect the game to function properly with the graphic drivers commonly used, which work with everything else and if it does not, I would consider it a bug which I would expect to be fixed by the developer.

I am surprised that there is no word from the developer at all on this.
Showing 1-15 of 34 comments
< >
Per page: 15 30 50