DeadWire Jul 13, 2013 @ 3:54am
Linux version "Settings" crash
The game crashes instantly, when I try to click on settings in the menu.

Ubuntu 13.04 AMD64
i5 ivy
660ti
Last edited by DeadWire; Jul 13, 2013 @ 4:04am
Showing 1-15 of 16 comments
< >
NoXPhasma Jul 16, 2013 @ 7:49pm 
I can confirm that, it crashes directly to the desktop when I click on settings in main menu. I have searched in the the gane folkders, but there is no log file :(

Linux Mint 13 x64
AMD Phenom X4 965
NVidia GTX 660

Can you take a look into this error please

*edit*
I have started the bout.sh on terminal, when I click on settings the game crashes with this message:
Segmentation fault (core dumped)

*edit2*
Found out its related to the RenderSystem_GL.so in lib/32 folder, on x64 system you can't install a 32 version of libogre-1.7.4 out of the repository, but I found on this topic in last post a link with the right file: http://steamcommunity.com/app/221410/discussions/3/846939071103394100/#p2

Now I can get to the settings.

To the devs: you should take a closer look into this, it is not good that we customer have to fix your bugs ;)

And this same error appears in The Critter Chronicles.
Last edited by NoXPhasma; Jul 16, 2013 @ 9:06pm
menaKer Jul 24, 2013 @ 4:36am 
apparently the problem is out there for a good six months, still without a proper fix by the developers..

Thanks to the community for the handmade solution !
Last edited by menaKer; Jul 24, 2013 @ 4:36am
DeadWire Jul 24, 2013 @ 1:42pm 
Originally posted by menaKer:
apparently the problem is out there for a good six months, still without a proper fix by the developers..

Thanks to the community for the handmade solution !

Indeed, but the dev still needs fix this, and the fact that the community is awsome doesn't let them off the hook.
Last edited by DeadWire; Jul 24, 2013 @ 1:42pm
noccy Jul 25, 2013 @ 4:26pm 
Still haven't been able to launch the game, even by dropping a new .so in place as it leaves me with garbled textures instead so have no clue what to click. Would be nice to have this game working :)
Bitxa Jul 26, 2013 @ 6:20am 
I downloaded the file, but I'm not sure what I have to do with it...

Originally posted by NoXPhasma:

*edit2*
Found out its related to the RenderSystem_GL.so in lib/32 folder, on x64 system you can't install a 32 version of libogre-1.7.4 out of the repository, but I found on this topic in last post a link with the right file: http://steamcommunity.com/app/221410/discussions/3/846939071103394100/#p2
DeadWire Jul 26, 2013 @ 5:15pm 
Originally posted by Bitxita:
I downloaded the file, but I'm not sure what I have to do with it...

Originally posted by NoXPhasma:

*edit2*
Found out its related to the RenderSystem_GL.so in lib/32 folder, on x64 system you can't install a 32 version of libogre-1.7.4 out of the repository, but I found on this topic in last post a link with the right file: http://steamcommunity.com/app/221410/discussions/3/846939071103394100/#p2

Go to your local files, and replace the ones there with the ones in the zip (lib32).
Last edited by DeadWire; Jul 26, 2013 @ 5:18pm
Bitxa Jul 27, 2013 @ 6:31am 
I just don't know wich local files I have to replace... sorry, I don't know much about linux...
DeadWire Jul 27, 2013 @ 1:37pm 
Originally posted by Bitxita:
I just don't know wich local files I have to replace... sorry, I don't know much about linux...

Just like the windows client, the Linux version of Steam lets you browse local files...just right click on the game then 'properties' and go to the 'BOWSE LOCAL FILES' tab then you should be in your games install folder there should be a file with the same name as the one you extracted form the zip file, replace it with the downloaded file.
Bitxa Jul 28, 2013 @ 12:20am 
Thanks, now I can get to the settings :)

Originally posted by Dead Wire:
Originally posted by Bitxita:
I just don't know wich local files I have to replace... sorry, I don't know much about linux...

Just like the windows client, the Linux version of Steam lets you browse local files...just right click on the game then 'properties' and go to the 'BOWSE LOCAL FILES' tab then you should be in your games install folder there should be a file with the same name as the one you extracted form the zip file, replace it with the downloaded file.
PsioN Oct 1, 2013 @ 10:22am 
It's October and the bug is still there... Thank you all for finding a fix!
Allsor_Sykes Oct 14, 2013 @ 3:08am 
@NoXPhasma: Thanks for the tipp. It was very helpful.
MaximB Oct 15, 2013 @ 9:33am 
The "settings" no longer crush BUT when I try to set the resolution higher to the normal 1680x1050 the settings doesn't save and return to the lower resolution.

P.S
This problem doesn't happen in The Critter Chronicles nor The Raven.

Last edited by MaximB; Oct 15, 2013 @ 10:20pm
VENDETTA Jun 5 @ 3:54pm 
Installed today, still crashing when entering settings. Needed to fix it manually :/
stan Jun 6 @ 2:55pm 
Same crash on Arch Linux 64 bit, nvidia. I should have read the forums before I bought the game… :(
MaximB Jun 7 @ 1:41pm 
Can you please fix this bug?
It was fine before and something broke it, please fix it...it's been several months already.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50