Intrusion 2 > General Discussions > Topic Details
Ianforcements Mar 24, 2013 @ 9:57pm
Terrible performance issues.
I am having an awful time trying to play this game. It is running excruciatingly slow.

Running the game on:

Windows 8 Pro x64
AMD Phenom II 1090T Black Hexcore @ 3.5Ghz
8Gb DDR3 1333 RAM
AMD Radeon HD 6950 2Gb
WD Caviar black 640Gb 7200rpm HDD
Xbox 360 controller for Windows

Can't think of any reason why it would be slow. It's expecially bad in full screen mode, but it even lags in its tiny little windowed mode. I'm able to play other flash based games with no issues.

Also, I freshly secure deleted my ssd and re-installed Windows this morning, and the game is a fresh install.

Anyone have any tips?
Showing 1-8 of 8 comments
< >
[BoS] Old World Vulture Apr 6, 2013 @ 2:46pm 
It seems this game is locked at 30fps, making it seem sluggish (but still playable). Is your framerate around this or even lower? I'm not aware of any available framerate unlocks at the moment but would definitely welcome one :)
Chance Apr 11, 2013 @ 6:27pm 
my pc runs it at 29 fps the game was made with flash not your fault bro best i can tell you dont play it on full screen its a very incosistent game quite honestley
[2spooky4me] Burn3dRobot Oct 9, 2013 @ 1:27pm 
I have an computer that could run bf3 on high 60 fpss no problem but barely runs this a 30 fps.
Shadow Spark Oct 22, 2013 @ 2:01pm 
I have a ♥♥♥♥ty laptop that can't run tf2 playably.... This runs fine.... So i don't know whats going on there...
Last edited by Shadow Spark; Oct 22, 2013 @ 2:01pm
SimonG Oct 29, 2013 @ 12:50pm 
This still isn't fixed? What a waste of money ...
Nebujin383 (Untamed) Jun 21 @ 4:00pm 
PPL, this is a possible fix for "everyone" make sure your energysaving settings are set to balanced or high settings. Powersaving slows flash files, or flash based games, down drastically. I was using powersaving settings, and the game was slowing down and even lagging massivly, after setting the energysaving settings to balanced i am fine now, depending on your system high instead of balanced could be recommended. Hope this fixes the issue for everyone who bought the Indie 8 Bundle, or the game itself.
Shadow Spark Jun 21 @ 4:16pm 
Originally posted by Nebujin383 (Untamed):
PPL, this is a possible fix for "everyone" make sure your energysaving settings are set to balanced or high settings. Powersaving slows flash files, or flash based games, down drastically. I was using powersaving settings, and the game was slowing down and even lagging massivly, after setting the energysaving settings to balanced i am fine now, depending on your system high instead of balanced could be recommended. Hope this fixes the issue for everyone who bought the Indie 8 Bundle, or the game itself.


Nice necro m8...
Nebujin383 (Untamed) Jun 21 @ 4:23pm 
Hey Dude .... i just recently bought this Game and was about to finish it yesterday the first time ever. The lags made the last Bossfight impossible, so ive been searching for a fix.... guess what.... the whole Net didnt have a fix for this :S I use(d) power saving settings for a reason, and before today i was clueless that this would cause Flashfiles to lag like this. Since no one ever shared a fix for this, i felt free to do so <3
Showing 1-8 of 8 comments
< >
Per page: 15 30 50