Total War: ROME II - Emperor Edition

View Stats:
Poita Sep 5, 2013 @ 9:20pm
Rome 2 won't launch
Just built a new PC. It's running fine. I just finished downloading Rome 2 here on Steam but when I run the game (for the first time) it just goes to a red square that doesn't take up the whole screen (just the centre) with the Rome 2 images on it and the little rotating circle (loading animation) goes round and round and the game won't go any further.
At first I thought it was unpacking or configuring the downloaded content but it goes on for a long time. I can't get out with escape so I have to ctrl,Alt,Del and a box says 'Rome 2 not responding.
I updated my gaphics card drivers so I don't know what the problem is.

My system is
16gig ram
Core i7
GTX 670
Showing 1-15 of 17 comments
< >
Augustus XXX Sep 5, 2013 @ 9:42pm 
i had all most the same issue after i finished the download, i search online and found a fix which work for me. Under Rome 2 properties i verify integrity the game cache which found three missing files. After the three files were downloaded the game work, i don't know if this helps with you issue but give it a try.
Poita Sep 5, 2013 @ 9:46pm 
Thanks Augustus but I don't really understand your instruction.
Where do I find 'Rome 2 properties'? Is in in the Steam interface or do I look in my computer?
I don't know what 'verify integrity the game cache' means?
If there are three missing files and I need to download them then where do I get them from and how do I know what they are if they are missing?
Augustus XXX Sep 5, 2013 @ 9:59pm 
If you go to your Steam Library where all you games are listed you see Rome 2. If you right click on rome 2 a list will appear and you will see properties last on the list. Click on that and a box with about six tab will pop up, the tab that has local file listed is were you will find the verify integrity cache. What this does for any game is if you have a game with issues this will verify the files and if anything is missing should download the files
Zynth Sep 5, 2013 @ 10:01pm 
right click rome 2
move your cursor down to the properties option
in the new window that opens, for the rome 2 properties, go to the third tab
there is a button there that will 'verify integrity of the game chache'

If you are like many of us, this will not work. It's still good to try, but I have tried everything under the sun, with no luck.
Metoo I cant even launch the game. There is a window showing rm2 stop working. ♥♥♥ that
RVM Ent.Hoaviệt Sep 5, 2013 @ 10:24pm 
Yeah me too, I did the verity integerity of cache and have to download 800 MB!!, honestly the pirated version doesn't have these ♥♥♥♥♥ problems
RVM Ent.Hoaviệt Sep 5, 2013 @ 10:31pm 
"For those who get stuck at the Sega logo screen, follow these steps:

1-
C:UsersAdministrador (or whatever your admin account name is) AppDataRoamingThe Creative AssemblyRome2 (AppData it's hidden)

If you don't find the folder of "AppData"

just search the Folder "Rome" with Ctrl +F will appear Rome2.

Delete the folder Rome2 completly


2-

When we erase that folder we go to.

C:Program Files (x86)SteamSteamAppscommonTotal War Rome IIredist

And we execute and repair(it will appear the option don't worry):

vcredist_x86-90.exe
vcredist_x86-100-sp1.exe
vcredist_x86-80-sp1.exe

And it's done!

Hope you all fix it."

Not sure if these works but try it and report back.
Poita Sep 5, 2013 @ 10:32pm 
Thanks Augustus. I validated them and there are none missing.

RVM I'll try that. Thanks.
Kampsaiyan Sep 5, 2013 @ 10:35pm 
uninstall and reinstall? That might help if you haven't already tried that (:
Poita Sep 5, 2013 @ 10:44pm 
RVM I deleted the folder but still get stuck on the Sega launch screen. I'll see if it crashes after a re start. If so Ill delete the content and try a re install.

Poita Sep 5, 2013 @ 10:45pm 
I have to say, after pre purchasing Rome 2 and building a £1,600 PC it's a pain in the ♥♥♥ that the game won't actually work.
Kampsaiyan Sep 5, 2013 @ 10:51pm 
Poita, have you uninstalled it from your pc, then reinstalled it?
It may fix it, fairly confident it will.
Poita Sep 5, 2013 @ 11:33pm 
After a reboot it still won't launch so it looks like uninstalling it and trying again is the next option. Stupid CA.
Poita Sep 7, 2013 @ 9:37am 
The re install worked.
cypress_graphic Sep 7, 2013 @ 9:43am 
I had a same problem too, I am trying to reinstall the game now, hope it work...
Showing 1-15 of 17 comments
< >
Per page: 15 30 50

Date Posted: Sep 5, 2013 @ 9:20pm
Posts: 17