Total War: ROME II - Emperor Edition

View Stats:
Grimm Sep 5, 2013 @ 7:16pm
Incompatible Version - Multiplayer (Help)
Wanted to get into the multiplayer.
Went to battles. No matches found. None. Nothing. Nada.
Went to co-op camp. Found matches. Attempt to join: Failed to join - Incompatible Version. Wut? Look on Google. Nothing comes up except for Shogun 2: They say its due to updates or mods.

No mods. Updated. Whats going on? Suggestions please.

UPDATE: 2015

Made this thread two years ago - I still get notified people are posting on it. I never found an answer for the issue - eventually it cleared itself up without me doing anything. Keep in mind I made this thread during launch, and Rome II had one of the worst launches of all time. It was likely just a bug.
For those having this issue now: the cause is mods. Either you have mods the other person does not, or vise versa. This also happenes when you have Rome II installed on a different computer with mods, and try to play it on another computer without the mods. The solution to this second issue is to subscribe and unsubscribe to all the mods you had on the previous computer, on the current computer.
Last edited by Grimm; May 10 @ 11:07pm
Showing 1-15 of 47 comments
< >
Chargeback Thomas Sep 5, 2013 @ 7:17pm 
Opt into the beta patch. That may be your problem.
Grimm Sep 5, 2013 @ 7:17pm 
Doing so now. Get back to you in a moment.
Grimm Sep 5, 2013 @ 7:27pm 
Negative. This has caused all servers to appear red and not be joinable due to me having a different version.

At first they were joinable, but upon attempting to join I would get the error message for incompatible version.

Any other ideas?
Chargeback Thomas Sep 5, 2013 @ 7:28pm 
Originally posted by =(e)= Sgt. Grimm:
Negative. This has caused all servers to appear red and not be joinable due to me having a different version.

At first they were joinable, but upon attempting to join I would get the error message for incompatible version.

Any other ideas?
No, I've got nothing, sorry.
Grimm Sep 5, 2013 @ 7:32pm 
I feel like my simple help thread is being burried by the argument threads.
Chargeback Thomas Sep 5, 2013 @ 7:39pm 
Yeah, it sucks. People need to stop making new threads every 2 minutes, and keep all their arguments in one place.
davewv38 Sep 11, 2013 @ 5:40pm 
I have had the same problem.......does it have something to do with the prepaid version versus the later version?
Grimm Sep 11, 2013 @ 6:29pm 
No idea. I have yet to find a fix for this. It seem to only affect the co-op campaign, because my multiplayer battles work just fine.
W!LDWEASLE Sep 12, 2013 @ 3:21am 
I have the same issue, if I host a game no one can join me?! Cant seem to find any tips as to why, every ones should be the same at the moment< if you are online, means steam has run the updates. has done this since day 1.
Killer Steve Sep 12, 2013 @ 3:27am 
i have the same problem! What the hell it is happening?
W!LDWEASLE Sep 12, 2013 @ 3:29am 
ok just conected to one, see 7 others but only one! And then he left the game!!!NOOO. seems if the game is already in progress then it brings that message.
Grimm Sep 12, 2013 @ 11:56am 
This is a very odd problem for which I can find no support or assistance on the all-knowing interwebs. I have composed an email to Total War support detailing the problem. The more people sharing their experiences the faster we can get it resolved. Keep posting.
Last edited by Grimm; Sep 12, 2013 @ 11:56am
MeetYourMaker Sep 12, 2013 @ 12:10pm 
Me and my friend have just started to get this problem in a coop campain after playing about 26 turns so far. Versions are the same, both not in beta, verified files in steam .. ect ...
Last edited by MeetYourMaker; Sep 12, 2013 @ 12:15pm
EternalSilence Sep 12, 2013 @ 1:20pm 
Incompatible versions of the game are caused because one of the two players has mods in his data folder.
Grimm Sep 12, 2013 @ 6:55pm 
Mods are not the culprit here for two reasons: I got this error when I have no mods installed. Second, I started getting this error the day after release, when no mods had yet been made. I was recieiving it for ALL multiplayer matches as well, so unless it was a mod everyone was using and I was just out of the loop, that isnt the problem.
Showing 1-15 of 47 comments
< >
Per page: 15 30 50

Date Posted: Sep 5, 2013 @ 7:16pm
Posts: 47