LeadStarDude Nov 30, 2013 @ 9:49pm
30% CPU usage on Extreme @ 1080p?
I was at the understanding that this game is very CPU intensive, but my CPU is only running at 30%. I checked with resource mananger & it shows all of my (8) cores unpark & share the work load when playing this game, but only using 30%. I also have two GPUs, but I am only able to use one GPU right now because of no SLI support for Rome 2 yet. My one GPU never goes over 40%. Strange huh? Right now I am getting between 55 to 62fps with all settings on & @ Extreme except Shadows=Ultra, Unit Size=Medium, Alpha Vegetation=Off, SSAO=Off, AA=On, & AF=16x. This is @ 1920x1080. I was getting 40 to 45fps before patch 7 with the exact same settings. I gained a solid 15fps with patch 7. I normally get around 80 to 85fps on Shogun 2 maxed out at the same resolution, but Shogun 2 does have SLI support.

Alienware 18
Intel i7 4900MQ quad core (8 logical processors) @ 2.8GHz to 3.8GHz OC to 4.0GHz
32GB 1600MHz DDR3 RAM (Kingston HyperX)
Dual nVidia GTX 780M (256-bit) 4GB GDDR5 VRAM in SLI (3072 CUDA cores total)
Two 1TB Samsung 840 EVO SSD (2TB total space)
Killer Wireless N 1202
Windows 7 Pro 64-bit

Has anyone else noticed low CPU or low GPU usage while playing Rome 2? If so how is your in game performance? My performance seems unaffected by this issue, but my FPS is still much lower than what I expect to get over all when playing this game. Anyone else?
Showing 1-15 of 24 comments
< >
manana2522 Nov 30, 2013 @ 9:54pm 
AMD Anthlon II P340 GHz 2.20

AMD mobility raedeon HD 4250

3.00 GB installed(currently 2.75 in storage)

Windows 7 ultimate

If the game would use 100% of my CPU, how much FPS would i get. If it even became able to run the game.
LeadStarDude Nov 30, 2013 @ 10:10pm 
Originally posted by manana2522:
AMD Anthlon II P340 GHz 2.20

AMD mobility raedeon HD 4250

3.00 GB installed(currently 2.75 in storage)

Windows 7 ultimate

If the game would use 100% of my CPU, how much FPS would i get. If it even became able to run the game.
I don't know if you can or not? My old laptop could run this game on Medium to High with all special effects turned off @ 1600x900. It is a:

HP dv7 4069wm 1600x900 17.3" laptop
AMD Phenom II N830 triple core @ 2.1GHz
8GB 1066MHz DDR3 RAM (Crucial)
ATI Mobility Radeon HD 5470 512MB DDR3 VRAM
Two 750GB WD Black 7200rpm HDD (1.5TB total space)
Windows 7 Home Premium 64-bit

Honestly I think you are out of luck. I am not saying it won't play for you, but there is no way it will play good. You really need more RAM. You may be able to get this game to run ok if you get more RAM (upgrade to 6GB), but honestly that Mobility Radeon HD 4250 is very weak. Does it even meet the minimum requirements for this game? The whole laptop is weak. Sorry... I don't mean anything bad by telling you this. Also why do you have Windows 7 Ultimate on a lower end laptop? Your laptop can't hold enough RAM to need Ultimate.
Last edited by LeadStarDude; Nov 30, 2013 @ 10:11pm
Order Nov 30, 2013 @ 10:19pm 
My cpu never breaks 50%, it's a 3930k 4.6 OC watercooled. Crossfire works like a charm with rome II (finally). Getting over 170 FPS from 3 way Crossfire 7950's, first two cards running at 75-90%, 3rd card does not show useage information. Performance is really good on my end.
Last edited by Order; Nov 30, 2013 @ 10:21pm
LeadStarDude Nov 30, 2013 @ 10:27pm 
Originally posted by Order:
My cpu never breaks 50%, it's a 3930k 4.6 OC watercooled. Crossfire works like a charm with rome II (finally). Getting over 170 FPS from 3 way Crossfire 7950's, first two cards running at 75-90%, 3rd card does not show useage information. Performance is really good on my end.
See? That is what I don't understand. My system is barely running when playing this game. I am getting good performance, but nothing like what I should be getting. How are you getting Crossfire to work without there being any official support yet?
Order Nov 30, 2013 @ 10:32pm 
Originally posted by LeadStarDude:
Originally posted by Order:
My cpu never breaks 50%, it's a 3930k 4.6 OC watercooled. Crossfire works like a charm with rome II (finally). Getting over 170 FPS from 3 way Crossfire 7950's, first two cards running at 75-90%, 3rd card does not show useage information. Performance is really good on my end.
See? That is what I don't understand. My system is barely running when playing this game. I am getting good performance, but nothing like what I should be getting. How are you getting Crossfire to work without there being any official support yet?

There are beta drivers out which support Crossfire for Rome II, I have a program that grabs all new beta drivers (for the 79** series cards) and installs them when available. Google beta drivers for your cards. There was micro-stuttering issue with Crossfire but that has seemed to be fixed in the last driver patch.
Last edited by Order; Nov 30, 2013 @ 10:34pm
LeadStarDude Nov 30, 2013 @ 10:36pm 
nVidia still doesn't have SLI for this game yet even with the beta drivers. This official driver I have just released last week. It is 331.82. I am hoping this will all be fixed by the end of the year.



Originally posted by Order:
Originally posted by LeadStarDude:
See? That is what I don't understand. My system is barely running when playing this game. I am getting good performance, but nothing like what I should be getting. How are you getting Crossfire to work without there being any official support yet?

There are beta drivers out which support Crossfire for Rome II, I have a program that grabs all new beta drivers (for the 79** series cards) and installs them when available. Google beta drivers for your cards.
Order Nov 30, 2013 @ 10:41pm 
Originally posted by LeadStarDude:
nVidia still doesn't have SLI for this game yet even with the beta drivers. This official driver I have just released last week. It is 331.82. I am hoping this will all be fixed by the end of the year.



Originally posted by Order:

There are beta drivers out which support Crossfire for Rome II, I have a program that grabs all new beta drivers (for the 79** series cards) and installs them when available. Google beta drivers for your cards.

Usually AMD are really bad with driver updates but for the first time they are ahead of Nvidia (only because of CA messing around I think). Hope you get your SLI working soon, this game really loves multi card builds when it works. These are my first AMD cards and I won't be staying with AMD that's for sure, Nvidia usually have less issues with drivers I notice.
Last edited by Order; Nov 30, 2013 @ 10:43pm
LeadStarDude Nov 30, 2013 @ 10:52pm 
Originally posted by Order:
Originally posted by LeadStarDude:
nVidia still doesn't have SLI for this game yet even with the beta drivers. This official driver I have just released last week. It is 331.82. I am hoping this will all be fixed by the end of the year.



Usually AMD are really bad with driver updates but for the first time they are ahead of Nvidia (only because of CA messing around I think). Hope you get your SLI working soon, this game really loves multi card builds when it works. These are my first AMD cards and I won't be staying with AMD that's for sure, Nvidia usually have less issues with drivers I notice.
Yes. I think you are right. My first build almost 15 years ago was an Intel/nVidia system. Ever since I have been using AMD/ATI. This new system of mine is the first Intel/nVidia system I have had since that first build all of those years ago, & I am absolutely loving it. All of my games run flawlessly with my current setup, & at much lower temps. I will just be glad when all of the crap for this game gets sorted out. The Total War series is one of my all time favorites. I have been playing since the original Shogun & still have all of the games.
Order Nov 30, 2013 @ 11:23pm 
Originally posted by LeadStarDude:
Originally posted by Order:

Usually AMD are really bad with driver updates but for the first time they are ahead of Nvidia (only because of CA messing around I think). Hope you get your SLI working soon, this game really loves multi card builds when it works. These are my first AMD cards and I won't be staying with AMD that's for sure, Nvidia usually have less issues with drivers I notice.
Yes. I think you are right. My first build almost 15 years ago was an Intel/nVidia system. Ever since I have been using AMD/ATI. This new system of mine is the first Intel/nVidia system I have had since that first build all of those years ago, & I am absolutely loving it. All of my games run flawlessly with my current setup, & at much lower temps. I will just be glad when all of the crap for this game gets sorted out. The Total War series is one of my all time favorites. I have been playing since the original Shogun & still have all of the games.

I agree with you about them temps, my cards got crazy hot when I didnt have them water cooled. I want new Nvidia cards (as the issues with drivers over the last 15 months has driven me mad at times) but performance wise it's pointless and a waste of money until end of 2014 at least, because the 3 7950's out perform most builds and cost vs performance I can't see a better build. I just have to deal with the frustration of them drivers for another 12-15 months or so =)

Total War always takes 6-12 months until it's really playable, I love the franchise and I don't mind waiting 6 months for a stable build, that's just the way it has always been. Anyway best of luck and I envy your SLI as besides Rome II I'm sure you have 0 issues with it.
DelroyMonjo Dec 1, 2013 @ 11:50am 
Depends on which point of the game you are looking at the Win Resource Mgr. It can use 100% of at least 4 cores (i5-4670 running Turbo to 3.8GHz only). Try Open Hardware Monitor for Min-Max readings.
LeadStarDude Dec 1, 2013 @ 12:10pm 
Originally posted by DelroyMonjo:
Depends on which point of the game you are looking at the Win Resource Mgr. It can use 100% of at least 4 cores (i5-4670 running Turbo to 3.8GHz only). Try Open Hardware Monitor for Min-Max readings.
I did & two cores run at like 80%, two more are running at 40%, & the rest are barely runing at all. They are not in a parked mode when the game is running, but they are barely being used. I wish this game would use what I have available to increase in game performance instead of just playing the way it wants to no matter how many resources are available.
mattius1989 Dec 1, 2013 @ 2:37pm 
Originally posted by manana2522:
AMD Anthlon II P340 GHz 2.20

AMD mobility raedeon HD 4250

3.00 GB installed(currently 2.75 in storage)

Windows 7 ultimate

If the game would use 100% of my CPU, how much FPS would i get. If it even became able to run the game.

Kill yourself.
Order Dec 1, 2013 @ 10:32pm 
Originally posted by mattius1989:
Originally posted by manana2522:
AMD Anthlon II P340 GHz 2.20

AMD mobility raedeon HD 4250

3.00 GB installed(currently 2.75 in storage)

Windows 7 ultimate

If the game would use 100% of my CPU, how much FPS would i get. If it even became able to run the game.

Kill yourself.

Even better, Kill Mattius1989, Then spend $400-600 and upgrade your laptop
Last edited by Order; Dec 1, 2013 @ 10:33pm
StrangerUK Dec 2, 2013 @ 6:14am 
Originally posted by DelroyMonjo:
Depends on which point of the game you are looking at the Win Resource Mgr. It can use 100% of at least 4 cores (i5-4670 running Turbo to 3.8GHz only). Try Open Hardware Monitor for Min-Max readings.

I have the same CPU and it never goes to 100% most is on the first core and rest are lower.

prime95 puts all to 100 though so its not my cpu.
Last edited by StrangerUK; Dec 2, 2013 @ 6:15am
Lafferty Dec 2, 2013 @ 6:40am 
You all do realize its not the manufactuers thats at fault its the game developers that are specifically at fault for not supporting sli by default. Yes these drivers help thats the manufacturers stepping in rather than the devs doing this since they have not got a single clue what they are doing or so it seems.

ey would need to develop this into the game itself and optimize for sli support thats not the job of the supplier of this tech. You all target nvdia and amd as if it is somehow their fault for how a game dev company develops their game. Are you all ♥♥♥♥♥♥$ thats as nice as im putting it !.

Also when it comes to multi core, hyper threading. gpu usage you all except 100% usage with no idea of how the hardware is being ultised. Read up on game development and especially hyper threading !
Last edited by Lafferty; Dec 2, 2013 @ 6:47am
Showing 1-15 of 24 comments
< >
Per page: 15 30 50
Date Posted: Nov 30, 2013 @ 9:49pm
Posts: 24