LeadStarDude Mar 26 @ 7:53pm
OMG! SLI is working!!!
Finally SLI is working! I am so happy. I can finally play this game maxed out & stay above 60fps.

Here is a link to my official TW forum thread about it. Some screenshots from someone else proving that SLI is working.
http://forums.totalwar.com/showthread.php/125132-SLI-is-working!!!/page9
Last edited by LeadStarDude; Apr 5 @ 11:04am
Showing 1-15 of 132 comments
< >
eL_GuRu Mar 26 @ 8:01pm 
SLI IS WORKING ALSO THEY CHANGED HOW MODS WORK, THERE IS NOW OLD MODS OPTION
LeadStarDude Mar 26 @ 8:04pm 
Originally posted by eL_GuRu:
SLI IS WORKING ALSO THEY CHANGED HOW MODS WORK, THERE IS NOW OLD MODS OPTION
I never use mods on TW games until they have been out for a year. I started with Shogun 1 & I already know better than to use mods until the game is finished.
PurSpyk!! Mar 26 @ 9:13pm 
What settings are you using for Sli?
Firahel Mar 26 @ 9:15pm 
SLI still does not work for me...
Last edited by Firahel; Mar 26 @ 9:15pm
LittleKat Mar 26 @ 9:49pm 
Originally posted by Firahel:
SLI still does not work for me...

It is working for me now, I'm using 2 ways SLI GTX cards. Update all your drives
PurSpyk!! Mar 26 @ 10:03pm 
Are you using the Shogun 2 profile?
LittleKat Mar 26 @ 10:06pm 
Originally posted by PurSpyk!!:
Are you using the Shogun 2 profile?

Yeah, didn't work the 1st try then it just work on 2nd try.
Adrian Mar 26 @ 10:37pm 
Confirmed SLI is working with 660 TI SLI and 780 TI SLI with the latest drivers
LeadStarDude Mar 26 @ 11:27pm 
Mine is GTX 780M SLI in a laptop. I am on driver 335.23. It is working great.
MAGIC-MIKE81 Mar 26 @ 11:42pm 
about time i built this rig before lunch of this game and when i found out no sli support
i was mad but now i can have some fun:)

PC specs:
cpu:i5-4670
gpu:2 asus gtx 760 directcu ll sli
psu:corsair cx750m
mobo:asus maximus gene 6
ram:16gb
2tb and 250gb ssd
Firahel Mar 27 @ 1:00am 
maybe i should configure it somehow somewhere?
Berserk Smurf Mar 27 @ 2:41am 
How's it performing for you, LeadStarDude?
{sFSBz} Jonboy Mar 27 @ 3:51am 
Originally posted by LeadStarDude:
Mine is GTX 780M SLI in a laptop. I am on driver 335.23. It is working great.


Glad to hear it
Genghison Mar 27 @ 3:59am 
Originally posted by MAGIC-MIKE81:
about time i built this rig before lunch

PC specs:
cpu:i5-4670
gpu:2 asus gtx 760 directcu ll sli
psu:corsair cx750m
mobo:asus maximus gene 6
ram:16gb
2tb and 250gb ssd
Wow...that's impressive.....
Relapse Mar 27 @ 4:14am 
Originally posted by LeadStarDude:
Finally SLI is working! I am so happy.

You have waited a long time for SLI support. Have fun. :)

Originally posted by LeadStarDude:
I can finally play this game maxed out & stay above 60fps.

I don't think so. There are many extreme situations, but those extreme situations are neglible.
Last edited by Relapse; Mar 27 @ 4:16am
Showing 1-15 of 132 comments
< >
Per page: 15 30 50
Date Posted: Mar 26 @ 7:53pm
Posts: 132