Duckdevil Feb 1 @ 7:07am
A possible fix to the game crashes
Dear people,

First, a list of things to try before attempting my possible solution.


Originally posted by Bane:

-When booting up the game, when you see the windows icon on your mouse, click nothing! if you do it will crash, boot up, wait 30 seconds and let it do its thing.

If it still does not work:

-Remove all mods (first uncheck off the launcher, if it does nothing, unsubscribe through steam workshop) then reboot the game.

If the above fails to work follow these steps:


-Go to "C:\Users\Administrador\AppData\Roaming\The Creative Assembly\Rome2"

-Then delete the Rome2 folder.


-Once removed go to "C:\Program Files (x86)\Steam\SteamApps\common\Total War Rome II\redist"

-Then open the files listed below in that order and click on repair for each one, the last one doesn't have a repair window pop up, instead you will see a small loading bar,

1-vcredist_x86-90.exe
2-vcredist_x86-100-sp1.exe
3-vcredist_x86-80-sp1.exe

Then just proceed to load your game and it should then go onto the main menu.



Basically a file save of settings which corrupts at random it seems. Reinstalling the game wont do anything as these files save locally.

Be aware that in the Users/roaming Rome 2 folder are your local save files, you may want to make a copy of these or just copy the entire Rome 2 folder which the guide asks you to delete. A friend recently fixed his game using this when it stopped working earleir today after 130 hours play time.

If you are unable to find the app data file then you will need to enable view of hidden files/folders.

For windows 7 go to control pannel, folder options, view tab and enable show hidden files and folders.

For Windows 8 go to the control pannel app, scroll to the bottom and select the More Settings. Then click on appearance and personalization, look under the folder options category and check the show hidden files/folders.

If you have hidden files/folders enabled and still dont see it make sure your looking at the User profile your currently logged into windows with.


Hope this helps! good luck

If that doesn't work, i may have found a solution to the crashes related to Patch 9.
My game crashed at startup since Patch 9.
Some other games had this issue aswell so i tried following, with succes:
-Go to %appdata%/Roaming/The Creative Assembly/Rome2/Scripts/
(Start > search bar > %appdata%)
-Open: preferences.script.txt
-Search the following (CTRL + F): directx
-You should find the following line:
gfx_enable_directx11 true; # gfx_enable_directx11 <bool>, Enable DirectX 11 rendering #
-Change the "true" to "false", so it looks like this:
gfx_enable_directx11 false; # gfx_enable_directx11 <bool>, Enable DirectX 11 rendering #
-Save and close the file.
-Launch the game, and it should hopefully work :)



If you do not have any files in the /scripts/ folder, please download my preferences.txt and place it into the /scripts/ folder.
Make sure to change the settings to your liking once you are at the ingame Main menu.
http://www.mediafire.com/download/tw1i58lq4d7ssdv/preferences.script.rar

If you do not have ANY folder in %Appdata%, please download the following and extract it to your %Appdata%:
https://www.mediafire.com/?ci7ywgs99rlq195

NOTE: the line may look different from the above example. But it should look familiar.
For me, the line looked like this:
GFX_Directx11_Enable_True
Which i changed to:
GFX_Directx11_Enable_False

This disabled Directx11.
So the game might not look as pretty, but atleast it works.
We'll have to wait for CA to fix the issue with Directx11.

Hope this works for you :)
If it did, please leave a reply so the topic will stay on the first page.
Last edited by Duckdevil; May 1 @ 4:54pm
Showing 1-15 of 933 comments
< >
Balthazaar Feb 1 @ 7:25am 
where can I find the folder %appdata%?

or am I being thick?
Misgun2 Feb 1 @ 7:32am 
search %Appdata% on START search
Misgun2 Feb 1 @ 7:40am 
It's amazing. It does work!!
Duckdevil Feb 1 @ 3:42pm 
Originally posted by l_zuidema:
It's amazing. It does work!!
Glad it worked for you ^^
crispinh46 Feb 1 @ 3:48pm 
I m crashing on startup - but when Igo to the ....\scripts directory it's empty. Any other ideas?
Duckdevil Feb 1 @ 3:55pm 
Originally posted by crispinh46:
I m crashing on startup - but when Igo to the ....\scripts directory it's empty. Any other ideas?
Yes, if you have any other Total War game, you could take the preferences file from that game and copy it to the Rome 2/scripts directory.

I will upload my preferences file for people that do not have the file/any other Total War game.
Please check the OP again in 5 minutes ^^

EDIT: added a link for you, and all other people that do not have the file.
Last edited by Duckdevil; Feb 1 @ 3:59pm
crispinh46 Feb 1 @ 4:04pm 
Sorry - I can't see the link to your prefs file????
Duckdevil Feb 1 @ 4:07pm 
Originally posted by crispinh46:
Sorry - I can't see the link to your prefs file????
It should be there in the OP.
http://www.mediafire.com/download/tw1i58lq4d7ssdv/preferences.script.rar
crispinh46 Feb 1 @ 4:18pm 
Sorry - blind! Many thanks for your assistance - now working!
Duckdevil Feb 1 @ 4:25pm 
Originally posted by crispinh46:
Sorry - blind! Many thanks for your assistance - now working!
Great !
jgblount Feb 1 @ 4:34pm 
This method got the game working (and for that i am thankful) but now I cannot put the graphics above medium....is there a way around this?
enduramin Feb 1 @ 4:36pm 
works great, actually improved performance for me also, as I'm on an pretty outdated laptop, and i't can't realle handle the game very well with dx11
Duckdevil Feb 1 @ 4:54pm 
Originally posted by jgblount:
This method got the game working (and for that i am thankful) but now I cannot put the graphics above medium....is there a way around this?
Well that is an interesting issue.
Because my preferences are very high/ultra, except for shadows.
Did you enable 'unlimited memory' ?
You could also try changing the video settings in the preference file.
Open the preferences file and find the lines responsible for quality and change it to something between 1 and 5.

For example:
gfx_terrain_quality 4; # gfx_terrain_quality <int>, Set terrain quality. 0 - low, 5 - extreme #
Would set the terrain quality to Very High.
Correct me if i'm wrong: 1-low 2-medium 3-high 4-very high 5-extreme.

But there's the boolean value's written behind the lines.
jgblount Feb 1 @ 5:08pm 
It won't let me enable the unlimited memory, but i think i got about every thing else back to it's old level thanks......I just hope they fix whatever the problem is so i can use the directx 11 again.
Duckdevil Feb 2 @ 2:21am 
Originally posted by jgblount:
It won't let me enable the unlimited memory, but i think i got about every thing else back to it's old level thanks......I just hope they fix whatever the problem is so i can use the directx 11 again.
Same here.
I'm happy i got it working, but Dx11 looks better.
Showing 1-15 of 933 comments
< >
Per page: 15 30 50