blogdron Oct 5, 2013 @ 11:48am
[Resolved] Segmentation fault , Debian GNU/Linux
(steam:9924): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
Segmentation fault
Game removed: AppID 214910 "Air Conflicts: Pacific Carriers", ProcID 10721

dron@gnu:~$ uname -a
Linux gnu 3.10-3-amd64 #1 SMP Debian 3.10.11-1 (2013-09-10) x86_64 GNU/Linux


dron@gnu:~$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on AMD BARTS


dron@gnu:~$ glxinfo | grep Mesa
client glx vendor string: Mesa Project and SGI
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.1.6
OpenGL version string: 3.0 Mesa 9.1.6


dron@gnu:~$ Xorg -version

X.Org X Server 1.14.3
Release Date: 2013-09-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.10-2-amd64 x86_64 Debian
Current Operating System: Linux gnu 3.10-3-amd64 #1 SMP Debian 3.10.11-1 (2013-09-10) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.10-3-amd64 root=UUID=d2f693b7-c107-4c4a-8639-ccf23159544d ro quiet
Build Date: 22 September 2013 02:44:54PM
xorg-server 2:1.14.3-3 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.30.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
dron@gnu:~$



dron@gnu:~$ lspci |grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Barts PRO [Radeon HD 6850]
Last edited by [= GF =] Slnecnica; Oct 6, 2013 @ 7:16am
Showing 1-5 of 5 comments
< >
Linux.PlayX Oct 5, 2013 @ 1:01pm 
You need OpenGL 3.2 support to run the game.

Minimum
OS: Ubuntu 12.04
Processor: Intel/AMD CPU (1.1GHz+)
Memory: 1 GB
Hard Disk Space: 2 GB
Video Card: Shader 3.0 compatible graphics card with min. 256 MB RAM
->OpenGL: 3.2
Sound: Sound card required

But Mesa supports only a few features of 3.1. So use the closed source driver für your amd card.
Last edited by Linux.PlayX; Oct 5, 2013 @ 1:03pm
blogdron Oct 5, 2013 @ 1:37pm 
thank you
[= GF =] Slnecnica  [developer] Oct 6, 2013 @ 7:16am 
Thanks GTuxTV.PalyX for your help :)
Rexo12 Dec 21, 2013 @ 8:29pm 
Sorry to dig up an old topic, but when i install the closed source drivers for my AMD Radeon HD 2xxxx series card (don't even ask) on OpenSuSE 12.2, I cannot open up steam, because steam doesn't like the updated OpenGL.
V10lator Feb 5 @ 8:36pm 
Originally posted by Linux.PlayX:
But Mesa supports only a few features of 3.1. So use the closed source driver für your amd card.
I know this thread is old but the information is no longer true. Mesa git currently supports up to OpenGL 3.3 and runs this game just fine. If you don't know how to use Mesa git just wait till mesa 10.2 is stable. :)
Showing 1-5 of 5 comments
< >
Per page: 15 30 50