Biggus Dickus Oct 10, 2013 @ 4:55am
[MAC] cant launch game
i click on the game and nothing happens
Showing 1-15 of 23 comments
< >
[= GF =] Slnecnica  [developer] Oct 11, 2013 @ 3:28am 
Can you please report us exact hardware configuration and OSX version you have?
Boke Oct 11, 2013 @ 5:46pm 
Cant launch, I am using an OSX version 10.6.8. 2 GHz Intel Core i7, 4 GB 1333MHz DDR3
Biggus Dickus Oct 11, 2013 @ 7:38pm 
Mac osx x
ver 10.7.5

memory 4gb 1333Mhz DDR3
processor 2.7 gHz intel core i5
grachics AMD radeon HD 6770M 512 MB

[= GF =] Slnecnica  [developer] Oct 15, 2013 @ 8:03am 
Can you please try with the latest update?
s.ditgens Oct 16, 2013 @ 9:18am 
i got the same problem....i click on the game and nothing happens
OS X 10.8.5
2,6 GHZ Intel Core I7
16 GB 1600 MHZ DDR3

how can i solve the problem....any Tipps?
davew26z Oct 16, 2013 @ 10:42am 
I have a mac, 10.8.5. Here is a more detailed description of the error i am getting, same deal, tries to load the game, then crashes instantly.


Process: ACPC [576]
Path: /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/MacOS/ACPC
Identifier: com.GamesFarm.ACPC
Version: 1 (1)
Code Type: X86 (Native)
Parent Process: launchd [139]
User ID: 502

Date/Time: 2013-10-16 10:41:20.757 -0700
OS Version: Mac OS X 10.8.5 (12F45)
Report Version: 10

Interval Since Last Report: 120230 sec
Crashes Since Last Report: 9
Per-App Crashes Since Last Report: 9
Anonymous UUID: 3AD4BB87-D24F-33ED-1868-481DFBDF7325

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/SFML.framework/Versions/2.0.0/SFML
Referenced from: /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/MacOS/ACPC
Reason: image not found

Binary Images:
0x1000 - 0x6f7fe7 +com.GamesFarm.ACPC (1 - 1) <AE20CE81-18CB-3832-AE32-222574516936> /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/MacOS/ACPC
0x2be8000 - 0x2bedffb +org.sfml-dev.sfml-system (2.0.0 - 2.0.0) <52930DC4-701A-36E4-8887-BE5D5E946F4B> /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/Frameworks/sfml-system.framework/Versions/2.0.0/sfml-system
0x2bf4000 - 0x2c0dff7 +org.sfml-dev.sfml-window (2.0.0 - 2.0.0) <08579B74-DED3-3129-A3C6-CE75CBED07F5> /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/Frameworks/sfml-window.framework/Versions/2.0.0/sfml-window
0x2c1a000 - 0x2ca3fe7 +org.sfml-dev.sfml-graphics (2.0.0 - 2.0.0) <44D1ECAA-2C1B-301E-B52F-AE7BB56A2D2E> /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/Frameworks/sfml-graphics.framework/Versions/2.0.0/sfml-graphics
0x2cd7000 - 0x2ce3ff7 +org.sfml-dev.sfml-audio (2.0.0 - 2.0.0) <46B37808-62A0-3379-A45A-A6475E861172> /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/Frameworks/sfml-audio.framework/Versions/2.0.0/sfml-audio
0x2ceb000 - 0x2cfcff3 +org.sfml-dev.sfml-network (2.0.0 - 2.0.0) <6EB0D8F1-875F-372F-949D-61D97B76BB4E> /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/Frameworks/sfml-network.framework/Versions/2.0.0/sfml-network
0x8fe36000 - 0x8fe68e57 dyld (210.2.3) <23516BE4-29BE-350C-91C9-F36E7999F0F1> /usr/lib/dyld
0x917d4000 - 0x9183cff7 com.apple.framework.IOKit (2.0.1 - 755.42.1) <230C6EEC-A926-3720-82DB-25D0FAAEF962> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x950b6000 - 0x950c4ff7 libz.1.dylib (43) <245F1B61-2276-3BBB-9891-99934116D833> /usr/lib/libz.1.dylib
0x96327000 - 0x96333ff8 libbz2.1.0.dylib (29) <7031A4C0-784A-3EAA-93DF-EA1F26CC9264> /usr/lib/libbz2.1.0.dylib
0x99032000 - 0x99352ff3 com.apple.Foundation (6.8 - 945.18) <BDC56A93-45C5-3459-B307-65A1CCE702C5> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation

Model: MacBookPro9,2, BootROM MBP91.00D3.B08, 2 processors, Intel Core i5, 2.5 GHz, 8 GB, SMC 2.2f44
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 512 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3431554638424455352D474E2D4620
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3431554638424455352D474E2D4620
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (5.106.98.100.17)
Bluetooth: Version 4.1.7f2 12718, 3 service, 13 devices, 3 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: APPLE HDD ST500LM012, 500.11 GB
Serial ATA Device: MAT♥♥♥♥ADVD-R UJ-8A8
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1a100000 / 2
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0x1a110000 / 3
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1d100000 / 2
USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0x1d180000 / 3
USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x1d181000 / 6
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821d, 0x1d181300 / 7
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0252, 0x1d183000 / 5
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x1d182000 / 4
davew26z Oct 16, 2013 @ 1:20pm 
Well everyone, I have found a solution to this issue. In my last post, it was bombing out with:


Library not loaded: @executable_path/../Frameworks/SFML.framework/Versions/2.0.0/SFML
Referenced from: /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/MacOS/ACPC
Reason: image not found

The SFML.framework folder was in fact missing, so i headed over to http://www.sfml-dev.org/download/sfml/2.0/ and downloaded the SFML file for Mac OS X. then i copied the SFML.framework folder to ~/Library/Application Support/Steam/SteamApps/common/Air Conflicts - Pacific Carriers/ACPC.app/Contents/Frameworks .

Then I ran the app, got a new error, were are moving up! Now the error is:

Dyld Error Message:
Library not loaded: /Library/Frameworks/FreeType.framework/Versions/2.4/FreeType
Referenced from: /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/MacOS/ACPC
Reason: image not found

OK, so, we moved passed on error, only to get a new one. Now head over to http://www.kyngchaos.com/software/frameworks , download the FreeType package for mac. Run the pkg file and install.

Now the game runs!! I am having some mouse glitches on my Mac, however, the Core i5 and Intel HD 4000 is underpowered, so i did not expect great performance. (Good thing I also have Linux and Windows machines to play with!)

I will still be looking into fixing some glitches, at least what i can do on my end.

Hope this little guide helps!
Last edited by davew26z; Oct 17, 2013 @ 3:42pm
CanyonKidd Oct 18, 2013 @ 12:34am 
This is for davew26z. Question, how did you copy the SFML.framework folder to the library?
I can figure out how to accomplish this.
If you can run me through the process please.
Thx
davew26z Oct 18, 2013 @ 7:19am 
Hi there. The easiest way (since Library in you home dir is hidden by Finder by default) is to open a finder window, then hit Command-Shift-G. Once the goto window appears, input ~/Library/Application Support/Steam/SteamApps/common/Air Conflicts - Pacific Carriers/ (Default steam locale for the game). Then Right-Click the file labeled ACPC (.app extension is hidden in MAC) , and then click "Show Package Contents". Then you will see the "Contents" folder. Open that one and you will then see the "Frameworks" folder. Let me know if you have any more questions.
CanyonKidd Oct 18, 2013 @ 11:22am 
Hi davew26z, Thanks for the instructional lesson. I have placed both the SFML and the FreeType famework folders in the framework folder of contents folder of the ACPC file.
I still can launch the program. Did I do something wrong or did I miss a step?
I am running OSX 10.8.5 . How do you find the error message, maybe I can see what else might be missing from the program.
CanyonKidd Oct 18, 2013 @ 11:33am 
davew26z when I put the folders into the ACPC framework folder I just did drag and drop. Could that be the problem, because I notice a lot of alias folders within SFML and also FreeType.
Is there a different way to copy those folder to the ACPC frameworks folder?
Grabbing at straws. frustrated.
davew26z Oct 18, 2013 @ 5:13pm 
Ahh, well, i went through all the symlinks in the SFML.framework folder, and it just links the "Headers" and "Resources" folders and SFML binary to the 2.0.0 files in the "Versions" folder, so no worries there.

As far as freetype goes, if you notice the freetype error was:

Library not loaded: /Library/Frameworks/FreeType.framework/Versions/2.4/FreeType

FreeType does not go in the frameworks folder of ACPC, just install the pkg file from the link and it will install to /Library/Frameworks (Globally, not in the ACPC app). Thats why it would not open from steam (doesn't show you the errors), it probably bombs with the FreeType error still.

Oh, and to see the error, just double click "ACPC" (the actual game).
Last edited by davew26z; Oct 18, 2013 @ 5:28pm
CanyonKidd Oct 18, 2013 @ 6:44pm 
So I corrected the FreeType folders location issue. Still did not launch. The error message:
Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/SFML.framework/Versions/2.0.0/SFML
Referenced from: /Users/USER/Library/Application Support/Steam/*/ACPC.app/Contents/MacOS/ACPC
Reason: image not found

The SFML folder is in the frameworks folder of the contents folder of the ACPC.
Vresion I downloaded: Clang - universal 32+64 bits (OS X 10.8+, compatible with C++11 and libc++)
Now I just did drag and drop. Could that be the problem? Is there a different way to copy to the frameworks folder?

Also have an installscript_osx.vdf that is in the ACPC folder below the contents folder.
Do you have that too? Or should it be in another place?
Thanks for all your help.
CanyonKidd Oct 18, 2013 @ 7:24pm 
Still not reading the SFML folder.
davew26z Oct 18, 2013 @ 8:04pm 
I copied it (right click Copy) and not the drag in drop move, but I don't really think that should matter either way. Here is a screenshot of my ACPC Frameworks folder. Not sure what the problem could be, i guess just make sure the SFML.framework (case sensitive) contains the SFML binary, the "Headers", and "Resources" folders are present in the SFML.framework/Versions/2.0.0/ folder (not symlinks, as the other symlinks you saw were linked to these files). Very version specific, has to be 2.0.0

https://dl.dropboxusercontent.com/u/10313520/Screen%20Shot%202013-10-18%20at%207.55.12%20PM.png

installscript_osx.vdf is present on mine too. It is the script that runs (not sure if only once) when you launch from Steam, it changes permissions on a bunch of important files. After I tried the first time from Steam (wanted to make sure the script ran at least once) and it crashed, I was confident that I could run the ACPC app file manually no problem because the permissions would not have changed on the files since the script changed them.

Oh, and the log file from the run (appears next to the ACPC app file once you get a successful run)

https://dl.dropboxusercontent.com/u/10313520/ACPC.log
Last edited by davew26z; Oct 18, 2013 @ 8:46pm
Showing 1-15 of 23 comments
< >
Per page: 15 30 50