Vince V Nov 18, 2013 @ 10:27am
[Linux] Air Conflicts does not launch
I'm running Mint 14 64bit, the game does not launch at all. I can view the config window but once I click play nothing happens apart from my screen changing resolution (if i've cnaged the settings in config).
anyone solved this yet?
Showing 1-15 of 42 comments
< >
Owtcry Nov 18, 2013 @ 10:21pm 
This is happening for me on windows 7 as well.
NETabuse Nov 19, 2013 @ 8:00am 
Same issue here, ubuntu 13.04 64bit on Intel HD4000 graphics chip. set to full screen and windowed, no luck.
Probably Alligator Nov 19, 2013 @ 3:06pm 
Same problem, also HD4000 on newest ubuntu. Tried running it from console, doesn't show any output at all, just quits.
Last edited by Probably Alligator; Nov 19, 2013 @ 3:06pm
Suchakra Nov 19, 2013 @ 8:22pm 
Same here. HD4000 and Fedora 19. There seems to be a pattern here. If there are any devs listening, do we have some provision to enable debug flag etc. to know where the issue is.
Rabid Bat Nov 19, 2013 @ 10:59pm 
you guys tried using an actual dedicated video card like a Geforce or Radeon Card?

Intel HD4000 or any intergrated intel GPU will always sucks for gaming.
Owtcry Nov 19, 2013 @ 11:32pm 
Yes, I;m using a GeForce
pratthugo Nov 20, 2013 @ 10:58am 
Same problem here. Can't find the error log. Linus Mint 14 32bits . Any idea where I could find those logs ?
Last edited by pratthugo; Nov 20, 2013 @ 10:58am
cobrast5 Nov 20, 2013 @ 2:01pm 
I am on a Mac with 1GB dedicated video and having the same issue.
paule Nov 20, 2013 @ 6:48pm 
Same here, no Error Message, there happens just nothing!
ninjawax Nov 24, 2013 @ 12:05pm 
Same problem :
It doesn't start on my brand new Thinkpad T530 laptop : Fedora 19 64bits, Intel HD4000, 8G RAM

EDIT : I can launch the game my desktop (Fedora 19 64bits, GeForce GT 530 with nVidia drivers, 8G RAM). But it's a windowed mode with ugly graphics and without any sound :(
Last edited by ninjawax; Dec 3, 2013 @ 4:34pm
NETabuse Nov 24, 2013 @ 1:26pm 
I decided to try running ACPC again with a bit more of a debug effort.
For a normal steam setup, the binaries for the game are located at:
/home/{user}/.local/steam/Steam/steamApps/common/Air Conflicts - Pacific Carriers/ACPC/bin/
I ran ./ACPC from there in my terminal but it fails to run anything. The reason for this is that the binary does not know where to look for a steamappid, to authenticate the game.

I realised this when i saw error files appearing in the bin/ folder
acpc-err.log and acpc-out.log appear when you run the binary. The program has the annoying habbit of truncating/deleting these log files when run from steam.

anyway, uppon discovering their existance. I tail -f 'd them and watched their output, i received this output in the acpc-err.log from running ./ACPC from the bin directory in the terminal directly:

---------------------------------------
[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.
---------------------------------------

From this point I figured then i could only test the app by running from my steam library screen.
When i ran from their, i received the below output in the sfml-log.txt

---------------------------------------
Using altered version of SFML2 (core profile enforced)
Attempting to create GL context...
Error creating OpenGL 3.x context! Falling back to OpenGL 2.x ...
---------------------------------------

From this, the sfml library linked by the game or in ubuntu's setup is missing or an incorrect versoin. I'm not sure which package name to look for in dpkg of apt-cache search to see if it's the ubuntu setup.

I wonder if anyone out there has knowledge of these error log's meanings?

cheers folks.
efdejot Nov 27, 2013 @ 8:10am 
dont work ubuntu 13.10 nvidia gt630m
MAR11166909 Nov 28, 2013 @ 8:28am 
Same problem here, with both a 64bit 13.04 and a 32bit 13.10 (Desktop/laptop).
Roni-BR**Linux** Nov 30, 2013 @ 6:00am 
Same problem here. Ubuntu 13.10x64, kernel 3.12, AMD-HD5770 Open source driver.
ACey Dec 1, 2013 @ 2:13pm 
Same problem, Linux Mint 15 x64 (Ubuntu 13.04), kernel 3.8, nvidia GTX460

I can launch the game but i don't have sounds, i can't config controller (xbox360 pad) and i can't configure the game (fullscreen, graphics ...)
Last edited by ACey; Dec 1, 2013 @ 2:15pm
Showing 1-15 of 42 comments
< >
Per page: 15 30 50