Lazicful Oct 16, 2012 @ 1:12am
I can't launch my game...
It literally doesn't launch when I press play.
Any help?!?
Showing 1-15 of 17 comments
< >
some danny Oct 16, 2012 @ 1:31am 
The "Play!" button is for playing your Steam Workshop subscriptions.

Press F5 or click the little green arrow to play your own game.
Lazicful Oct 16, 2012 @ 1:39am 
That's what I meant...
I do that...
some danny Oct 16, 2012 @ 1:48am 
So it doesn't do anything, and it doesn't show any compiler output at all?

Is your target set to "Windows"?
Lazicful Oct 16, 2012 @ 2:06am 
heh...No... :/
Lazicful Oct 16, 2012 @ 9:13am 
Well, still doesn't work most of the time, I have to restart when it happens.
[DK] Stefan Oct 16, 2012 @ 10:47am 
And my game say "Error #2: Steam must be running gamemaker:studio to run!" When i click play...
Lazicful Oct 16, 2012 @ 12:38pm 
Sucks
[DK] Stefan Oct 16, 2012 @ 2:01pm 
My gamemaker worked again. Have you try to restart your pc?
Lazicful Oct 16, 2012 @ 2:07pm 
No...
Rolz73 Oct 27, 2012 @ 3:03pm 
Vex, I had the same issue. I found it was an issue becasue I am using WinXP and there is a certain Windows environment variable that is automatically set in VISTA or higher, but not in XP. Here is where I read about the solution:

{LINK REMOVED - Please don't spam, and be wary of scams.}http://goo.gl/46GqF
ashofmind Apr 1, 2013 @ 2:14pm 
Mine does not launcher either 64-bit windows 7.
It Compiles, Steam loses focus like the app is running
I get steam achievements for running or debugging the app yet it never opens.

this is the compile output:
Saving IFF file... C:\Users\edit\AppData\Local\Temp\gm_ttt_44436\IDK.win
Writing Chunk... GEN8
Writing Chunk... OPTN
Writing Chunk... EXTN
Writing Chunk... SOND
Writing Chunk... SPRT
Writing Chunk... BGND
Writing Chunk... PATH
Writing Chunk... SCPT
Writing Chunk... FONT
Writing Chunk... TMLN
Writing Chunk... OBJT
Writing Chunk... ROOM
Writing Chunk... DAFL
Writing Chunk... TPAGE
Writing Chunk... CODE
Writing Chunk... VARI
Writing Chunk... FUNC
Writing Chunk... STRG
Writing Chunk... TXTR
0 Compressing texture... writing texture texture_0.png...
Writing Chunk... AUDO
Writing Chunk... SCPT
Writing Chunk... DBGI
Writing Chunk... STRG
-----------------------------------------------------------
executing C:\Users\edit\AppData\Local\Temp\gm_ttt_44436\IDK.win
-----------------------------------------------------------
RunnerLoadGame: C:\Users\edit\AppData\Local\Temp\gm_ttt_44436\IDK.win
#########################################################################
####!!!!$$$$$$ pwd - C:\Users\edit\AppData\Local\Temp\gm_ttt_44436
#########################################################################
RunnerLoadGame() - C:\Users\edit\AppData\Local\Temp\gm_ttt_44436\\IDK.win
Checking if INIFile C:\Users\edit\AppData\Local\Temp\gm_ttt_44436\/options.ini Exists
!!!!No INI File C:\Users\edit\AppData\Local\Temp\gm_ttt_44436\/options.ini
Process Chunk: SCPT 12
Process Chunk: DBGI 20
Process Chunk: STRG 43
Reading File C:\Users\edit\AppData\Local\Temp\gm_ttt_44436\\IDK.win
Loaded File C:\Users\edit\AppData\Local\Temp\gm_ttt_44436\\IDK.win
IFF wad found
Get Resolution
Get Header Information
InitGMLFunctions
HighScore..filename = C:\Users\edit\AppData\Local\IDK\\hiscore.dat
Reading highscore file
Finished reading highscore file = 00000000
finished reading HighScores!!
Game..Math..Graphic..Action..File..Resource..Interaction..3D..Particle..Misc..DS..Sound..DPlay..Physics..Gamepad..Buffers..Networking..YoYo..Fini
Code_Load()
ID_STRG
Create Window
AdjustWindowRectEx
RegisterClassEx
CreateWindowEx
Init Graphics
GR_D3D_Init()
Enable DwmEnableMMCSS
Create D3D9Ex interface
Enumerate Adapters
Selected Resolution: 640x480
Get Current Desktop Display Mode
Prepare to create device
Creating D3D device - ARGB=32bit, D24S8, SwapEffect=Copy, Hardware vertex processing
Creating screen render target
Get Device Caps
Graphics initialisation end...
Background_InitTextures()
Sprite_InitTextures()
Font_InitTextures()
IO Init
Process Messages
Splash!
SPLASH :: Start Frame
SPLASH :: Draw Clear
SPLASH :: DrawLogo
Compile finished: 2:06:38 PM
plasmor_88 Apr 1, 2013 @ 2:50pm 
Go to File, then go to Preferences.. A window with several tabs will appear, check the box that says 'Enable asset Compiler caching' then click OK.. then Hit F5 and your game should run, this is on the general tab and let me know how it goes. This will allow you to run the game in game maker, this is for game maker studio of course not too sure about the earlier versions but I imagine it's the same... I posted this on the other one this should help you
ashofmind Apr 1, 2013 @ 3:39pm 
resolved it thanks
Fraggelsmurf Apr 8, 2013 @ 12:54pm 
Thank you Plasmor_88! It worked after I enabled asset compiler caching!
Lazicful Apr 9, 2013 @ 2:05am 
It worked Plasmor, thanks. n_n
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Oct 16, 2012 @ 1:12am
Posts: 17