Vashta Nerada Mar 9, 2013 @ 7:42am
Unable to create directory
I can't run GM:S because everytime i try to create a Projekt an Error occurs: Unable to create directory i have no idea what i should do about it tried it with folder permissions...and failed. Any ideas?
Showing 1-5 of 5 comments
< >
FunInt3ntions Mar 12, 2013 @ 4:33pm 
Hey, I had the same problem. I fixed it by rolling back to a previous version. You can do that by right clicking on GM in your steam library, selecting properties, opening the Betas tab, and then selecting the version you'd like. current-1 worked for me. Hope that helps.
Vashta Nerada Mar 13, 2013 @ 3:43am 
Here is the solution:

open Regedit and go to HKEY_CURRENT_USER\Software\GMStudio_Steam\Version 1.0\Preferences. --> 5tudioKeyStoreFilename -->empty?-->yes-->fill in the path to your keystore by double-clicking the key and choosing to modify it (the path is typically C:\Users\[YOUR NAME]\AppData\Local\gamemaker_studio\keystore.keystore)

Thanks to Yoyogames support for the fast help!

Ghost
Agenerick Mar 28, 2013 @ 11:33am 
That's still not working for me but I have the normal version, not on steam but it looks the same in registry. I'll try downgrading.

#EDIT
Downgrading worked!
Last edited by Agenerick; Mar 28, 2013 @ 11:40am
Kelderan Mar 28, 2013 @ 1:01pm 
I can confirm that ghostrico666's solution worked fine for me. I had to create the 5tudioKeyStoreFilename as a String Value once I got to the area in regedit he mentioned. If you aren't comfortable making registry changes, I'd do some research first.
Weedman4201985 Apr 7, 2013 @ 4:29pm 
Originally posted by ghostrico666:
Here is the solution:

open Regedit and go to HKEY_CURRENT_USER\Software\GMStudio_Steam\Version 1.0\Preferences. --> 5tudioKeyStoreFilename -->empty?-->yes-->fill in the path to your keystore by double-clicking the key and choosing to modify it (the path is typically C:\Users\[YOUR NAME]\AppData\Local\gamemaker_studio\keystore.keystore)

Thanks to Yoyogames support for the fast help!

Ghost

Upon loading the program and either selecting a new project or starting with the tutorials i got this error. First before the error I would get a message stating that the keystore file would be overwritten. I would normally press ok then this error would appear. After much messing around, with the registry key stated above, uninstalling the program and removing all temp files, reinstalling it, messing around with permissions i still had the same problem.

However just by accident i found that if you keep pressing the no button when it asks you if you want to overwrite the existing keystore, the program/tutorial will still load, without the "unable to create directory". It loads the program, the tool bar and all the menus.

After this go to file-preferences menu and choose the Android tab (This was the only tab where I found anything regarding a keystore). The third option down the window states "Private Keystore File". I selected the browse button(...) and navigated to the directory where the keystore file was located and selected the keystore. I also removed the password option under the private keystore settings.

SUCCESS!!!!! I can now load the program and load a tutorial or create a new project WITHOUT this ANNOYING ERROR.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Mar 9, 2013 @ 7:42am
Posts: 5