Half Minute Hero: Super Mega Neo Climax Ultimate Boy
Charon Mar 25, 2013 @ 9:39am
Half hour hero
Recently I noticed an issue with this game. I attempted to play multiplayer with my brother and when we did I was shocked at how much faster he moved compared to my character.

After comparing what was going on it seems the game is running slower on my computer than on his. After realising this, I went back into single player and noticed that even there, my game is running slow. Patiently watching the timer reveals that a second in game, is actually around 2 and a bit seconds of real time.

As you can see from my system specs below, my machine is more than capable of running this game. What's going on? And how can I fix it?

System specs.

Processor: AMD FX(tm)-4170 Quad-Core Processor (4 CPUs), ~4.2GHz
Memory: 8192MB RAM
Video Card: AMD Radeon HD 7950 (3072MB GDDR5)
Operating System:
Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_rtm.101119-1850)
Showing 1-3 of 3 comments
< >
cowbell Mar 25, 2013 @ 9:57am 
You must be walking or he had fast gear.
Last edited by cowbell; Mar 25, 2013 @ 9:57am
Charon Mar 25, 2013 @ 10:39am 
Originally posted by cowbell:
You must be walking or he had fast gear.

You misunderstand me. I'm aware of how weight affects walking speed and how you can use circle (or the equivalent xbox button) to sprint. :P This is not the issue.

The problem is that my game is running at the wrong speed. If I play single player, my 30 second timer lasts 60 seconds. If we both play multiplayer, his timer goes up and down as it tries to sync to my slower timer and on his screen I appear to moving incredibly slowly, like one step at a time, he on the other hand appears to run round my screen at sprint speed even when he isn't sprinting.

It's similar to the bug in Saints Row 2 where the game would not correct itself to take into account different processor speeds.

To put it another way. Go to the map with Donovan on it in Hero 30 mode. In one thirty second timer, I can walk (not sprint) to the village at the top, then down to the mines and fight Donovan and then walk all the way back to the starting village without running out of time. :S

The really weird thing is... I do move at the correct speed inside the villages and inside combat, but on the world map it's like the game is running at half speed.
Last edited by Charon; Mar 25, 2013 @ 10:39am
Charon Mar 25, 2013 @ 11:01am 
Ok, this issue has resolved itself. I verified the cache, which redownloaded one file at 528 bytes. Initially, this made no difference but after doing it two more times the game now runs at the correct speed. I could tell it was fixed immediately when the initial 3, 2, 1 countdown took three seconds instead of nearly ten. >_<
Showing 1-3 of 3 comments
< >
Per page: 15 30 50