dreamZ Dec 15, 2012 @ 3:32am
[RESOLVED] Wont let me play?!
"DirectX Error : Stretchrect is invalid call"

Fatal Error
adress : [0x0049fa5a]
code : [STATUS_BREAKPOINT]

It was playing just fine all yesterday, now all of a sudden im getting this ♥♥♥♥♥♥♥♥ error. Help!
Last edited by dreamZ; Dec 28, 2012 @ 1:21am
Showing 1-6 of 6 comments
< >
dreamZ Dec 15, 2012 @ 3:13pm 
Ok this is starting to anger me, ive tried playing on a completely different computer, still ran into this problem. So it cant be on my side. Its something with either Steam, or the game itself.
AbyssalSoul Dec 15, 2012 @ 3:51pm 
Well, that does sound weird indeed. And it's a DirectX error so the first thing I would try to do is to, just in case, reinstall DirectX End User runtime to see if that fixes it. Sometimes those files seem to break for no reason.

Try retrieving and installing this to repair DirectX: http://www.microsoft.com/en-us/download/details.aspx?id=35

Hope that fixes it!
dreamZ Dec 15, 2012 @ 5:31pm 
Ive tried this before, and it says that my direct x is fine and doesnt need installing.
dreamZ Dec 28, 2012 @ 1:18am 
So apparently the easiest way to solve this is specific issue is to load the game, and hit Alt+enter which will force the game to be windowed mode.
Since the stretchrect error is an error consisting of (probably) a low resolution trying to be stretched into full screen.
So a simple force window mode will change all that, and you can then change your resolution and go full window mode after. Hope this helps for the people that experience this problem in the future.
Last edited by dreamZ; Dec 28, 2012 @ 1:20am
AbyssalSoul Dec 28, 2012 @ 5:10am 
Interesting! Glad you could solve it too, this one really was a bit strange. Btw, were you using a big TV screen or a monitor? Could help as a reference for the devs.
dreamZ Dec 28, 2012 @ 8:37pm 
I was using my LED monitor my max resolution is 1920 x 1080
Showing 1-6 of 6 comments
< >
Per page: 15 30 50