Vekyllis Feb 3, 2013 @ 10:30am
"It' Won't Be That Easy" Not Unlocking
I have tried all variations to get this achievement to unlock - I tried both Story mode and Free Play mode of the Prologue. I have jumped in as Isildur before killing the orcs and after killing the orcs. I have tried with Invinicibility turned on. I have tried with all red brick cheats turned off. I have played that scene over and over for about 50 times.

I have walked off the platform. I have jumped off the platform. I have Googled the problem and there doesn't seem to be much information on this glitch. Does anyone else have any insight as to why this might not be unlocking?

It is very frustrating to be only one achievement away from 100% and especially on one that should be this straight-forward. Is this a problem that Steam or the developers of LEGO The Lord of the Rings could patch?

Sincerely,
Frustrated Achievement Hunter :D
Showing 1-15 of 32 comments
< >
Dragon Feb 3, 2013 @ 12:16pm 
I did it in free play mode, isildur off top line, and jumped towards top of screen not bottom, off the bridge.
Vekyllis Feb 3, 2013 @ 8:07pm 
I just tried it again. Isildur off the top line in Free Play mode ... but no luck. :( I suppose as my last option I could delete my save file, uninstall Lego LoTR and re-install and try. Perhaps my file "thinks" it is achieved when it is not.
[NoNo]Sula Feb 5, 2013 @ 10:09pm 
+1 I cant get this one either. The last One. This achievement was gltich in PC version.
Even i try no cheat code in Story mode and Free mode.Reinstall game and del save files etc.
It doesnt work.So that's why it call "It' Won't Be That Easy" .
Vekyllis Feb 7, 2013 @ 2:28pm 
LOL Definitely a good reason to call it that!

Damn. Let's hope the developer or Steam will take note.
Skaery Feb 14, 2013 @ 3:28am 
Same problem here. =(
TheStickKid Mar 1, 2013 @ 6:23am 
Same. I messaged the creators of this game about this glitch and they haven't replied to me at all. I don't even think the creators have a fix for this glitch,
Blade12775 Mar 2, 2013 @ 4:12pm 
Jump off near the door to the bottom of the screen or the top of the screen. Make sure it's close to where the door is.
Vekyllis Mar 3, 2013 @ 5:47am 
I just re-installed it and tried jumping off near the door. I did both bottom of the screen and top of the screen, but no achievement. :( Ah well. Time to let it go ... LOL
golovorezkin Apr 12, 2013 @ 2:50am 
I have this bugggggggggg too. But I reinstall this game to another PC and this achievement open!
Inspector Gadget|UST Apr 19, 2013 @ 11:21am 
don't play it in "free play" play it in story mode. and jump towards the top.
Sastift Apr 22, 2013 @ 10:59am 
I jumped 1000 Times...nothing :(
I start a new game - nothing...
TheStickKid Jun 3, 2013 @ 8:14am 
Blade12775: Tried that. Didn't work.
Inspector Gadget: I did it both Story Mode and Free Play. Didn't work.
Ill try one more time, except on a different computer. If it unlocks, than this might be the only solution (to probably do it RIGHT when you begin the game the first time)
ReD DeViL Jun 30, 2013 @ 9:04am 
Same problem here. Anyone have a solution for this? It's very frustrating because it's the last achievement which is missing. :(
VAVLIE Jul 20, 2013 @ 6:49pm 
I have the exact same problem. Apparently a few pple who [maybe] had the same bug got this achievement by installing the game on another computer. I'm just waiting to borrow a friend's computer to try this, and hope it will work.
VAVLIE Jul 23, 2013 @ 9:59pm 
So I tried again yesterday just to show someone how it wasnt unlocking, and it did unlock. After so many attempts. I have no idea what was different this time, except maybe that i did it with a new save file (even though i already tried that before). Hope you'll get yours!
Showing 1-15 of 32 comments
< >
Per page: 15 30 50