Siberian_Bear Nov 30, 2013 @ 3:10am
Help! Bug where I can not complete the game 100%
In the mission "Track Hobbits" I have collected all of the items (shield, water Ents and something else, I do not remember), but during the mission I flew a game and they will not count... In the inventory they have, Pepin water-hit achievement received. But Mithril Ingot for it was not given and I can not make the last thing to go and the game 100% (just one is not enough, everyone else has already collected).
Does anyone know what can be done?...
Showing 1-5 of 5 comments
< >
Mung0 Dec 5, 2013 @ 5:28pm 
I have a similar problem, but on the Dead Marshes level. First time I played it on Free Play I somehow got 4/3 treasures (perhaps the bucket got counted twice? I dunno) anyway now it shows as 0/3 and won't give me the treasures on subsequent playthroughs because I already have them. I am one mithril short so I can't smith my last item. I'll keep looking for a solution.
Bassa Dec 8, 2013 @ 2:53am 
I think this is an error everyone has, meaning no one can complete the game 100%. The company released a code for people over 99% to use which will take it to the 100%, but I don't know what it is. :/
Mung0 Dec 8, 2013 @ 10:28pm 
I found a list of codes someone had posted on an xbox support forum and used one of them, which gave me all the items and characters and the associated achievements, but left me at 249/250 mithril and took me from 99.2% to 99.8%. So I decided to just start a fresh save and go through from the beginning again, to try and get that last achievement. I also read that avoiding the in-level save statues helps to prevent the problem, so I haven't used one yet on this playthrough.
DeadBabyJuggler Dec 9, 2013 @ 12:37am 
Recently played through this till 100%. I checked the forums first and as Mung0 said I read some people mentioning not to use in level save statues and also to not do co-op. For some reason it bugs up levels. Worked fine for me. Besides some buggy jumps that you have to get around all worked well. Good luck.
Thunderscunt Gibber Dec 14, 2013 @ 12:37pm 
I have found a solution!!!! Go to the tree where gollum (smeagol) stands, in front of the water bucket, you will going to see a red brick pick it up its going to count it because its the key of it, its worked for me, good luck!
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Nov 30, 2013 @ 3:10am
Posts: 5