Zorlac Jun 24, 2013 @ 11:06am
Performance of this game is abyssmal.
Literally, this is one of the worst running games I have ever played. Sure it's fine when you first start a map, but about half way through the framerate plummets. On the classic maps when I have a full set of towers out the game runs LESS than 10 fps on the lowest settigns if I actually watch the action. Keep in mind, my computer can run crysis, and crysis 2 at 60 fps on high settings. Not ultra, but high.

It's really saddening how badly this game runs as it has the potential to be so good.
Showing 1-15 of 26 comments
< >
[SVS] whyttrash  [developer] Jun 24, 2013 @ 12:08pm 
Originally posted by Zorlac:
Literally, this is one of the worst running games I have ever played. Sure it's fine when you first start a map, but about half way through the framerate plummets. On the classic maps when I have a full set of towers out the game runs LESS than 10 fps on the lowest settigns if I actually watch the action. Keep in mind, my computer can run crysis, and crysis 2 at 60 fps on high settings. Not ultra, but high.

It's really saddening how badly this game runs as it has the potential to be so good.

Zorlac,

Have you tried modifying your Graphic settings at all? If not, one recommendation that I would make is to lower the setting on SSAO (Low or Normal). You should see a big jump in performance from just that alone.

OOC, what video car are you running?
Willybach Jun 24, 2013 @ 12:40pm 
I had this proglem too. My PC just isn't powerful enouth for full graphics settings, especially when there's a screen full of Pepto HP regen and catapults etc. I have the settings down failry low, but I don't really notice the graphics that much - I never zoom in. Does anyone during a game?????? Seems a strange feature come to think of it.
Zorlac Jun 24, 2013 @ 1:25pm 
As I said in the OP I set EVERYTHING to low and it still does this. And my video card is a 560 ti.
Willybach Jun 24, 2013 @ 3:58pm 
oh yeah sorry didn't read it all obviously :)

[SVS] whyttrash  [developer] Jun 24, 2013 @ 6:23pm 
Zorlac,

The game is also fairly CPU heavy. What CPU do you have in your PC? I also know that this is one of the most hated questions asked...but when you run TW do you have other programs running in the background as well?

You commented on single player games, how is it when you play in a matched game vs. an opponent or with a friend in co-op?
Zorlac Jun 24, 2013 @ 6:30pm 
Originally posted by SVS whyttrash:
Zorlac,

The game is also fairly CPU heavy. What CPU do you have in your PC? I also know that this is one of the most hated questions asked...but when you run TW do you have other programs running in the background as well?

You commented on single player games, how is it when you play in a matched game vs. an opponent or with a friend in co-op?

Amd quad core 9600.

I only have fraps and xfire open though I've tried it without both and it makes no difference.

I've not tried multiplayer honestly. considering it's rendering more players, and actions I assumed it would be even worse in performance than single player was so I've stayed away so i didn't drag anyone else down.
1G.DABSX24/DAYX365/YEAR Jun 24, 2013 @ 7:38pm 
you will find that running it on a 386 powed rig with boxfan cooling still isnt enough for the modern game :/
1G.DABSX24/DAYX365/YEAR Jun 24, 2013 @ 7:39pm 
but seriously when running the game just set task TW.exe to high priority and it will run smooth on most older computers.
Zorlac Jun 24, 2013 @ 8:08pm 
Originally posted by professional pyro(highly paid):
you will find that running it on a 386 powed rig with boxfan cooling still isnt enough for the modern game :/


Yeah, you're helpful. It would be more helpful if you went away.
Areinha Jun 26, 2013 @ 7:56pm 
Try to set the game on high priority
Mune Jun 27, 2013 @ 5:10pm 
I too think something is holding this game back performance-wise, and it is one of the main reasons I haven't played it in a while. I've been keeping up to date on any patches that come out in case I hear anything about optimization, but unless I missed something, there hasn't been since beta. It's too bad because this game is great at it's core, but performance and limited map pool are holding it back in my humble opinion.

First, I'll give my computer specs since I'm sure that will come up in response. I made this computer myself with the sole purpose of playing games well, so I don't mind sharing either. :)

Processor - i5 3570k running overclocked at 4.2ghz, max temps of ~52 degrees C
Motherboard - ASRock Z77 Pro3
RAM - 16Gb DDR3 1600 not overclocked
Video Card - Radeon HD 7850 2Gb not overclocked, max temps of ~55 degrees C
Hard Drive - OCZ Vertex 4 256Gb
PSU - 530w Rosewill Green series

I fix computers for a living, have for 8 years, have a bachelors in CS and am A+ certified in 4 different fields (not trying to brag, just trying to give measurable data on my computer knowledge). I have my background processes stripped down to a bare minimum, and do not use an active antivirus.

a few game FPS comparisons:

Starcraft 2 - Ultra settings - constant 60 FPS (vsync) or 100+ FPS (no vsync)
Skyrim - Ultra+ (modified) settings - constant 60 FPS (vsync) or 80+ FPS (no vsync)
Planetside 2 - Medium settings - 40-100 FPS (no vsync)
Tower Wars - Lowest settings - 7 to 60 FPS (no vsync) and by lowest settings I mean bare minimum everything off or lowest

I'll generally get 60 FPS for the first 5 minutes or so of the game, and as the stuff on screen builds up, it gradually drops down to the lowest I've seen being 7 FPS on the snow level (lowest for the other levels more like 15-20 FPS or so).

I wont claim that it is definitely an optimization problem, as it could be some sort of hardware-specific bug or any number of other reasons. My best guess as to what it could be, based solely off of observations of when the frames drop or not, are particle effects and/or a problem with some textures. Snow on the snow level seems to take a heavy toll on my frames, for example. Other than that, just having alot of stuff going on will bog it down.

These performance problems have unfortunately impeded my ability to have fun with this game. I was willing to forgive it when the game was in beta, and had tons of fun playing this game for many hours despite the low frames. Now, no longer new, it is enough of a problem that I rarely play anymore.

As mentioned though, I eagerly await any sort of patch which might improve this problem, and I continue to check regularly on any updates just in case.

Please SVS, if you aren't already, please spend some time looking into this problem some more. If there is any way I can be of help, I'd be happy to oblige.
Last edited by Mune; Jun 27, 2013 @ 5:16pm
MAND4-senpai Jun 28, 2013 @ 4:06am 
I actually never had any issues with the game. In single player, when the heat is up, FPS sometimes drops to 20-25 but it's mostly far above. In multiplayer, it never drops below 30 even when the game goes for 30min or so and players have massive number of towers.

My specs: CPU i3-3.1GHZ
nvidia 430GT
RAM: 2x4GB

As far as I can see, I have lower spects than most of you complaining, but there's a possibility that I'm just a lucky guy xD
Mune Jun 28, 2013 @ 2:53pm 
Indeed, reports do seem to vary with some players having performance problems and some not, and it isn't as simple as having an underpowered rig. This makes me lean towards the problem being hardware-specific, as in a problem only with a certain video card series or something to that effect. I don't really know to be honest, but I can state with a high degree of certainty that this game should run better on my computer. Others seem to have similar problems, so it seems to be a real issue.
1G.DABSX24/DAYX365/YEAR Jun 28, 2013 @ 6:03pm 
U DIDNT READ MY COMMENT BELOW. CHANGE THE PRIORITY OF TW.EXE TO HIGH
Zorlac Jun 28, 2013 @ 7:19pm 
Originally posted by professional pyro(high n paid):
U DIDNT READ MY COMMENT BELOW. CHANGE THE PRIORITY OF TW.EXE TO HIGH

Doesn't help man, also chill your caps lock. It doesn't help.
Showing 1-15 of 26 comments
< >
Per page: 15 30 50