Deponia > General Discussions > Topic Details
sharl Oct 3, 2012 @ 6:09am
Missing Postage achievement
Weird. I'm pretty sure I did the right thing (give the orange cat espresso and give the white cat tranquilizer), managed to get _no_ stamp on the parcel and I still couldn't unlock the achievement no matter how many times I tried. Does anyone else have this problem?
Showing 1-7 of 7 comments
< >
sharl Oct 30, 2012 @ 4:28am 
That was the exact guide I was following, and it didn't unlock for me...
I guess this is another bug with the achievement system?
bradacus Nov 4, 2012 @ 3:30pm 
I just got this. You have to give the hamster wheel cat the espresso and postage licking cat the tranquilizer. (note - I got this before doing any other combo of stimulant on the cats and before the bubble wrap part, maybe this makes a difference not sure)
Last edited by bradacus; Nov 4, 2012 @ 3:31pm
A.J Dandy Nov 7, 2012 @ 11:19am 
DOH! I just missed this as I over written my save after giving the robot bubble wrap, I should have looked at the achievement list before hand *cries*
Basost Nov 24, 2012 @ 2:48pm 
Originally posted by sharl:
That was the exact guide I was following, and it didn't unlock for me...
I guess this is another bug with the achievement system?
I had the same problem. I did some debugging and found out my profile.dat (%localappdata%\Daedalic Entertainment\Deponia\Savegames) was corrupted (don't know why). It turns out the game keeps an internal list of achievements it thinks it's given out, and it wrongfully thought it already gave me this one (nr. 6, same problem with nr. 10: Newton would be proud).

The game regenerates the list correctly (by asking Steam) if you delete profile.dat, but that means you lose the extras and droggeljug mode if you've unlocked those, so back it up if you want those back. Unfortunately loading a saved game will restore the corrupt achievement list, so you have to play the game from the start again to the point of the achievement. But really that only takes about 15 minutes if you know the puzzles and skip the animations (press esc to skip, and double click doors).

If you want to look at your profile.dat, learn some Java and use this.
String[] profile = new BufferedReader(new FileReader("C:\\Users\\USERNAME\\AppData\\Local\\Daedalic Entertainment\\Deponia\\Savegames\\profile.dat")).readLine().split("\0");
byte[] keyBytes = new byte[profile[1].length()/2];
for (int i=0; i<profile[1].length()/2; i++)
keyBytes[i] = (byte) Integer.parseInt(profile[1].substring(i*2,i*2+2));
String cipher = profile[2];

String hash = "";
byte[] digest = MessageDigest.getInstance("SHA-1").digest(keyBytes);
for (byte b : digest)
hash += Integer.toString((b & 0xff) + 0x100, 16).substring(1);

String data = "";
for (int i=0, hashIndex=0; i<cipher.length()/5; i++)
data += (char) (Integer.parseInt(cipher.substring(5*i, 5*i+5))/hash.charAt((hashIndex++)%40));
System.out.println(data);
Writing to profile.dat it is left as an exercise to the reader ;) don't forget the \0 at the end.
(@dev: I don't mean to intrude, I'll remove the code if you don't like it)
Last edited by Basost; Nov 24, 2012 @ 3:01pm
sharl Nov 25, 2012 @ 9:29pm 
@Basost : Thanks for the input, I'll try to delete profile.dat and play the game again from the beginning. I guess I'm in no hurry though, this whole thing rather dampens my motivation to finish the game... :-/
Master Duggi Jul 8 @ 10:12pm 
I had the same problem. All achivements being unlocked but this one, and playing from a saved gave didn't help. So the workaround was this:
- turn off cloud sinchronisation for Deponia in Steam
- delete all files from C:\Users\Andrei\AppData\Local\Daedalic Entertainment\Deponia\Savegames
- begin the game anew and play to the achivement point (just 15 minutes when you already know what to do)

It worked for me and I got this achivement.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50