Yme Jun 4, 2013 @ 12:26pm
Crashes on launch
When I hit play, the screen goes black, then the game stops working, and it takes me back to the config tool. I'v ttried different settings, and different resolutions, but nothing works.
I'v tried running as administrator aswell.

I read some where that people have this problem when running the game on a computer thats using a TV as a monitor, but I could not find any solution for my problem.
Showing 1-15 of 20 comments
< >
Raze Jun 4, 2013 @ 1:25pm 
Did you try starting the config tool and/or game directly, from the 'Divine Divinity' install folder?

Did you check out the suggestions / links in the discussions Having issues or Game Crash - Can't start, etc?
Last edited by Raze; Jun 4, 2013 @ 1:28pm
Yme Jun 4, 2013 @ 2:43pm 
I tried both starting the game directly, as well as through the config tool.

I did read this part, that was supposed to fix the problem:

"So all i did was go into CCC and enable gpu scaling under properties digital flat panel. I also ran avast under silent and gaming mode, but it did not work until i change the properties in CCC. Hope this helps someone else!"

Only problem is that I have no idea what CCC is :-P
Raze Jun 4, 2013 @ 4:33pm 
CCC is the Catalyst Control Centre, for an ATI video card. There should be a similar option somewhere in the Nvidia Control Panel, or within the driver display settings.
Last edited by Raze; Jun 4, 2013 @ 4:36pm
Yme Jun 6, 2013 @ 2:07am 
I found a similar setting, but it doesnt help. It's still the same black screen, then a "devine divinity stopped working".

I'v tried using the "test" buttong aswell, after changing settings, but that never works ither. It lauches a black screen that I have tro alt tab to find, that never goes away before I alt tab to find an error message that it failed to launch.
Raze Jun 6, 2013 @ 5:39am 
When you click the Test button in the configuration program, you should get a message that it is going to start the test, and after you click OK (or, strangely, the red 'close window' button) the screen should turn black for a second before the test image is shown for the (10 second) duration of the test.

Do you have a monitor handy you could try, just to confirm or eliminate the TV as the source of the problem?

You can try emailing support@larian.com, with a description of the problem and maybe a link to this discussion, though I'm not sure they would have many suggestions that haven't been mentioned here or in links already.
Yme Jun 6, 2013 @ 7:22am 
I'll see if I can get hold of another monitor, and see if that helps.

When I run the test, it tels it is going to start. I press "ok" and the screen turns black all the way untill i tab out of it ( waited for more than 10 seconds, and there was no test image), then I get the message "Uanble to read configuration file-Exiting". Somet times, before that error, I get "initialisation of this mode failed".

I'll send an e-mail to larian, with a link to this thread. Would be cool to get to play the game ;-P

Edit. If I run the config tool from the gamefolder, I get a "Failed to launch devine divnity: 740"
Last edited by Yme; Jun 6, 2013 @ 7:35am
Raze Jun 6, 2013 @ 2:04pm 
Were you trying to use a TV, or did you just mention that as a similar type of crash? If you are using a monitor, I don't think a different monitor would be likely to help.

Did you try switching to Software mode rather than Direct3D?
Running the configuration program or game as administrator may help if being unable to read the files is a permissions issue.

With the disk version there were a couple people who had a problem with the game creating the configuration files in Direct3D mode, but if they already existed the game would start. If you wish, you could try downloading my config files[members.shaw.ca], extract them into your 'Divine Divinity' install folder (backup/move the existing versions first, if you wish, or delete mine if they don't help and verify local files for the game), edit the config.div file in Notepad (or other text editor) to set the desired resolution, and see if the game will start.

Hopefully the '740' error will help support narrow down the problem.
Last edited by Raze; Jun 6, 2013 @ 2:05pm
The Dude Jun 20, 2013 @ 7:56pm 
I have the same problem as OP, including the errors and failure of the config tests. I have tried all possible settings and resolutions. My monitor/TV is 1920x1080 native as well. I tried editing the config file, but the settings there are correct even when the test fails. On launch I get a black screen, clicks from the speakers presumably as the sound initializes, then CTD with the standard windows 'appcrash' dialog box. I am running a 7970Ghz using HDMI out, latest non-beta drivers. Tried adjusting GPU scaling to no effect, though I suspect the problem is along that lines as the screen does some funky stuff after it fails typical of a failed resolution change.
looserbaby Aug 4, 2013 @ 2:16pm 
Same problem, almost a bit worse. I get the black screen when I start the game or the confiq, both from steam or from the folder, the confiq asks me to choose resolution and such and no matter what I choose, my PC locks up on the black screen, no music no nothing, have to reset the PC each time. running in admin and turning off firewall and anti virus does nothing to help. First steam game I have bought that does not work AT ALL! :(
Yme Aug 4, 2013 @ 4:38pm 
I was never able to solve the problem, even when contacting the develoupers, but if you get the game from gog.com, it works fine, for some reason...
Raze Aug 4, 2013 @ 5:49pm 
That is strange. GOG has the same version of the game as Steam, except that you need to manually add the music fix[www.gog.com], while it is already included with Steam. Maybe a difference in how the game is installed, or where?


looserbaby
Maybe try moving/copying the Divine Divinity install folder to another location (like c:\games) and try starting the game from there, without the Steam client running. If the cause of your problem is the same as Yme, maybe that will help.
Last edited by Raze; Aug 4, 2013 @ 6:28pm
looserbaby Aug 4, 2013 @ 8:50pm 
It's already in my games folder and not the "confusing to some games (Programs(x86)", does not make a difference if I start from steam or directly, always the same black screen :(

After each of my black screen freezes (yes I have to reset the PC) steam tells me that 3 files are currupted and downloads them again, it does not help though.
Compatability mode does not help either.

And yme never solved it..... hope fading....

Seriously feel ripped off :(
Last edited by looserbaby; Aug 4, 2013 @ 8:55pm
Raze Aug 4, 2013 @ 10:58pm 
The 3 'corrupted' files may be configuration files that don't get properly updated. Did you try my config files (link/description above)?

Do you want to give the GOG version a shot? PM me in the GOG forum (Raze_Larian) for a gift code (pretty sure I have one left).
Last edited by Raze; Aug 4, 2013 @ 11:48pm
looserbaby Aug 5, 2013 @ 5:45am 
pfff.. my antivirus program tells me that the website your confiq files are on, is a dangerous site that might plant vira on my PC. So no, I have not tried those.
I might try the GOG version, I just don't understand why all this is needed, I bought this on steam, so it should work on steam... yes?
Last edited by looserbaby; Aug 5, 2013 @ 5:49am
Raze Aug 5, 2013 @ 12:45pm 
Your anti-virus program is apparently using some less than optimal heuristic rules; zipped text files can not spread a virus. As for being dangerous, my ISP will not allow uploads of executable files (no install files or self extracting archives, etc) as an over zealous anti-virus measure, and made a deal with an anti-virus company to give the program to all their customers.

Yes, it should work on Steam. If you've tried everything in the links above, etc, it seemed worth a shot to try the GOG version, since that worked for Yme.
Last edited by Raze; Aug 5, 2013 @ 12:49pm
Showing 1-15 of 20 comments
< >
Per page: 15 30 50