Xander51 Dec 23, 2012 @ 7:14pm
Windows 8 Direct 3D Issues / Woes
I finally started playing this game again after having it on my "must play" list for a while , and I'm having issues in Windows 8. I've found reports elsewhere that the Direct3D renderer is slow in Windows 8, and sure enough I have that issue. The save game functionality is also weird. It saves a shot of the last 2D element I looked at rather than my gameplay screen for the little save thumbnail. Also, all the load times are really slow probably due to the framerate issues.

Now, I've seen elsewhere that the solution is to use the Software renderer, and sure enough this improves the framerate and load times a great deal. However, the lighting isn't quite as good, and many of the effects like the fog and the little swirl when I use the teleport pyramid don't display correctly. It's workable, but not ideal.

On my quest to have a "perfectly playing" version of the game, I've tried the old config tool, but it won't launch. I tried installing the old demo, setting it to Glide, copying the config files over to my full game install, and using a Glide wrapper to play the game. This works fairly well, except the transparencies don't function quite right and the game would only work correctly in 4:3. Also, it crashed every time I exited. I also noticed doing all this that the demo has nice full screen wipe transitions betweeen areas and cutscenes, which seem to have been removed from the full version of the game.

I know this is a lot of text to say "this doesn't work totally right in Windows 8," but hopefully this information is useful to someone out there. What are the chances of Larian fixing the Direct3D issues? The software renderer is workable till then, just wish I could play this game with all the effects working.

My machine has a Core i7 975 at 4 Ghz, 6 gigs of RAM, an Nvidia GeForce 660ti, and Windows 8. I'm still loving the game in spite of all this, but it's so close to perfect as far as performance that it has really frustrated me.
Showing 1-15 of 21 comments
< >
Raze Dec 23, 2012 @ 10:46pm 
When set to Direct3D, did you try running the game as administrator, and in Win98/ME compatibility mode?

I'm not sure there are many suggestions you haven't tried yet, but you could check the GOG forum topics Divine Divinity running very slow and clunky[www.gog.com] and Game is Running Very Slow[www.gog.com].
Xander51 Dec 24, 2012 @ 6:34am 
Oh yes, believe me, I spent about 2 days trying just about everything I could think of or find online. :) I really appreciate the suggestions though. Even the old demo runs at about 35 FPS with slowdown during the game in Direct3D mode, so I'm guessing it's either something to do with Windows 8 and/or Nvidia's current driver set. Again, I appreciate it!
krashd Jan 26, 2013 @ 4:54am 
i run the game in software and it is identical to direct 3d, but 10x faster.
Xander51 Jan 26, 2013 @ 11:36am 
It's not actually identical, there are several effects missing and worse lighting. But you're right, it is faster!
hexaae Feb 11, 2013 @ 4:12pm 
Try to set through Microsoft ACT tool the fix for "Simple windows"... I've read it fixes some slowdown issues with old d3d games on Win8....
Xander51 Feb 12, 2013 @ 2:08am 
Hmm I've never heard of this tool/fix before. Thanks for pointing it out, I'll look into it!
paracelsusx Apr 24, 2013 @ 5:24pm 
Did you ever find a solution?
Xander51 Apr 24, 2013 @ 6:39pm 
Sadly, no.
Squid Apr 24, 2013 @ 11:08pm 
This is probably your only real soloution:
http://www.youtube.com/watch?feature=player_embedded&v=dpGvBZD0q4A

:)
Raze Apr 24, 2013 @ 11:35pm 
You could try using the disk version configuration tool to set the game to use Direct Draw, and see if that works better than Software mode without the performance problems of Direct3D (it's worth a shot, anyway). This GOG forum post[www.gog.com] contains a download link[www.mediafire.com], or you can use the version from the demo, if you still have it installed.
Xander51 Apr 24, 2013 @ 11:57pm 
Squid - I saw that, looks really cool!
Raze - That GoG forum post is a treasure trove of stuff, thanks for the link! Even with the game running imperfectly, it's still playable on Windows 8, just not ideal.
Kablam0 Jul 4, 2013 @ 9:58am 
Originally posted by Raze:
You could try using the disk version configuration tool to set the game to use Direct Draw, and see if that works better than Software mode without the performance problems of Direct3D (it's worth a shot, anyway). This GOG forum post[www.gog.com] contains a download link[www.mediafire.com], or you can use the version from the demo, if you still have it installed.

Hi Raze.

I have the same exact issues as Xander has posted. My specs are - W8 64bit, I5, GTX 650 - and the game is simply unplayable in D3D mode. The extremely long loading times are as bad as the lagging and lurching.

I attempted to use the old DD config tool, but whenever I opened it, all that I would get was a pop-up with a yellow (!) on it - it just will not open to allow configuring the game to use Direct Draw.

Running the game in software mode is litterally the only solution for me, but the detrimental change to the graphics quality is just too noticeable for me to fully enjoy the game.

This issue with D3D mode has got to be attributed to either Windows 8 or nVidia - maybe both, as the entire game is not accessing system hardware properly (GPU, CPU, Ram, and even the Hard Drive).

I am redownloading the game, and have disabled 'Execute Disable Bit', in my BIOS (DEP) - and I have disabled Windows Defender 'Real Time Monitoring' and User Account Controls as well.

I will post back with my results.

Edit: Raze, I am going to send you a friend request (I hope you don' mind), as you are a great and trusted Divine Divinity resource, and maybe we could mp in the future when the new Larian games are released.
Last edited by Kablam0; Jul 4, 2013 @ 10:16am
Kablam0 Jul 4, 2013 @ 10:07am 
Originally posted by hexaae:
Try to set through Microsoft ACT tool the fix for "Simple windows"... I've read it fixes some slowdown issues with old d3d games on Win8....

Have you done this yourself and could you post your experience? I actually went to the site and read up on it a bit, but I am just not tech savvy enough to confidently use such a tool - the instructuions and options on the page made me dizzy, and I am fearful of completely mucking up my system.

Maybe I just didn't understand what I was reading, as I am an "advanced novice' pc user at best.
Kablam0 Jul 4, 2013 @ 11:14am 
Well, disabling all of that did absolutely nothing. It looks like it is either software mode, or no mode at all. The fog and shadows still work in software mode, but the color depth must be 16 bit, becuse it looks pretty grainy and washed out.

If anybody has any solutions or tweaks, it would be nice if you could post them.
Kablam0 Jul 4, 2013 @ 1:16pm 
Software mode actually looks really good, what worked better for me to alleviate the semi washed-out look, was to set (in the options/video/visual settings) the gamma to 90, and then the darkness to 25. It really brought back the richness of the lighting, and the shadows are darker and more pronounced.

Hopefully I am not coming across as a graphics nit-picker, but now, even in software mode, the game looks and performs wonderfully.

It is time once again to get my *ss thoroughly kicked, and my spirit crushed - and I wouldn't have it any other way. I love this game.
Last edited by Kablam0; Jul 4, 2013 @ 1:16pm
Showing 1-15 of 21 comments
< >
Per page: 15 30 50