Dwarfs F2P > General Discussions > Topic Details
Brizon Sep 9, 2013 @ 8:35am
Game won't start on Linux (Ubuntu 13.04 x64)
Game update: AppID 213650 "Dwarfs F2P", ProcID 3694, IP 0.0.0.0:0
Stacktrace:

at (wrapper managed-to-native) Dwarves.xSteamWrapper.InitializeSteam (intptr) <0xffffffff>
at DwarfsWindows.Program.Main (string[]) <0x00047>
at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

./libmono-2.0.so.1(+0xaa2c0) [0xf74592c0]
./libmono-2.0.so.1(+0xec830) [0xf749b830]
./libmono-2.0.so.1(+0x1fc38) [0xf73cec38]
[0xf76de410]
/lib/i386-linux-gnu/libc.so.6(+0x8e1cf) [0xf72691cf]
/home/me/.local/share/Steam/ubuntu12_32/libtier0_s.so(ThreadSetDebugName+0x30) [0xf54a3bee]
./libtier0_s.so(+0x14ac1) [0xf52e6ac1]
./libtier0_s.so(+0x1d8fa) [0xf52ef8fa]
./libtier0_s.so(+0x6dcf) [0xf52d8dcf]
/lib/ld-linux.so.2(+0xf1d5) [0xf76ee1d5]

Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted
Game removed: AppID 213650 "Dwarfs F2P", ProcID 3694
Last edited by Brizon; Sep 9, 2013 @ 8:35am
Showing 1-5 of 5 comments
< >
humblepac Sep 9, 2013 @ 8:07pm 
They dont care, it's been like this for months.
ShatteredSoul Sep 12, 2013 @ 10:15am 
If they dont care,they should remove it from the game list...
mirivlad Sep 23, 2013 @ 8:44pm 
Same error on Ubuntu 13.04 x86_64 :(
giner Jul 26 @ 12:49pm 
I remember Dwarfs FTP working some time ago (it was my first installation of Steam) however now I can't make it run on any Ubuntu from 12.04 to 14.04 both architectures i386 and amd64. I also tried not to load shipped libraries and use provided by a system instead but nothing worked in any combination.

Could anybody suggest any combination of Linux distribution / version to try?
Showing 1-5 of 5 comments
< >
Per page: 15 30 50