Dwarfs F2P > General Discussions > Topic Details
Mascota May 30, 2013 @ 4:56am
Linux Users: Don't even try
I downloaded the game and tried to play about 15 times. Only 5 actually "worked", showing me the start screen with an amazing lag (at least it let me close the game properly).
I only could play once, but it was really laggy.

My computer isn't the best, but it meets the "recommended requirements". Also I can play heavier games without problems.
I don't know if it performs well in better machines, but all those posts about bugs and crashes aren't a good signal.

It will be great if they can fix the game, or, at least, modify the Requirements list so people like me don't feel disappointed.
Showing 1-15 of 24 comments
< >
m93a.cz Jun 16, 2013 @ 9:01am 
For me (Ubuntu 12.04 LTS) works fine.
Thorwaldsson  [developer] Jun 18, 2013 @ 5:27am 
What version of Linux is you running on your computer?

//Thorwaldsson
Mascota Jun 19, 2013 @ 7:16am 
Ubuntu 12.04 LTS too.
MrTheSoulzツ Jul 6, 2013 @ 7:09am 
this could be GOU driver related, chck them out :)
Artemis3 Jul 9, 2013 @ 8:38am 
Mine doesn't even launch... Xubuntu 12.04.
smaug42 Aug 2, 2013 @ 3:57am 
Doesn't launch for me in Linux either... click Play... nothing. No windows drawn, no activity on top... nothing.
[TSG] Apples Aug 4, 2013 @ 11:20am 
Can't get it to run either.
Any fix yet for Ubuntu 12.04 LTS?
rt1805 Aug 4, 2013 @ 12:58pm 
Does not start with Ubuntu 13.04. No error message, nothing. - Any hints?
[TSG] Apples Aug 4, 2013 @ 1:57pm 
Originally posted by rt1805:
Does not start with Ubuntu 13.04. No error message, nothing. - Any hints?
Seems to be missing a executable due to a error. We will have to wait for the fix.
HumbleLinux Aug 5, 2013 @ 7:10am 
Originally posted by rt1805:
Does not start with Ubuntu 13.04. No error message, nothing. - Any hints?
+1. Any updates on this?
rt1805 Aug 6, 2013 @ 11:35am 
Ok, i tried the check for the game data. The checks says that there is a file missing and that this file has to be downloaded again. The next check says everything is fine. But nothing changes, the game does not start without any message.

I checked the game folder and found the following executables:
- Dwarfs_Bundle.exe
- DwarfsLinux.exe
- DwarfsLinux1.exe

Besides the third check of the game data says that there is a missing file again. This repeats until infinity. ;-)
Last edited by rt1805; Aug 6, 2013 @ 11:38am
de.nagical[linux] Aug 11, 2013 @ 4:05am 
Same here. Doesn't even launch. Console:

Game update: AppID 213650 "Dwarfs F2P", ProcID 25122, IP 0.0.0.0:0
Stacktrace:

at (wrapper managed-to-native) Dwarves.xSteamWrapper.InitializeSteam (intptr) <0xffffffff>
at DwarfsWindows.Program.Main (string[]) <0x00047>
at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

./libmono-2.0.so.1(+0xaa2c0) [0xf747d2c0]
./libmono-2.0.so.1(+0xec830) [0xf74bf830]
./libmono-2.0.so.1(+0x1fc38) [0xf73f2c38]
linux-gate.so.1(__kernel_rt_sigreturn+0) [0xf772e410]
/lib32/libc.so.6(+0x844b6) [0xf72754b6]
/play/.local/share/Steam/ubuntu12_32/libtier0_s.so(ThreadSetDebugName+0x30) [0xf3388b16]
./libtier0_s.so(+0x14ac1) [0xf335aac1]
./libtier0_s.so(+0x1d8fa) [0xf33638fa]
./libtier0_s.so(+0x6dcf) [0xf334cdcf]
/lib/ld-linux.so.2(+0xf185) [0xf773e185]

[...]


Thread 1 (Thread 0xf4d27740 (LWP 25122)):
#0 0xf772e430 in __kernel_vsyscall ()
#1 0xf72ce46b in read () from /lib32/libc.so.6
#2 0xf747d4bf in ?? () from ./libmono-2.0.so.1
#3 0xf74bf830 in ?? () from ./libmono-2.0.so.1
#4 0xf73f2c38 in ?? () from ./libmono-2.0.so.1
#5 <signal handler called>
#6 0xf72754b6 in __strncpy_ssse3 () from /lib32/libc.so.6
#7 0xf3388b16 in ThreadSetDebugName () from /play/.local/share/Steam/ubuntu12_32/libtier0_s.so
#8 0xf335aac1 in ?? () from ./libtier0_s.so
#9 0xf33638fa in ?? () from ./libtier0_s.so
#10 0xf334cdcf in _init () from ./libtier0_s.so
#11 0xf773e185 in call_init () from /lib/ld-linux.so.2
#12 0xf773e2a4 in _dl_init_internal () from /lib/ld-linux.so.2
#13 0xf7742297 in dl_open_worker () from /lib/ld-linux.so.2
#14 0xf773e04a in _dl_catch_error () from /lib/ld-linux.so.2
#15 0xf7741ae4 in _dl_open () from /lib/ld-linux.so.2
#16 0xf6f6bcbc in dlopen_doit () from /lib32/libdl.so.2
#17 0xf773e04a in _dl_catch_error () from /lib/ld-linux.so.2
#18 0xf6f6c38c in _dlerror_run () from /lib32/libdl.so.2
#19 0xf6f6bd81 in dlopen () from /lib32/libdl.so.2
#20 0xf33afd04 in ?? () from ./libsteam_api.so
#21 0xf33b01ad in ?? () from ./libsteam_api.so
#22 0xf33b06d3 in SteamAPI_Init () from ./libsteam_api.so
#23 0xf33c69ce in SteamWrapper::InitializeSteam() () from ./libSteamLinux.so
#24 0xf33c6b7b in InitializeSteam () from ./libSteamLinux.so
#25 0xf3518c24 in ?? ()
#26 0xf3512dd8 in ?? ()
#27 0xf3512f0f in ?? ()
#28 0xf73f72a2 in ?? () from ./libmono-2.0.so.1
#29 0xf75567f4 in mono_runtime_invoke () from ./libmono-2.0.so.1
#30 0xf755c148 in mono_runtime_exec_main () from ./libmono-2.0.so.1
#31 0xf755e9f6 in mono_runtime_run_main () from ./libmono-2.0.so.1
#32 0xf7453912 in mono_jit_exec () from ./libmono-2.0.so.1
#33 0xf7455441 in mono_main () from ./libmono-2.0.so.1
#34 0x080489e3 in main (argc=1, argv=0xffbcff74) at temp.c:206


At the very wild guess I'd say it does some b0rked steam init and/or callback
de.nagical[linux] Aug 11, 2013 @ 4:23am 
Ok, I can run it. Somehow the game brings kinda its own steam with it, which collides with the one running (I guess). If I do the following it starts up:

chmod -rwx libX11.so.6 libsteam.so libtier0_s.so libvstdlib_s.so steamclient.so

Run in the games folder this removes read, write and executable rights to those specific libraries, which either steam provides or the system (in case of libX11).

As always YMMV.


P.S. WTH are there so many backup files (*.*~) in the game tree?
HumbleLinux Aug 11, 2013 @ 6:39am 
Thanks for your efforts de.nagixal

Although I will rather leave my hands out of this, considering the devs seem to not even be able to make the game run normally via steam and seem to not even care enough to fix it for so long.
Last edited by HumbleLinux; Aug 11, 2013 @ 6:44am
de.nagical[linux] Aug 11, 2013 @ 7:18am 
Urks, it still crashes on quit. On x86_64 if it crashes it tends to hang (actually it emits SIGSTOP) steam. Doesn't seem to happen if calling 'i386' first to pseudo-arch to x86. Anyway it allowed me to achieve the 40000k-gold-achievement, which I only wanted in the first place. I must say I still like boulderdash clones more, probably because one is the 'dwarf' there eheh. Anyway nice graphics, but the missing stability ruins the game experience. Still I wonder if the paid full version suffers the same problems...
Showing 1-15 of 24 comments
< >
Per page: 15 30 50