ThunderPX Nov 22, 2012 @ 8:09am
Game doesn't launch
I can't start the game; using the launcher crashes as soon as I press "Save settings and launch", and going into /steamapps/ and starting the main EXE crashes instantly. I've already tried verifying the cache and reinstalling, and even got someone else's config file since the launcher crashed before it could make one.
Showing 1-15 of 24 comments
< >
KAIΣAΡ Nov 22, 2012 @ 6:01pm 
same here please help!
ezodagrom Nov 22, 2012 @ 6:05pm 
Originally posted by NaziSlaughterHousePotatoes:
same here please help!
In the case of ThunderPX, the launcher didn't show any resolutions in the resolutions option, is it the same for you?
ThunderPX Nov 22, 2012 @ 6:08pm 
I actually fixed this. I'm not sure how or why this works, but try changing the resolution and refresh rate in the game's config to 640x480 and 60Hz, respectively. Then launch the game. If you can't do that because of the crashing launcher, go into steamapps/common/Sonic Adventure 2/config, create a UserConfig.cfg file and put in this:

<?xml version="1.0" ?>
<Configs FullScreen="1" Display="0" Res="22" Width="640" Height="480" RefreshRate="60" Language="0" Analytics="0" />

You may also need to manually make the Keyboard.cfg file, which looks like this:

<?xml version="1.0" ?>
<Setup Layout="0" />
<Players>
<Player InputWay="1" Vibrate="0">
<key index="83" />
<key index="65" />
<key index="73" />
<key index="79" />
<key index="5" />
<key index="52" />
<key index="56" />
<key index="54" />
<key index="25" />
<key index="16" />
<key index="37" />
<key index="23" />
<key index="4" />
<key index="37" />
<key index="27" />
<key index="67" />
</Player>
<Player InputWay="0" Vibrate="0">
<key index="22" />
<key index="18" />
<key index="0" />
<key index="3" />
<key index="102" />
<key index="98" />
<key index="101" />
<key index="99" />
<key index="66" />
<key index="104" />
<key index="37" />
<key index="76" />
<key index="105" />
<key index="37" />
<key index="28" />
<key index="111" />
</Player>
</Players>

At any rate, after I changed the resolution the game suddenly did start. If it works so far, exit the game, go back into UserConfig.cfg and change the resolution and refresh rate to whatever you wanted in the first place.

Hope this helps!
KAIΣAΡ Nov 23, 2012 @ 6:25am 
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
same here please help!
In the case of ThunderPX, the launcher didn't show any resolutions in the resolutions option, is it the same for you?
no i cannot even run the launcher. i actually haven seen any peice of the game not even the launch screen because the first thing i get when i press play on steam is "launcher.exe has stopped working
ezodagrom Nov 23, 2012 @ 6:44am 
Originally posted by NaziSlaughterHousePotatoes:
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
same here please help!
In the case of ThunderPX, the launcher didn't show any resolutions in the resolutions option, is it the same for you?
no i cannot even run the launcher. i actually haven seen any peice of the game not even the launch screen because the first thing i get when i press play on steam is "launcher.exe has stopped working
First, what are your PC specs, your processor, graphics card, and operative system (windows version)?
Try installing .NET Framework 3.5, someone else mentioned before that the launcher needs this installed.
Last edited by ezodagrom; Nov 23, 2012 @ 6:45am
KAIΣAΡ Nov 23, 2012 @ 7:01am 
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
same here please help!
In the case of ThunderPX, the launcher didn't show any resolutions in the resolutions option, is it the same for you?
no i cannot even run the launcher. i actually haven seen any peice of the game not even the launch screen because the first thing i get when i press play on steam is "launcher.exe has stopped working
First, what are your PC specs, your processor, graphics card, and operative system (windows version)?
Try installing .NET Framework 3.5, someone else mentioned before that the launcher needs this installed.

- processor: AMD Phenom(tm) II x61045T 2.70 GHz
- Nvidia GeForce GTX 460
- operative system: windows 7 64 - bit
ezodagrom Nov 23, 2012 @ 7:17am 
Originally posted by NaziSlaughterHousePotatoes:
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
same here please help!
In the case of ThunderPX, the launcher didn't show any resolutions in the resolutions option, is it the same for you?
no i cannot even run the launcher. i actually haven seen any peice of the game not even the launch screen because the first thing i get when i press play on steam is "launcher.exe has stopped working
First, what are your PC specs, your processor, graphics card, and operative system (windows version)?
Try installing .NET Framework 3.5, someone else mentioned before that the launcher needs this installed.

- processor: AMD Phenom(tm) II x61045T 2.70 GHz
- Nvidia GeForce GTX 460
- operative system: windows 7 64 - bit
Oh, just noticed that you posted in another topic where I suggested to install several microsoft runtimes, hmm, it is really strange that the game isn't working for you...
In the other topic someone mentioned that the game crashes alot when using Steam Big Picture mode, so if you have it, open the game with the normal overlay.

Don't know what else you can try...Your PC is more than capable, maybe try installing more recent graphics drivers, or running windows update which could install something that could be missing, dunno. :\
Last edited by ezodagrom; Nov 23, 2012 @ 7:18am
KAIΣAΡ Nov 23, 2012 @ 7:25am 
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
Originally posted by ezodagrom:
Originally posted by NaziSlaughterHousePotatoes:
same here please help!
In the case of ThunderPX, the launcher didn't show any resolutions in the resolutions option, is it the same for you?
no i cannot even run the launcher. i actually haven seen any peice of the game not even the launch screen because the first thing i get when i press play on steam is "launcher.exe has stopped working
First, what are your PC specs, your processor, graphics card, and operative system (windows version)?
Try installing .NET Framework 3.5, someone else mentioned before that the launcher needs this installed.

- processor: AMD Phenom(tm) II x61045T 2.70 GHz
- Nvidia GeForce GTX 460
- operative system: windows 7 64 - bit
Oh, just noticed that you posted in another topic where I suggested to install several microsoft runtimes, hmm, it is really strange that the game isn't working for you...
In the other topic someone mentioned that the game crashes alot when using Steam Big Picture mode, so if you have it, open the game with the normal overlay.

Don't know what else you can try...Your PC is more than capable, maybe try installing more recent graphics drivers, or running windows update which could install something that could be missing, dunno. :\

really!? man ok i tried even sending steam support messages and got no answer... this is crazy! im trying the drivers but if that doesnt work what the hell? i bought a game i cant play! thanks anyway man really apreciate the help!

if it can help at all check here http://steamcommunity.com/app/213610/discussions/0/882966056794790542/
i posted some error code that might be useful! thanks for all your time!
ezodagrom Nov 23, 2012 @ 7:45am 
Originally posted by NaziSlaughterHousePotatoes:
really!? man ok i tried even sending steam support messages and got no answer... this is crazy! im trying the drivers but if that doesnt work what the hell? i bought a game i cant play! thanks anyway man really apreciate the help!

if it can help at all check here http://steamcommunity.com/app/213610/discussions/0/882966056794790542/
i posted some error code that might be useful! thanks for all your time!
After a bit of searching around, well, I could be wrong, but it seems like the error may be related to .NET Framework.
Last edited by ezodagrom; Nov 23, 2012 @ 7:45am
TheColorRed Nov 25, 2012 @ 4:16am 
Originally posted by ThunderPX:
I actually fixed this. I'm not sure how or why this works, but try changing the resolution and refresh rate in the game's config to 640x480 and 60Hz, respectively. Then launch the game. If you can't do that because of the crashing launcher, go into steamapps/common/Sonic Adventure 2/config, create a UserConfig.cfg file and put in this:

<?xml version="1.0" ?>
<Configs FullScreen="1" Display="0" Res="22" Width="640" Height="480" RefreshRate="60" Language="0" Analytics="0" />

You may also need to manually make the Keyboard.cfg file, which looks like this:

<?xml version="1.0" ?>
<Setup Layout="0" />
<Players>
<Player InputWay="1" Vibrate="0">
<key index="83" />
<key index="65" />
<key index="73" />
<key index="79" />
<key index="5" />
<key index="52" />
<key index="56" />
<key index="54" />
<key index="25" />
<key index="16" />
<key index="37" />
<key index="23" />
<key index="4" />
<key index="37" />
<key index="27" />
<key index="67" />
</Player>
<Player InputWay="0" Vibrate="0">
<key index="22" />
<key index="18" />
<key index="0" />
<key index="3" />
<key index="102" />
<key index="98" />
<key index="101" />
<key index="99" />
<key index="66" />
<key index="104" />
<key index="37" />
<key index="76" />
<key index="105" />
<key index="37" />
<key index="28" />
<key index="111" />
</Player>
</Players>

At any rate, after I changed the resolution the game suddenly did start. If it works so far, exit the game, go back into UserConfig.cfg and change the resolution and refresh rate to whatever you wanted in the first place.

Hope this helps!

Okay so I am trying to get mine working and my problem sounds a lot like yours, however my incompitense at computers has caused me to make a fool out of myself by even asking this but.
Is the Refresh rate Config in the game settup screen that pops up right after hitting play(On Steam) or in the files, because I dint see a 640x480 setting in the settup screen... ><
ThunderPX Nov 25, 2012 @ 10:09am 
Change it in UserConfig.cfg. If your problem's anything like mine the launcher doesn't work anyway, you should skip it and just launch sonic2app.exe from your Steam/steamapps/common/Sonic Adventure 2 folder.
TheColorRed Nov 25, 2012 @ 8:21pm 
I tried that but I still got the crash "sonic2App has stopped working" so I think we have two different problem.
All my Drivers are as up to date as possible, but my laptop is still pretty old so I dont expect it to work. I figured its such an old game that I figured my computer could handle the port.
If you would like me to post my System specs just ask.
ezodagrom Nov 25, 2012 @ 8:35pm 
Originally posted by TheColorRed:
I tried that but I still got the crash "sonic2App has stopped working" so I think we have two different problem.
All my Drivers are as up to date as possible, but my laptop is still pretty old so I dont expect it to work. I figured its such an old game that I figured my computer could handle the port.
If you would like me to post my System specs just ask.
Yes, it would be better if you posted your specs.
TheColorRed Nov 25, 2012 @ 9:13pm 
This is from the DirectX Diagnostic tool.

Device-
Name: Mobile Intel(R) 945 Express Chipset Family
Manufacturer: Intel Corporation
Chip Type: Intel(R) GMA 950
DAC Type: International
Approx. Total Memory: 256 MB
Current Display mode: 1680 x 1050 (32 bit) (60 Hz)
Monitor: Generic PnP Monitorz

Drivers-
Main Driver: igdumd32.dll
Version: 8.15.10.1930
Date: 9/23/2009
WHQL Loo'd: Yes
DDI Version: 9Ex
Driver Model: WDDM 1.0
Last edited by TheColorRed; Nov 25, 2012 @ 9:16pm
Sue Nov 25, 2012 @ 9:20pm 
Originally posted by TheColorRed:
This is from the DirectX Diagnostic tool.

Device-
Name: Mobile Intel(R) 945 Express Chipset Family
Manufacturer: Intel Corporation
Chip Type: Intel(R) GMA 950
DAC Type: International
Approx. Total Memory: 256 MB
Current Display mode: 1680 x 1050 (32 bit) (60 Hz)
Monitor: Generic PnP Monitorz

Drivers-
Main Driver: igdumd32.dll
Version: 8.15.10.1930
Date: 9/23/2009
WHQL Loo'd: Yes
DDI Version: 9Ex
Driver Model: WDDM 1.0

Although you have a very low specs but it shouldn't lead to crashing issue.

Have you tried to install Visual C++ 2008 Redist and .NET Framework 2? I also got crashing in sonic2app.exe when I tried SA2 in other computer, and I found out it doesn't have VC++ 2008 installed.
Last edited by Sue; Nov 25, 2012 @ 9:20pm
Showing 1-15 of 24 comments
< >
Per page: 15 30 50
Date Posted: Nov 22, 2012 @ 8:09am
Posts: 24