edge lord Feb 28, 2013 @ 6:38am
The Port is Bad,The game is nostalgicly good.
The port for this game is so terrible,even for an old game the following problems i had are true:

1.Can't launch the game due to "Sonicapp2.exe" error or whatever it is

2.Like those screenshots the screen goes into seizure mode

3.Screen starts flickering (happens mostly)

Holy mother of god the port is just so bad there needs to be a new word to discribe "Bad,Terrible,Horrendous" into one word.

Edit:I swear i am not trolling.
Last edited by edge lord; Mar 8, 2013 @ 7:24pm
Showing 1-15 of 56 comments
< >
Sera Feb 28, 2013 @ 10:33am 
Correction, port is bad for "some" people. Not for many others. Stop crying... If you were only a little smart, you'd figure that not everyone have those issues. The port is like the gamecube for me. Can't really have better unless you expect a kind of wii remake for PC.
edge lord Feb 28, 2013 @ 10:34am 
Originally posted by Sera:
Correction, port is bad for "some" people. Not for many others. Stop crying... If you were only a little smart, you'd figure that not everyone have those issues. The port is like the gamecube for me. Can't really have better unless you expect a kind of wii remake for PC.

I know that some people don't have this problem,i had this game on the GC version.
Nanomachines Mar 1, 2013 @ 10:43am 
Having a flawless experience with this masterpiece sucks for you mate
edge lord Mar 1, 2013 @ 11:09am 
Originally posted by Clyde le noir Nordique:
Having a flawless experience with this masterpiece sucks for you mate

Yeah ._.
Sacred Myths Mar 2, 2013 @ 6:45am 
It's actually a good port imo, plays just like the version I got on XBL arcade.
edge lord Mar 2, 2013 @ 6:48am 
Originally posted by 帝国 Sacred_Myths:
It's actually a good port imo, plays just like the version I got on XBL arcade.

50% of the time the game crashed before i can get to the title screen...

now it crashes every time i enter Chao Race
Sera Mar 2, 2013 @ 7:50am 
Blame your computer, not the port.
edge lord Mar 2, 2013 @ 9:58am 
Originally posted by Sera:
Blame your computer, not the port.

I don't see anything wrong with my computer.
SCP-789-J Mar 2, 2013 @ 2:23pm 
If it can't run the game, then LOGICALLY you'd think something is wrong with your computer.

sense make the what
edge lord Mar 2, 2013 @ 2:24pm 
If it can't run the game, then LOGICALLY you'd think something is wrong with your computer.

sense make the what

No,the game runs and works perfectly,is just that it crashes every so often for no reason.
SCP-789-J Mar 2, 2013 @ 2:26pm 
Then reinstall it.
Sera Mar 2, 2013 @ 5:12pm 
Considering that the port works perfectly for me and many others as if I played the Gamecube then by logic, the port is clearly not the issue. Computers are customizable material systems so yeah. If you get an issue with it then blame your computer. Better yet, search for solutions to make it work. Check the files or do as the comment above says and reinstall it, etc.
King of Koopas Mar 2, 2013 @ 9:14pm 
Port is only ok. I've had a lot of flicker errors but I ignored them after a while. However I don't like the glitches. Psyics in some areas is very wonky, hero fruit fills stamina faster then nomral, tree models don't grow properly, I got stuck on an invisable piece of gyomratery on eternal engine. Still most of these didn't hinder the fun of the game, and after a 100% playthrough I"m glad I can say I still enjoy it after all thee years
Sera Mar 2, 2013 @ 9:46pm 
Yeah, it's some minor glitches that I sometimes get myself but none are gamebreaking. Check SA1 if you think SA2 is glitched... I was stuck here and there in many stages. None were gamebreaking but the difference was very noticeable.
Byrnvif Mar 3, 2013 @ 9:30am 
you know sometimes i feel like only 10 people (including me) in the world dont have this problem, for me this is better than the gamecube
Showing 1-15 of 56 comments
< >
Per page: 15 30 50
Date Posted: Feb 28, 2013 @ 6:38am
Posts: 56