Luscifer Nov 27, 2012 @ 7:20pm
I can't get pass the launcher, Please Help!
I wan't to play this game really bad but i can't get past the launcher. See here for the error [s7.postimage.org]

My specs are the following:
- NVIDIA GeForce GTS 360M
- Intel Core i7 CPU Q720 @ 1.60GHz
- Ram 6077MB

Take note in the picture how the Resolution selection bar is empty, extending the list reveals nothing.. i literaly CANNOT chose a resolution.

Please answer quickly, thank you all in advance
Showing 1-15 of 17 comments
< >
ezodagrom Nov 27, 2012 @ 7:54pm 
Someone else had a similar issue to yours, but he managed to find a workaround:


Originally posted by ThunderPX:
I actually fixed this. I'm not sure how or why this works, but try changing the resolution and refresh rate in the game's config to 640x480 and 60Hz, respectively. Then launch the game. If you can't do that because of the crashing launcher, go into steamapps/common/Sonic Adventure 2/config, create a UserConfig.cfg file and put in this:

<?xml version="1.0" ?>
<Configs FullScreen="1" Display="0" Res="22" Width="640" Height="480" RefreshRate="60" Language="0" Analytics="0" />

You may also need to manually make the Keyboard.cfg file, which looks like this:

<?xml version="1.0" ?>
<Setup Layout="0" />
<Players>
<Player InputWay="1" Vibrate="0">
<key index="83" />
<key index="65" />
<key index="73" />
<key index="79" />
<key index="5" />
<key index="52" />
<key index="56" />
<key index="54" />
<key index="25" />
<key index="16" />
<key index="37" />
<key index="23" />
<key index="4" />
<key index="37" />
<key index="27" />
<key index="67" />
</Player>
<Player InputWay="0" Vibrate="0">
<key index="22" />
<key index="18" />
<key index="0" />
<key index="3" />
<key index="102" />
<key index="98" />
<key index="101" />
<key index="99" />
<key index="66" />
<key index="104" />
<key index="37" />
<key index="76" />
<key index="105" />
<key index="37" />
<key index="28" />
<key index="111" />
</Player>
</Players>

At any rate, after I changed the resolution the game suddenly did start. If it works so far, exit the game, go back into UserConfig.cfg and change the resolution and refresh rate to whatever you wanted in the first place.

Hope this helps!
Luscifer Nov 28, 2012 @ 10:30am 
I did as it says... the same error happens but with one difference...

In the error line: InvalidArgument=Value of '22' is not valid for 'index'

The "22" that used to be a "0" in the previously posted picture, changes to whatever is the value of the "RES" attribute in the following line: <Configs FullScreen="1" Display="0" Res="22" Width="640" Height="480" RefreshRate="60" Language="0" Analytics="0" />

I've already tried changing it to many other values but with no success.

On an added note, the resolution selection box is still blanc
ezodagrom Nov 28, 2012 @ 11:12am 
Originally posted by Gopher:
I did as it says... the same error happens but with one difference...

In the error line: InvalidArgument=Value of '22' is not valid for 'index'

The "22" that used to be a "0" in the previously posted picture, changes to whatever is the value of the "RES" attribute in the following line: <Configs FullScreen="1" Display="0" Res="22" Width="640" Height="480" RefreshRate="60" Language="0" Analytics="0" />

I've already tried changing it to many other values but with no success.

On an added note, the resolution selection box is still blanc
I completely forgot to mention something, after creating the config files, you have to open the game directly through sonic2app.exe, and not through the launcher.
Last edited by ezodagrom; Nov 28, 2012 @ 11:13am
Luscifer Nov 28, 2012 @ 2:17pm 
Funny how such a small detail make such a big difference...

It works, thank you.
ezodagrom Nov 28, 2012 @ 2:29pm 
BTW, if you want to be able to open the game from the steam library, you can try changing the name of launcher.exe to sonic2app.exe, and change the name of sonic2app.exe to launcher.exe.
This way opening the game through the steam library should open the game directly, instead of the launcher.
Last edited by ezodagrom; Nov 28, 2012 @ 2:29pm
Tom Nov 28, 2012 @ 2:38pm 
I get the same unhandled exception error, and also can not pick any resolution through the launcher at all, none show up. This fix that you linked doesn't work for me, once I make the config files and try to run sonic2.app nothing happens.

Steam support have been no help.
Last edited by Tom; Nov 28, 2012 @ 2:49pm
Tom Nov 28, 2012 @ 2:41pm 
NVM I'm an idiot. Had this problem for days and I fixed it in 5 seconds. For some reason it won't work if I have my first display selected.

Give that a go if you have multiple displays.
Last edited by Tom; Nov 28, 2012 @ 2:50pm
Agx13 das SynchTroller Dec 30, 2012 @ 6:39am 
I had the same error which i fixed with this. But when i started it, it had an EXTREMLY slow speed on everything exept the sounds. Is there a way to double the speed?
Agx13 das SynchTroller Dec 30, 2012 @ 6:39am 
I had the same error which i fixed with this. But when i started it, it had an EXTREMLY slow speed on everything exept the sounds. Is there a way to double the speed?
SuperMegaBoy Mar 12, 2013 @ 4:10pm 
Originally posted by Bugnizzle:
NVM I'm an idiot. Had this problem for days and I fixed it in 5 seconds. For some reason it won't work if I have my first display selected.

Give that a go if you have multiple displays.
What do you mean by multiple displays? I made the file with no help. When i try to launch the sonic2.app it directs me to a windows problem notifying me that windows has a problem with it, could somebody please help?
TRAVDAGG Mar 13, 2013 @ 7:31pm 
it will work just uncheck fullscreen mode thats the only way it will work on my rig and i have two gtx titans sli
SuperMegaBoy Mar 13, 2013 @ 8:23pm 
Originally posted by TRAVDAGG:
it will work just uncheck fullscreen mode thats the only way it will work on my rig and i have two gtx titans sli

I tried to uncheck the full screen mode, but it still isn't playable. I start getting a windows tab telling me that windows has experienced a problem and needs to close the window.
ChaosController Mar 20, 2013 @ 11:27am 
I am having exactly the same problem. When I changed the resolution in the file, and went onto the game, it just switched back to 800x600 in the launcher again, and promptly crashed when I tried to open the game. None of the fixes I have found have worked so far.
.JezMM May 20, 2013 @ 6:10pm 
I kept getting this problem (but not every time, just restarting the game over and over and over without changing anything and/or making sure I had as few other programs as possible open would eventually work). Overall I've had next to no crashes since I bought the Battle DLC. Considering it costs money to do so it's a little bit of a risk, but you never know.
SuperMegaBoy May 21, 2013 @ 6:02am 
Ok thank you. I'll buy the DLC.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Nov 27, 2012 @ 7:20pm
Posts: 17