pixelation Jan 13 @ 4:28pm
Cant create account, registration down? edit: issue solved
Not sure if registration is down or not, but is anyone else unable to sign up for an account? Ive tried chrome and firefox (fill out form, blank page upon submitting) and IE (http 500 internal server error upon submitting)

Edit: solved issue today, all I did was change the password I was planning to use to not include symbols
Last edited by pixelation; Jan 14 @ 1:20pm
Showing 1-6 of 6 comments
< >
Valamar Jan 13 @ 4:50pm 
Nothing posted on Twitter or Facebook -- quit/reboot/try-again.
whiteytrav Jan 13 @ 11:22pm 
I'm having the same exact problem. chrome and firefox give a blank page, IE gives the same error.
Walidovich Jan 14 @ 2:26pm 
problem i have this message: your submission contained an error. please try again.
pixelation Jan 14 @ 3:24pm 
from what i've read that is a common issue with missing info on the form, invalid characters, and possibly just an already taken name
whiteytrav Jan 14 @ 7:09pm 
Confirmed, remove special characters from your password.
Revelation May 8 @ 3:59pm 
i cant create too this is my problem

Your submission contained an error. Please try again. Code: #FTx6GQ2YGKH
Showing 1-6 of 6 comments
< >
Per page: 15 30 50