Capt. Hicks 12. feb, 2013 @ 6:20pm
A little choppy
I've just got the game and can't even get it started without lag, choppy music and visuals. I've signed up to the bata. When I launch the game it gets stuck on the SAGA logo and the sound is choppy. Anything I can do make it run smoothly?
Sist redigert av Capt. Hicks; 12. feb, 2013 @ 6:21pm
Viser 1-15 av 17 kommentarer
< >
Kodizzle 12. feb, 2013 @ 6:32pm 
post specs of your pc
Capt. Hicks 13. feb, 2013 @ 5:21am 
Don't think it's a pc problem as I can run games like Skyrim and Assassin's Creed 3 without any problems. Maybe because the game it still in bata?

Windows 7
AMD M880G with ATI Radeon HD 4250
AMD Radeon HD 6470M
AMD Phenom II P960 Quad-Core Processor
Homer Pimpson 13. feb, 2013 @ 6:23am 
BATA? you sir, are lulzy
Capt. Hicks 13. feb, 2013 @ 8:08am 
Sir? really... So no help then...
[DFS] Green Giant 13. feb, 2013 @ 8:15am 
Opprinnelig skrevet av Quinn:
Sir? really... So no help then...
Are you using the beta version? Try the non-beta version. Also, try to enable V-Sync.
Capt. Hicks 13. feb, 2013 @ 9:42am 
Tried non-beta and also reinstalling it. Still can't past the loading screen
Sist redigert av Capt. Hicks; 13. feb, 2013 @ 9:42am
Capt. Hicks 13. feb, 2013 @ 11:40am 
The game also keeps stopping responding. Finally at the main menu and it's very laggy/ choppy/ really slow
S0L  [utvikler] 13. feb, 2013 @ 11:44am 
In the launcher you should be able to choose the GPU you want to use. I'd pick the better one of those two which will be the 6470M at a guess.

If it's defaulting to the other, good chance it will run slowly. Is that a laptop BTW, strange to see that kind of dual GPU setup if not?

The game is fully released BTW. The Beta thread is where we're making sure the update to address some issues doesn't cause anything new and serious. We're holding off pushing that live to everyone whilst we get to the bottom of some odd framerate hits on the Samba track.

---
S0L
---
Capt. Hicks 13. feb, 2013 @ 11:51am 
Yes, it's a laptop. In the launcher I can choose the AMD Radeon HD 6470M only. Will graphics setting do anything to help? Never had this sort of problem with any other game.
Sist redigert av Capt. Hicks; 13. feb, 2013 @ 11:52am
S0L  [utvikler] 13. feb, 2013 @ 11:55am 
Opprinnelig skrevet av Quinn:
Yes, it's a laptop. In the launcher I can choose the AMD Radeon HD 6470M only. Will graphics setting do anything to help? Never had this sort of problem with any other game.

I'd try the resolution at either 1366x768 or 1280x720. Try medium settings first with Vsync enabled.

Laptop GPU's are generally slower than desktop ones, but I'd expect about 25+fps with those kind of settings.

It's definitely worth checking you are on recent drivers too, many laptops ship with very old drivers and updating them can usually yeild a good performance increase across the board.

Sometimes it also helps to check that in the Power Setting you are running at High Performance when gaming too. It'll eat the battery quicker though!

---
S0L
---
Capt. Hicks 13. feb, 2013 @ 12:01pm 
Highest power setting, reduced the resolution and the graphic settings. Drivers are all recent. Anything else I could try?
S0L  [utvikler] 13. feb, 2013 @ 12:16pm 
Are there any applications running that are installed by the laptop manufacturer? It's rare but sometimes other applications can slow the game down. Sometimes they offer an option to switch which GPU is used in via a taskbar icon, it's worth checking.

I'm not convinced it's not attempting to use the integrated GPU. Are both listed when you look in the Device Manager via the System Settings (under Display Adapters).

We get around 25fps on a HD3000 with an equivelent processor, the Radeon should be a little faster, so this one is a mystery.

---
S0L
---
Capt. Hicks 13. feb, 2013 @ 12:18pm 
Nope, only one is listed. Like I said, never had this problem before and I play all the recent games.
S0L  [utvikler] 13. feb, 2013 @ 12:28pm 
OK, so only one GPU listed under Device Manager. At least we know that the other is likely disabled then.

Have you tried the Beta branch, previously we had issues where high fps translated into low fps as we were flooding the driver. Getting that branch and trying the game full screen with the vsync enabled should yield better performance on laptops and mobile GPU's. I'd start there.

If that doesn't work, try one of the windowed modes. If you see an improvement, it could be another application is stealing focus (i.e. trying to grab the window). Windowed modes ignore these screen grabs.

If that doesn't seem to be making a difference, check your Anti-virus is set to game mode. Sometimes AV can restrict loading files, which will slow the loading down dramatically.

Outside of that, or obvious things like rendering HD movies in the background... I'm kind of stumped. It's certainly should have the power to run the game. I'd need to get a close look at the actual system to figure it out though. What make and model is it?

---
S0L
---
Capt. Hicks 13. feb, 2013 @ 12:32pm 
Would it make a difference with Beta branch I use?
Viser 1-15 av 17 kommentarer
< >
Per side: 15 30 50
Dato lagt ut: 12. feb, 2013 @ 6:20pm
Innlegg: 17