Sonic & All-Stars Racing Transformed
Demacia's Broken Toaster Jan 31, 2013 @ 8:56pm
Xbox360 Controller Will not work?
Ok, my xbox360 usb Controller is on, even tested another game and it worked, but everytime i try to start Sonic & All-Stars Racing Transformed, My controller will not work, i can't hit any buttons. I even went to the Configure before starting the game and it does not show up as one of my options for a controller setting eather. I'm very confuzzled on why my Xbox360 Usb will not work on this game yet works on all my other steam games?
Showing 1-15 of 19 comments
< >
[PPP] Shadow Remix Jan 31, 2013 @ 9:13pm 
Do you have the Microsoft Xbox 360 Controller driver? http://www.microsoft.com/hardware/en-us/d/xbox-360-controller-for-windows

Is the controller wired, or does it use a wired adapter (Meaning you have a USB cable that plugs into the controller and the computer)?
Demacia's Broken Toaster Feb 1, 2013 @ 12:17am 
I remeber doing the whole driver thing to get it working for my other games. Windows 7 64bit it was. And its wired, hooks directly to the labtop. I can turn on one of my other games and just have it instantly working. but it just seems it does not exist or something when i try to play it for Sega All-Star Racing Transformed.
WiCKeDNaSTy Feb 1, 2013 @ 12:28am 
Hook up the controller, restart the laptop. Open the game Config. See if you can see the controller and configure it.
rafcor Feb 1, 2013 @ 6:44am 
You must turn on the controller BEFORE starting the game/configuration, otherwise it won't work. And if you will play local multiplayer, all the controllers must be activated before starting the game, no matter what, the game just accepts it this way
Demacia's Broken Toaster Feb 1, 2013 @ 9:37am 
I tried both solutions and both did not work. Restarted the labtop many times. never saw it in the Config. When i plug in my controller to the labtop its always on untill i unplug it. All that shows up is Keyboard1, no xbox360 controller.
Crimson Feb 1, 2013 @ 4:11pm 
i got the same problem...
and something funny, i cant play with my xbox360 controller, but if it's plugged when i play with keyboard, vibration is working.
Demacia's Broken Toaster Feb 1, 2013 @ 9:03pm 
Yes i noticed that too! the controller will vibrate yet i can't use it at all! I really hope there is a solution to this problem.
Hergard Dec 6, 2013 @ 12:36pm 
Any solution to this problem?
Last edited by Hergard; Dec 6, 2013 @ 12:36pm
S0L  [developer] Dec 6, 2013 @ 12:41pm 
Make sure you use the controller to bypass the 'Press Start to play!' screen, as if you use the keyboard it assumes you want to use that for Player 1.

---
S0L
---
Hergard Dec 6, 2013 @ 12:58pm 
But it doesn't respond at all, I have xbox controller
Hergard Dec 6, 2013 @ 3:20pm 
Do I need any kind of emulator or not?
Veiled Endless Dec 6, 2013 @ 7:02pm 
having same issues
cato911 Dec 6, 2013 @ 7:33pm 
Me too. Could have made a sale but I've got better things to do with my time (other games) than jump through hoops for this. Looks fun though.
SirDrexl Dec 6, 2013 @ 7:42pm 
I don't know what to say. I think I had to enable it in the config utility first, but once I did that it worked fine. I'm not sure if it's relevant, but the config uses .NET 4, so you might want to check Windows Update and see if there are updates available.

Other than that I don't know why it wouldn't work. Do you have any other controllers/joysticks connected? I've heard of games that will only "see" the first controller connected and ignore others.
cato911 Dec 7, 2013 @ 5:03am 
Originally posted by S0L:
Make sure you use the controller to bypass the 'Press Start to play!' screen, as if you use the keyboard it assumes you want to use that for Player 1.This worked for me.
When the game prompts you to press start DO NOT touch the keyboard. Press A on cotroller and navigate with that. The interface on this game is kinda f***ed up (nowhere near as bad as Burnout Paradise) but its a lot of fun.

---
S0L
---
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Jan 31, 2013 @ 8:56pm
Posts: 19