Sonic & All-Stars Racing Transformed

Sonic & All-Stars Racing Transformed

Voir les stats:
Configure for gamepads without the Configure setting?
I have a Logitech Rumblepad 2 USB Gamepad, It work on every other game just fine, no problem. But when I try to configure this game, it takes control of my mouse and moves it constantly to the top left of the screen and any changes, get moved to that button. Tried it ingame no problem, but I want to configure it with like an .ini file or something. Anyway I can do that?
Dernière modification de Lizard; 31 janv. 2013 à 11h48
< >
Affichage des commentaires 1 à 15 sur 43
I am experiencing this exact problem with my logitec wireless USB controller as well.
Lizard 31 janv. 2013 à 10h39 
I found a configure setting in the files. Documents/SART

But I have no idea what it is I'm looking at.
And before someone gets 'cute' and recommends unplugging the mouse when we're in configure, that doesn't work. It appears to be a problem with our Logitect constantly telling the game up and left.
Reconfiguring the controller from the control panel doesn't seem to help. From that interface, the controller is neutral until I move the sticks.
Dernière modification de TheMightyBorlaug; 31 janv. 2013 à 10h42
Yeah it forces +upleft, which makes it impossible to assign your controlls. Buggar. :B

Oh well. Hope it's fixed ASAP. My controller doesn't have "go forewards" as a thing by default.
Dernière modification de Balblair; 31 janv. 2013 à 10h43
Same here with a PS2 Controller with an USB adapter
Lizard 31 janv. 2013 à 10h44 
Cean a écrit :
Yeah it forces +upleft, which makes it impossible to assign your controlls. Buggar. :B

Oh well. Hope it's fixed ASAP. My controller doesn't have "go forewards" as a thing by default.

Haha! Yeah. Exactly what I did when I got in game. I was just sitting there. It was hilarious.
Liz a écrit :
Cean a écrit :
Yeah it forces +upleft, which makes it impossible to assign your controlls. Buggar. :B

Oh well. Hope it's fixed ASAP. My controller doesn't have "go forewards" as a thing by default.

Haha! Yeah. Exactly what I did when I got in game. I was just sitting there. It was hilarious.

Yeah, poor Pyro was starting getting bored just sitting there. :S The idle animations are great, though.
Lizard 31 janv. 2013 à 10h53 
They are quite nice. I guess I'll have to use my keyboard until there's a way to fix this.
Same on Mayflash Gamecube usb adapter
I have the same problem as the original poster. Random mouse movement in config mode, no "go forward" in game. I have a wired Logitech gamepad.
I am going to check to see if us Logitech users can use the profiler that came with our controllers to force attribute controls to the keybinds. I'll let you know what I find.
The fix is very easy

Download x360ce and use that program to emulate the 360 controller. It will work as it solved it for me.
Lizard 31 janv. 2013 à 11h28 
While that might be a temp fix. I do want a permanent fix sometime soon.
Rupple 31 janv. 2013 à 11h29 
You can readjust all the controls on the logitec gameplay to match the keyboard settings
Rupple 31 janv. 2013 à 11h36 
Confirmed and work. Open logitec gamepad config and remap all the gamepad keys to the keyboard key equivilant. Then Open game and get racing
< >
Affichage des commentaires 1 à 15 sur 43
Par page : 15 30 50