StealthDemon Mar 9, 2013 @ 8:12am
Error Cant Initialize Renderer Current D3D video device is not supported by the game
Cant Initialize Renderer
Current D3D video device is not supported by the game
Showing 1-15 of 18 comments
< >
edwin.gibson Mar 9, 2013 @ 5:13pm 
I'm geting this too. Any advice on how to get past it?
Haxton's Festive Left Nipple Mar 10, 2013 @ 3:31am 
What kind of video card do you have?
StealthDemon Mar 10, 2013 @ 5:27am 
Intel(R) G33/G31 Express Chipset Family 2009
Haxton's Festive Left Nipple Mar 10, 2013 @ 6:40am 
It's most likely because, your videocard below the minimum requirement.
Most of the Integrated video cards not able to run complex 3D games. But these kind of problems could be caused by outdated drivers/DirectX.
Evan-Almighty Mar 10, 2013 @ 10:27am 
I have the same problem with an NVIDIA GTX 295, just the first bit though and not the ' device is not supported by the game '
Haxton's Festive Left Nipple Mar 10, 2013 @ 11:47am 
Make sure you have installed the latest DirectX and Nvidia driver (GeForce 314.07 Driver the latest).
Or maybe you can try this: http://www.ehow.com/how_6698248_fix-direct3d.html
Evan-Almighty Mar 10, 2013 @ 2:17pm 
Realised I didnt have the latest driver, still no luck. I am getting this error now : WARNING| frame 2643 gameGlobals.frameTimeReal is too large (0.405689)
TOGM95 Mar 13, 2013 @ 2:12am 
I Have that too. You need to update your D3D Renderer. Later i try to give you a link of a D3D Renderer
alex_tg Mar 13, 2013 @ 3:08am 
Here is the list of unsupported video devices:
Radeon X700 - X850 and lower (X850, X800, X700, 9550, 9200 etc)
GeForce series 5 and lower (5950, 5600 etc)
GeForce 6200
Intel GMA (GMA 500, GMA 600 etc)
Radeon series x1000 (X1800, X1900, X1950 etc)
ikeyboardturn123 Mar 16, 2013 @ 9:27pm 
....wow Radeon series x1000 unsupported... can you ♥♥♥♥ing post that on the ABOUT GAME in the beginning so people dont even waste there time?..... @steam
2MuchCoffeeMan Mar 18, 2013 @ 1:20am 
wha ? but the x1000 series means like 75% of all the mobile ati device around ?

hm, ok ...... thats harsh ....
Last edited by 2MuchCoffeeMan; Mar 18, 2013 @ 1:20am
arbaskara0 Jun 10, 2013 @ 6:17am 
Really? The X1000 series? Are you kidding me?? This game looks great, I've downloaded it, and now I can't play it...
Last edited by arbaskara0; Jun 10, 2013 @ 6:30am
*Mühendis.™ Aug 13, 2013 @ 6:10am 
I was see 5 min ago this error and now installing DirectX wtf. not solved this problem fuuuuu.
[WFD]Usthebgo Aug 14, 2013 @ 7:54pm 
I have this error pop up also, however I have the same graphics card as my friend and he can play however I cant.....
2MuchCoffeeMan Aug 15, 2013 @ 4:14am 
are oyu guys running on the same drivers ???? if not, go install the exact same version as him :)

and same operating system ?
Last edited by 2MuchCoffeeMan; Aug 15, 2013 @ 4:14am
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Mar 9, 2013 @ 8:12am
Posts: 18