eLe|Subjugator Mar 5, 2013 @ 1:05pm
Bug: Keyboard input is blocked on OS X.
The game worked fine the first night I had it installed, I tried to launch the game today and for some reason all keyboard input is blocked, I get the "bonk" noise as if I'm trying to type in a field that is filtering my keys. SHIFT+TAB will still bing up the Steam console, but all other keys are blocked while the game is running, I have to crash to the desktop using CMD+ALT+SHIFT+ESC for 4 seconds.
Last edited by eLe|Subjugator; Mar 5, 2013 @ 1:06pm
Showing 1-15 of 21 comments
< >
BashYou Mar 11, 2013 @ 9:42am 
same here...
Don Mar 11, 2013 @ 10:01am 
bump
dwi Mar 11, 2013 @ 12:11pm 
Same here, annoying as hell, cant even play correctly :( Please someone, fix this
IHateYourMom Mar 11, 2013 @ 12:50pm 
+1
This 'bonk' drives me mad (╯°□°)╯ ︵ ┻━┻
NarWhaLs15 Mar 11, 2013 @ 7:10pm 
I have the same problem, and am thankful that I'm not the only one.

It's similar to the Emacs "end-of-buffer" noise. I have a mid-2010 Macbook Pro running Mountain Lion. This is my second session after the most recent update. I noticed the noise after my first trial and shut down first the game, then Steam, then my computer, all to no avail.

I checked to make sure all keys are mapped to functions, and they are. I also messed around with my sound settings and nothing changes, regardless of how loud the game is. Just trying to shed some light on the situation--is anyone's setup similar to mine?
Last edited by NarWhaLs15; Mar 11, 2013 @ 7:11pm
Andonis414C50 Mar 11, 2013 @ 7:27pm 
Got the same issue. I'm able to play normally except for the sound playing every time I hit a key. Running an early 2011 MacBook Pro with Lion.
NarWhaLs15 Mar 11, 2013 @ 7:38pm 
Yes, I'm also able to play normally except for the incredibly annoying sound.

I love this game though! Except for the sound.
Last edited by NarWhaLs15; Mar 11, 2013 @ 7:39pm
Je'dah Mar 11, 2013 @ 7:51pm 
I too am getting the alert sound effect every time I press a key. OS X 10.6.8 Temporary solution, lower the alert volume to nothing while the game is running, turn it back on when done. Still though, this definitely needs to be fixed.
NarWhaLs15 Mar 11, 2013 @ 8:15pm 
How do you lower alert sound?
NarWhaLs15 Mar 11, 2013 @ 8:16pm 
Never mind. Thank you!
peterrainesss4 Mar 11, 2013 @ 9:20pm 
Same here!
NoisekillerEXE Mar 11, 2013 @ 9:21pm 
the same things happening to me. i played the game successfully yesterday with no problems, now today i keep hearing the bonk for my whole qwerty keyboard leaving me with a massive headache. i hope they patch this really soon :'( its one of the best free to play games on mac and its so much fun
dwi Mar 12, 2013 @ 5:48am 
New update a while ago and this fraking annoying issue is still not fixed? Does any dev know about this?
MrBit Mar 12, 2013 @ 9:12am 
having same problem its well annoying
TwofishBluefish Mar 12, 2013 @ 9:26am 
same issue. it started after downloading an update on monday. no change after another small update today (tuesday). mac os 10.6.8
Showing 1-15 of 21 comments
< >
Per page: 15 30 50
Date Posted: Mar 5, 2013 @ 1:05pm
Posts: 21