PF.PilotA256 Nov 23, 2013 @ 7:56am
Anyone else have issues with star conflict not connecting?
I seem to be having issues lately with Star Conflict not connecting at the same time every day, usually about 5pm GMT (with the exception of today, Saturday, when I haven't been able to connect at all). It is an issue with the RU servers for me, if I can login and select EU servers it's fine, but otherwise I can't. If I'm playing on an RU server I get a massive ping, then the chat server connection is lost, then I get booted with a network error.
I posted a message on the SC forum to be told it's an issue with my ISP, and when I went to my ISP (BT) they said it's an issue with SC. Interestingly enough, I can't connect to their forums whilst I can't connect to the game.
Pingplotter says it is basically major packet loss en route to their servers (Main01av-ru.star-conflict.com).
Anyone know if there is a way to fix this, and whos fault this is for that matter? Don't even know whether I need to be bugging Star Conflict or BT for a solution at the moment!
Also, anyone actually have the same issue?

Thanks,

Anthony :)
Showing 1-7 of 7 comments
< >
nightmare_k Nov 23, 2013 @ 8:02am 
it's a glinch from steam just restart you're steam.
PF.PilotA256 Nov 23, 2013 @ 8:11am 
Thanks, but unfortunately I still get the same issue for some reason even after both restarting steam; and doing a logout, closing steam and logging back in again.
I did have a glitch yesterday though with Dota 2 not connecting, so it's a solution which I should definately keep in the back of my mind for my other games!

Anthony :)
NotKipps Nov 23, 2013 @ 9:59am 
Im exactly the same (Also with BT as my ISP)
Somewhere along the lines from Bt to Real Time Network the connection is dodgy around peak times
khanser Nov 24, 2013 @ 4:29am 
Same here (also using BT), but when this happens www.star-conflict.com webpage it's also lagging like hell, not just the game. I think it's a major issue of BT, I've got spanish friends that can play without problems while i can't even make it to the lobby.
Last edited by khanser; Nov 24, 2013 @ 4:31am
PF.PilotA256 Nov 24, 2013 @ 5:36am 
Originally posted by khanser:
Same here (also using BT), but when this happens www.star-conflict.com webpage it's also lagging like hell, not just the game. I think it's a major issue of BT, I've got spanish friends that can play without problems while i can't even make it to the lobby.

Yup, I also find the website gets really slow for me as well. Must be BT as you say.
PF.PilotA256 Nov 24, 2013 @ 7:23am 
In a 'live chat' with BT at the moment about the issue, still haven't actually got to tech support yet, being asked how I am related to the account holder...
But I'll tell you how it goes and whether I get any information as to why/how to fix!
SkyRobo1 Nov 25, 2013 @ 11:15am 
Recently downloaded this game (6 pm gmt) And when I logged in using steam it tells me "Connection to Server Failed" and for some reason when I try to go to their actual website it lags like hell...
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Nov 23, 2013 @ 7:56am
Posts: 7