Starbound > General Discussions > Topic Details
JpVicVega Dec 5, 2013 @ 1:49pm
REPOST OF LOW FPS FIX THIS WORKED FOR ME
FPS (Frames Per Second) Fix, Windows 7
Hello. Just wanted to share my fix for fps issues I was having in Starbound. I use an Nvidia Card (GTX 470, latest driver 331.93), 64bit OS, Windows 7.

1st: Resolving Compatibility Mode process confliction instead of right clicking the game's .exe to do it:

At desktop. (I shut down Steam prior to doing this step). Just copy and paste the following to clipboard for reference.

Hit Start (lower Left of screen), in the space provided, type in regedit

Left click or press Return

Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Look for a entry with your path to steam.exe
Highlight the entry and Delete it

IF you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Delete the Steam.exe in there and Delete

Click Ok


2nd: Nvidia Control Panel settings (right click on desktop to access). Click Manage 3D Settings, Left side of screen

Ambient Occlusion: Off
Anisotropic Filtering: Application Controlled
Antialiasing- FXAA: Off
Antialiasing Gamma Correction: On
Antialiasing-Mode: Application Controlled
Antialiasing-Setting: Application Controlled
Antialiasing-Transparency: Off
CUDA-GPU's All
Maximum pre-rendered frames: Use the 3D application setting
Multi-display/mixed-GPU acceleration: Single display performance mode (if you use 2 monitors, set this to multiple display)
Power Management Mode: Adaptive
Texture Filtering- Anisotropic sampling: Off
Testure Filtering- Negative LOD Bias Allow
Texture Filtering-Quality Quality
Texture Filtering-Trilinear Off
Threaded Optimization: Auto
Triple Buffering: Off
Verticle Sync Off

Click Apply

3rd
Enjoy playing Starbound smoothly and without slowdown.

Hope this may help some people out there. -Thanks to ZeroHour over at Edugeek site for the Steam compatibility issue fix-
If you are using an AMD/Radeon based card and having fps issues, settings above should be pretty much the same within the AMD/Radeon Panel.
Showing 1-15 of 44 comments
< >
Kolbear Dec 5, 2013 @ 2:31pm 
BUMP FOR GREAT JUSTICE, THIS WORKS!

I don't have nvidia graphic card, but doing the 1st part deleting the file in the regedit fixed the lag / stutter / bad fps.
Last edited by Kolbear; Dec 5, 2013 @ 2:32pm
Amber ♥ Dec 5, 2013 @ 2:43pm 
Originally posted by JpVicVega:
IF you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Delete the Steam.exe in there and Delete

This did it for me, finally it's playable!

Ty very much
Lovin_Dat_MC Dec 5, 2013 @ 2:52pm 
I did both and neither worked for me, and i have a GTX 630 (don't know the rest of my specs)
Solarstrike Dec 5, 2013 @ 2:58pm 
Originally posted by Kolbear:
BUMP FOR GREAT JUSTICE, THIS WORKS!

I don't have nvidia graphic card, but doing the 1st part deleting the file in the regedit fixed the lag / stutter / bad fps.

Glad this is helping people play Starbound. I posted the original thread here: http://steamcommunity.com/app/211820/discussions/0/648813576320331234/
Linebrell Dec 5, 2013 @ 3:13pm 
Don't work for me( I can laucn dota2, but terraria/starbound are running slow.
Trey Dec 5, 2013 @ 3:28pm 
This didnt really work for me, still, 95% of my CPU usage is being used.

I have 8GB
and
NVIDIA GTX 560
Wanakilo Dec 5, 2013 @ 3:37pm 
What exactly is the name of the entry you have to delete? I have several steam related entries and dont know which one to delete, and they all lead to different unrelated games. Like the bioshock and fallout and GTA steam folders.
The 4winds Dec 5, 2013 @ 4:45pm 
At the end it should say steam.exe. And thanks for this! I can play now!
mr.nerro Dec 6, 2013 @ 10:44pm 
What if ive accidentally deleted the registry file? (steam.exe)
Lheathal™ Dec 9, 2013 @ 5:52pm 
Originally posted by JpVicVega:
FPS (Frames Per Second) Fix, Windows 7
Hello. Just wanted to share my fix for fps issues I was having in Starbound. I use an Nvidia Card (GTX 470, latest driver 331.93), 64bit OS, Windows 7.

1st: Resolving Compatibility Mode process confliction instead of right clicking the game's .exe to do it:

At desktop. (I shut down Steam prior to doing this step). Just copy and paste the following to clipboard for reference.

Hit Start (lower Left of screen), in the space provided, type in regedit

Left click or press Return

Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Look for a entry with your path to steam.exe
Highlight the entry and Delete it

IF you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Delete the Steam.exe in there and Delete

Click Ok


2nd: Nvidia Control Panel settings (right click on desktop to access). Click Manage 3D Settings, Left side of screen

Ambient Occlusion: Off
Anisotropic Filtering: Application Controlled
Antialiasing- FXAA: Off
Antialiasing Gamma Correction: On
Antialiasing-Mode: Application Controlled
Antialiasing-Setting: Application Controlled
Antialiasing-Transparency: Off
CUDA-GPU's All
Maximum pre-rendered frames: Use the 3D application setting
Multi-display/mixed-GPU acceleration: Single display performance mode (if you use 2 monitors, set this to multiple display)
Power Management Mode: Adaptive
Texture Filtering- Anisotropic sampling: Off
Testure Filtering- Negative LOD Bias Allow
Texture Filtering-Quality Quality
Texture Filtering-Trilinear Off
Threaded Optimization: Auto
Triple Buffering: Off
Verticle Sync Off

Click Apply

3rd
Enjoy playing Starbound smoothly and without slowdown.

Hope this may help some people out there. -Thanks to ZeroHour over at Edugeek site for the Steam compatibility issue fix-
If you are using an AMD/Radeon based card and having fps issues, settings above should be pretty much the same within the AMD/Radeon Panel.


Originally posted by Mr.nerro:
What if ive accidentally deleted the registry file? (steam.exe)
I have a intel graphis card how do i do it on there
Knight of Virtue Dec 9, 2013 @ 5:59pm 
Yeah, the registry fix seems to fix the low fps for most people and imo should be stickied.
Ragnar Dec 10, 2013 @ 2:15am 
Big thanks, now i can play!
tropen Dec 10, 2013 @ 4:12am 
I have WIndows 8 and when i get to the layers folder, i don't see any steam.exe file to delete? cam anyne help me?
RecklessDX Dec 10, 2013 @ 4:57am 
Originally posted by JpVicVega:
FPS (Frames Per Second) Fix, Windows 7
Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Look for a entry with your path to steam.exe
Highlight the entry and Delete it

IF you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Delete the Steam.exe in there

I searched in both but it wasnt there..
THE_M4CH1NE Dec 10, 2013 @ 5:13am 
Is all that really needed? I had huge fps problems. I just ran the launcher and .exe's as administrator and now no fps problems at all, 100% smooth. Maybe people should just try that first.
Last edited by THE_M4CH1NE; Dec 10, 2013 @ 5:16am
Showing 1-15 of 44 comments
< >
Per page: 15 30 50
Date Posted: Dec 5, 2013 @ 1:49pm
Posts: 44