Starbound > General Discussions > Topic Details
Cedoxi Dec 14, 2013 @ 8:13am
Error Join failed!!
so i have this problem since yesterday i bought the game for me and my friend and i portforwarded my port and everything but whenever he tries to join it says Join failed (my ip) port 20125 anyone found a solution for this? or im the only one to have this problem...?
Showing 1-15 of 26 comments
< >
Zyfie Dec 14, 2013 @ 8:20am 
Make sure he uses the right ip to connect and you've forwarded to the right ip.
You could use this[www.checkmyports.net] to check the correct forwarding.
Cedoxi Dec 14, 2013 @ 8:26am 
Originally posted by 天の使者:
Make sure he uses the right ip to connect and you've forwarded to the right ip.
You could use this[www.checkmyports.net] to check the correct forwarding.

hmm it say my port are closed and connection timed out but on the other program i downloaded it tells me my port are open...
Zyfie Dec 14, 2013 @ 8:28am 
I expect you use that program in your local network since the connection could not be established from outside.
What have you used to forward the port?
Cedoxi Dec 14, 2013 @ 8:30am 
Originally posted by 天の使者:
I expect you use that program in your local network since the connection could not be established from outside.
What have you used to forward the port?

i went typed my ipv4 adress in my search bar then i went to port forwarding and i did the same thing i did for my terraria server except the port were 20125 insted of 7777
Zyfie Dec 14, 2013 @ 8:32am 
For both TCP and UDP traffic?
May I ask your modem/router model?
deadering Dec 14, 2013 @ 8:34am 
Can you join your own server?
Cedoxi Dec 14, 2013 @ 8:35am 
Originally posted by 天の使者:
For both TCP and UDP traffic?
May I ask your modem/router model?

yep i did for both and the router model is a sagemcom f@st 2864
Cedoxi Dec 14, 2013 @ 8:35am 
Originally posted by deadering:
Can you join your own server?

yes i can join my own server
Zyfie Dec 14, 2013 @ 8:41am 
May you've got a firewall which is blocking the server? Windows got a build in one for example.

Also someone mentionen that certain firmwares have problems with forwarding.
You could also try to deactivate the forwarding and go with UPnP.
Cedoxi Dec 14, 2013 @ 8:47am 
Originally posted by 天の使者:
May you've got a firewall which is blocking the server? Windows got a build in one for example.

Also someone mentionen that certain firmwares have problems with forwarding.
You could also try to deactivate the forwarding and go with UPnP.

im gonna try without the firewall and hmmm i dont know what is UPnP :l
Zyfie Dec 14, 2013 @ 8:50am 
"One solution for NAT traversal, called the Internet Gateway Device Protocol (IGD Protocol), is implemented via UPnP. Many routers and firewalls expose themselves as Internet Gateway Devices, allowing any local UPnP control point to perform a variety of actions, including retrieving the external IP address of the device, enumerate existing port mappings, and add or remove port mappings. By adding a port mapping, a UPnP controller behind the IGD can enable traversal of the IGD from an external address to an internal client." - Wikipedia

In general it tells your device which port it should forward so you don't have to add a rule manually. The starbound server should try this in it's standard config. I'm not sure but it also could cause problems if you forward a port manually and some software tries to get it the other way.
Last edited by Zyfie; Dec 14, 2013 @ 8:50am
Cedoxi Dec 14, 2013 @ 8:55am 
Originally posted by 天の使者:
"One solution for NAT traversal, called the Internet Gateway Device Protocol (IGD Protocol), is implemented via UPnP. Many routers and firewalls expose themselves as Internet Gateway Devices, allowing any local UPnP control point to perform a variety of actions, including retrieving the external IP address of the device, enumerate existing port mappings, and add or remove port mappings. By adding a port mapping, a UPnP controller behind the IGD can enable traversal of the IGD from an external address to an internal client." - Wikipedia

In general it tells your device which port it should forward so you don't have to add a rule manually. The starbound server should try this in it's standard config. I'm not sure but it also could cause problems if you forward a port manually and some software tries to get it the other way.

wait that ''rule'' you talked about is it important? because i entered the rule name base1 in my router configuration since i didnt know what name i was supposed to use
Zyfie Dec 14, 2013 @ 8:57am 
The name shouldn't matter. Just the right port it forwards.
Cedoxi Dec 14, 2013 @ 8:58am 
Originally posted by 天の使者:
The name shouldn't matter. Just the right port it forwards.

in source port i typed 20125 and in destination port i typed the same thing
Zyfie Dec 14, 2013 @ 8:59am 
To your local pcs ip?
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: Dec 14, 2013 @ 8:13am
Posts: 26