Codename:Grey Fox Oct 31, 2012 @ 2:30pm
Game crashes at startup. [SOLVED]
Pretty much that. As soon as I click the game on Steam, it crashes with a generic windows error message. No further detail is given.

AMD Athlon 64 X2 5600+
Windows 7 Ultimate 64
Radeon HD 4890

Anyone has any ideas?

Edit: Checked the event viewer:

Source: .NET Runtime

Application: Shuggy.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileLoadException
Stack:
at Shuggy.Program.Main(System.String[])

Source: Application error

Faulting application name: Shuggy.exe, version: 1.10.0.0, time stamp: 0x508a5e44
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319
Exception code: 0xe0434352
Fault offset: 0x0000b9bc
Faulting process id: 0xc14
Faulting application start time: 0x01cdb7affc7bc8d8
Faulting application path: C:\Jogos\Steam\steamapps\common\Adventures Of Shuggy\Shuggy.exe
Faulting module path: H:\Windows\syswow64\KERNELBASE.dll
Last edited by Codename:Grey Fox; Nov 1, 2012 @ 4:09pm
Showing 1-13 of 13 comments
< >
SmudgedCat  [developer] Nov 1, 2012 @ 2:47am 
That seems like a file is missing from the game. I'd recommend uninstalling and trying to install again.
Codename:Grey Fox Nov 1, 2012 @ 2:56am 
Thanks for the reply. Already tried it. 3 times =(
SmudgedCat  [developer] Nov 1, 2012 @ 12:35pm 
Hmmm, I'm not sure what else that could be. I suspect it might be to do with Windows being installed on H: but the game being on C:, I'm not sure exactly what's going on though. Can you send an email to support@smudgedcat.com please!
Codename:Grey Fox Nov 1, 2012 @ 4:09pm 
Solution found!

Go to your windows folder and then right click the Microsoft.NET folder and go to properties.

There go to security, then click advanced, go to the owner tab and click edit. Choose yourself as the current owner and be sure to check the "Replace owner on subcontainers and objects". Press OK, and you are done!
mega5010 Nov 25, 2012 @ 1:26pm 
Just got this during the sale and continually stops working. Tried what you posted above with no luck. It's a shame because the game seems pretty fun.
Codename:Grey Fox Nov 25, 2012 @ 2:08pm 
http://www.terrariaonline.com/threads/game-doesnt-start-no-crashlog.74569/

I got my solution from there. Maybe there's something to help you too?
Last edited by Codename:Grey Fox; Nov 25, 2012 @ 2:53pm
SmudgedCat  [developer] Nov 26, 2012 @ 6:15am 
What error message do you get when the game stops working?
mega5010 Nov 26, 2012 @ 7:09am 
It's a simple "Shuggy has stopped working and Windows is looking for a solution to the problem". I'm able to restart it and keep it going, but I never get more than about a level (or five, six minutes in) before it craps out on me. I'm running it on a laptop, Toshiba Satellite C655. I know it's not the most adequate for gaming, but it seems to run fine up until a certain point.

Also scanned that thread you posted, it's all gibberish to me - ha! I'm computer literate, but that stuff is a bit more advanced.
SmudgedCat  [developer] Nov 27, 2012 @ 11:07am 
Can you have a look at the Windows event log (it's under control panel, might be under 'administrative tools' depending on what Windows you're running) and find an entry for Shuggy. If you could send the details in there to support@smudgedcat.com that'd be great!
Doc Apr 6, 2013 @ 10:46am 
I sent in my error messages from Windows event log! I am having a similar problem (identical, in fact) to mega5010. It's a shame because I'm enjoying the game... just not for very long.
If it helps, every time this happens, Steam says it's "synching" before I can do anything else. This happens every time it crashes and it takes 1-2 seconds for that to finish. I can't open Shuggy while it's doing this.
Doc Apr 6, 2013 @ 11:24am 
Problem Event Name: APPCRASH
Application Name: Shuggy.exe
Application Version: 1.10.0.0
Application Timestamp: 508a5e44
Fault Module Name: unknown
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 170c60cf
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 1033

This popped up when it crashed as the listed error message, if that helps with anything.
Doc May 29, 2013 @ 9:50am 
I got a new computer recently, and the game hasn't crashed yet. Whatever the problem was, my new machine does not have it.
bonesnatch Apr 21 @ 7:11pm 
I installed MS XNA Framework 4.0 and it fixed the errors I had
Showing 1-13 of 13 comments
< >
Per page: 15 30 50