Peroxide Mar 11, 2013 @ 12:13am
Unable to use Xbox 360 Controller
I read a post where someone mentioned the game having issues with the controller due to the vibration. I tried to disable vibration, but I get the same error upon exiting the options. I couldn't find any other information regarding this, so figured I'd post.

https://www.dropbox.com/s/oiht8sw4t9jt0ln/shuggy.png
http://imgur.com/NhSSNkX (Dropbox link wasn't working when I replied)

There's the error, any solutions?
Last edited by Peroxide; Mar 11, 2013 @ 4:23pm
Showing 1-4 of 4 comments
< >
SmudgedCat  [developer] Mar 11, 2013 @ 6:27am 
Do you have any other devices plugged into your PC that might be taken as controller 1? What player number does the controller come up as? (ie. which quadrant lights up round the guide button?)
Peroxide Mar 11, 2013 @ 4:18pm 
Only other devices are my mouse and keyboard and it shows up as controller #1 when it's plugged in.

I was receiving random crashes even without the controller being plugged in and it gave me the same error so I'm really confused as to what's causing it now.
Peroxide Mar 11, 2013 @ 7:26pm 
I started thinking perhaps the drivers were corrupt and I remembered that I had installed a patch for Xinput that permanently disabled vibration due to a game that didn't allow you to choose.

After replacing the patched version with the original, I no longer experience the error while leaving the Options and was actually able to play a level so I believe that must have been the cause.

I assume the game relies on whatever was patched out so in case you wanted to look into it, here is the patched xinput1_3.dll.

https://dl.dropbox.com/u/38390200/xinput1_3%20-%20patched.dll
Last edited by Peroxide; Mar 11, 2013 @ 7:27pm
SmudgedCat  [developer] Mar 12, 2013 @ 2:21am 
Great, glad you got it fixed. Thanks for that DLL, I'll have a look at what's making it throw that error.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50