Adam Jul 17, 2013 @ 8:53am
Can't get AA (anti-aliasing) to work with DSfix.
Hi,

Just to confirm: I have DSfix 2.0.1 installed. I have disabled the in-game AA option and I have edited the DSfix .ini file to add AA (I've tried multiple settings, ranging from 0-4, I've also tried switching from SMAA to FXAA etc).

Regardless of what I try, I still get really bad jaggies in game. There is no noticeable difference between 0 and 4 on the DSfix AA settings.

Does anyone have any idea as to what might be causing the problem? It doesn't seem to be particularly widespread because I can find hardly anyone else with the same problem. My GPU is an AMD HD 6950 2gb.

Thanks.
Last edited by Adam; Jul 17, 2013 @ 8:54am
Showing 1-15 of 16 comments
< >
gl1tch Jul 17, 2013 @ 9:03am 
Chances are low, but it could be the FPSthreshold setting, which will dynamically disable AA if your FPS are low. There's not much explanation to the setting, but try setting it to 0. Maybe it's malfunctioning.
Adam Jul 17, 2013 @ 9:07am 
Originally posted by gl1tch:
Chances are low, but it could be the FPSthreshold setting, which will dynamically disable AA if your FPS are low. There's not much explanation to the setting, but try setting it to 0. Maybe it's malfunctioning.

I tried turning it to 1 instead of 28 because I thought the threshold might be detecting 2 frames off or so, but I haven't tried turning it to 0 yet - will do now, thanks.

EDIT: Doesn't seem to work either, unfortunately.
Last edited by Adam; Jul 17, 2013 @ 9:11am
gl1tch Jul 17, 2013 @ 9:37am 
Have you made comparison screenshots? If so, I'd like to see those.
Adam Jul 17, 2013 @ 9:44am 
Originally posted by gl1tch:
Have you made comparison screenshots? If so, I'd like to see those.

Sure thing, I'll do it now.
Adam Jul 17, 2013 @ 10:01am 
With SSAA (Ultra):

http://imgur.com/a/ZNWzB

Without any AA:

http://imgur.com/a/wW2si

(Oh yeah, remember to look at the images in their full resolution so you don't get a super-sampling-like effect).

You should see no noticeable difference (unless my eyes are deceiving me...) Unfortunately the ♥♥♥♥ty JPEG compression makes it hard to see.
Last edited by Adam; Jul 17, 2013 @ 10:11am
GeForce Jul 17, 2013 @ 10:12am 
I couldn't make anti aliasing work as well. I tried dozens of combinations on DSFix settings but there is no difference.
I managed to apply MLAA but it causes random FPS drops.
Adam Jul 17, 2013 @ 10:14am 
Originally posted by GeForce:
I couldn't make anti aliasing work as well. I tried dozens of combinations on DSFix settings but there is no difference.
I managed to apply MLAA but it causes random FPS drops.

I see. What did you use to apply MLAA? I'm guessing it was the nVidia control panel/CCC or something. Can't get my CCC to force AA either.
GeForce Jul 17, 2013 @ 10:18am 
Not sure but probably it was CCC. You can try RadeonPro as well.
Adam Jul 17, 2013 @ 10:23am 
Originally posted by GeForce:
Not sure but probably it was CCC. You can try RadeonPro as well.

Will try RadeonPro as well, thanks.
Adam Jul 17, 2013 @ 10:53am 
Yeah MLAA works but it makes everything else look terrible. Oh well, think I might just give up.
nightwolf Jul 17, 2013 @ 9:26pm 
!!!FIXED!!!
I had jaggies no matter what settings i used in DSfix. FXAA or SMAA, quality 0-4...no change...

Kept wondering if the dynamic AA threshold was causing my lack of AA so set it to zero and now no more jaggies.

# FPS threshold
# DSfix will dynamically disable AA if your framerate drops below this value
# and re-enable it once it has normalized (with a bit of hysteresis thresholding)
FPSthreshold 0

i suspect maybe MSI afterburner was the issue but untested.
Adam Jul 18, 2013 @ 1:17am 
Originally posted by nightwolf:
!!!FIXED!!!
I had jaggies no matter what settings i used in DSfix. FXAA or SMAA, quality 0-4...no change...

Kept wondering if the dynamic AA threshold was causing my lack of AA so set it to zero and now no more jaggies.

# FPS threshold
# DSfix will dynamically disable AA if your framerate drops below this value
# and re-enable it once it has normalized (with a bit of hysteresis thresholding)
FPSthreshold 0

i suspect maybe MSI afterburner was the issue but untested.

I'm glad you've got it working. Unfortunately that was one of the first things I tried and it still isn't working. I'm wondering now if it's got something to do with a conflicting setting in the .ini.
GeForce Jul 18, 2013 @ 2:18am 
I tried setting FPSThreshold to 0, worked for me as well!
Adam Jul 18, 2013 @ 2:22am 
I'm starting to think it's something wrong with my PC now! Grr. I have no idea why it still doesn't work for me.
dopeboy Jul 22, 2013 @ 2:42am 
i have the same problem and nothing has worked, fps threshold, forcing it through nvidia or other controllers, even trying to apply sweetfx aa filters. it drives me crazy
Showing 1-15 of 16 comments
< >
Per page: 15 30 50
Date Posted: Jul 17, 2013 @ 8:53am
Posts: 16