TheJediWookie Jan 3, 2013 @ 11:15am
FPS drops from a constant 30 to 15 randomly for a few seconds
Applied the DSFix and all seems to be working well, although I've not unlocked the game to 60 fps yet. I seem to be getting weird glithches for a few seconds where my frame rate is cut in half from a constant 30 fps to 15 fps. I'm running on a Radeon 5750 (pretty meh I know) at 1920x1080, with 4gb ram, i7 at 3ghz, plenty of HDD space, etc.
Has anyone else noticed this and if so is there anyway to stop it happening?
Showing 1-8 of 8 comments
< >
I BLESS THE RAINS DOWN IN AFRICA Jan 3, 2013 @ 11:18am 
Same with me and for some reason it seems to happen more now than before. If I bring up the menu it sometimes instantly goes back to 30 and stays until another 10-15mins and does it agin.
TheJediWookie Jan 3, 2013 @ 11:19am 
Oh well at least I'm not alone. I'm going to disable the steam overlay and see if that helps. I'll let you know if it does.
Puppymang Jan 3, 2013 @ 12:09pm 
try enabling 60fps with the latest dsfix also disable things like MSAA and SSAO
what hard drive are you using?
also the 30 to 15 is because of particles, im using HD 5770 and particles kill the fps but enabling 60fps helps keep it above 30 at all times
Last edited by Puppymang; Jan 3, 2013 @ 12:10pm
TheJediWookie Jan 3, 2013 @ 12:09pm 
Disabling the steam overlay did not help. Any other ideas anyone?
TheJediWookie Jan 3, 2013 @ 12:09pm 
Doesn't the 60fps thing get you banned from xbl though?
Puppymang Jan 3, 2013 @ 12:10pm 
no it doesnt, ive been using 60fps for a while now
its fairly stable nowadays but keep in mind th enable/disable key for it is the backspace key by default so you may wanna add a "#" on dsfixkeys.ini for that function

the only major downside to the 60fps mod is that it messes with vsync so you may get heavy screen tearing
hope you have some way to force vsync, i use d3doverride from rivatuner
if this makes your game crash whenever you alt tab use borderless fullscreen
Last edited by Puppymang; Jan 3, 2013 @ 12:12pm
TheJediWookie Jan 3, 2013 @ 12:12pm 
Thanks, I'll give it a try now.
TheJediWookie Jan 3, 2013 @ 12:26pm 
Unlocking to 60fps did it, thanks a lot, no more weird frame rate drops. I can't believe how much better this plays than the 360 version.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jan 3, 2013 @ 11:15am
Posts: 8